Support » Plugin: Elementor Website Builder » Elementor is not working with the latest wordpress version 5.5

  • Resolved adanbody

    (@adanbody)


    After installing the latest version in WordPress 5.5, all of my pages created with Elementor are presenting issues: it all looks BLANK for most of them and some other pages are not showing images…

    I know this is a general issue affecting a lot of users right now based on what I’ve read in the comments, but what I would like to know is if someone at the Elementor team is already working on fixing this? (per all of the comments I’ve read, the Elementor team is asking to upload to the latest version of elementor, unstall other pluggings etc.. but I haven’t read yet any acknowledge of the issue and anything like “we’re working on fix the issue”).

    I’m using the latest version of Elementor 2.9.14 and its obvious it isn’t compatible yet with WordPress 5.5, so is someone at Elementor working on this yet?
    any suggestions that doesn’t compromise the aesthetics of my website?

    thanks in advance for your help on this!
    looking forward for your reply
    regards,

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • With what I’ve seen so far, the reason for suggesting things like conflict testing, updating to the latest version of Elementor, etc, is that Elementor itself isn’t going kaboom if the latest version is active.

    As it is right now, if I try using just Elementor on a site with a base theme (Twenty Twenty), it’s working properly.

    As for something to try that doesn’t compromise the look of your site… when I look in my browser’s error console (I’m looking at your site’s homepage), I see this:

    Uncaught Error: Syntax error, unrecognized expression: a[href*=#]:not([href=#])
        at Function.ea.error (jquery.js?ver=1.12.4-wp:1)
        at ea.tokenize (jquery.js?ver=1.12.4-wp:1)
        at ea.select (jquery.js?ver=1.12.4-wp:1)
        at Function.ea [as find] (jquery.js?ver=1.12.4-wp:1)
        at n.fn.init.find (jquery.js?ver=1.12.4-wp:1)
        at new n.fn.init (jquery.js?ver=1.12.4-wp:1)
        at n (jquery.js?ver=1.12.4-wp:1)
        at HTMLDocument.<anonymous> (custom.js?ver=1.0:2)
        at i (jquery.js?ver=1.12.4-wp:1)
        at Object.fireWith [as resolveWith] (jquery.js?ver=1.12.4-wp:1)

    That “custom.js” file comes from the AccessPress Parallax Pro theme. Assuming that this file is the cause, you’d need to contact your theme’s support team (Pro products aren’t supported in the WP.org forums).

    If that isn’t the cause, the only other immediately obvious culprit would be RevSlider (your site’s running 6.1.8, and the latest version, 6.2.19, has been updated to account for WP 5.5).

    Failing any of that, I wouldn’t have an answer that wouldn’t temporarily compromise the aesthetic of the site (i.e. conflict testing). Doing it at a time when the site’s least busy would be the best that could be done.

    (not something I’d love to do on my own site, but then with weighing long-term kaboom vs. short term outage by putting up a maintenance mode page momentarily and doing conflict testing… I’d choose the latter option)

    Hopefully, this long post helps you @adanbody, ideally by getting you peace of mind sooner than later.

    Thread Starter adanbody

    (@adanbody)

    Hello, thanks a lot for your help on this, I also did a lot of research on my end and found this plugin (it is a life saver and solved all of my problems with the new WP 5.5 version, I strongly recommend everyone to install it: https://es.wordpress.org/plugins/enable-jquery-migrate-helper/

    I also sent the errors found to my theme developer and I’m hopping this helps them

    problem solved ๐Ÿ™‚

    Glad to hear that it’s resolved! ๐Ÿ™‚

    I’ve seen that plugin help in certain situations too, good to know it was useful here as well.

    The plugin worked for me too. The weird thing was that my pages looked fine when I was logged in, working on the site. As soon as I logged out of the administrator, anything that had an animation applied would just disappear. My theme is OceanWP.

    At the description of the plugin, it’s said:
    This plugin serves as a temporary solution, enabling the migration script for your site to give your plugin and theme authors some more time to update, and test, their code.

    writeherewritenow59

    (@writeherewritenow59)

    This just helped me too. Thanks. I’ll post the info on the elementor facebook page!

    Hi, I’m having the same issue with my website after installing wp 5.5….can anybody help? I am quite desperate

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.