Support » Plugin: Void Contact Form 7 Widget For Elementor Page Builder » elementor is not defined

  • Resolved yuvvraaj

    (@yuvvraaj)


    when I use this plugin in following theme https://qik.radiantthemes.com/vpn/

    I am getting following error in console.

    void-cf7-elementor-editor.js?ver=1.0.0:115 Uncaught ReferenceError: elementor is not defined
    at void-cf7-elementor-editor.js?ver=1.0.0:115
    at dispatch (jquery.js?ver=1.12.4-wp:3)
    at r.handle (jquery.js?ver=1.12.4-wp:3)
    at Object.trigger (jquery.js?ver=1.12.4-wp:3)
    at Object.a.event.trigger (jquery-migrate.min.js?ver=1.4.1:2)
    at jquery.js?ver=1.12.4-wp:3
    at Function.each (jquery.js?ver=1.12.4-wp:2)
    at a.fn.init.each (jquery.js?ver=1.12.4-wp:2)
    at a.fn.init.trigger (jquery.js?ver=1.12.4-wp:3)
    at Frontend.init (frontend.min.js?ver=2.9.14:2)

    JS file name: void-cf7-elementor-editor.js
    line no 115

    is it theme issue or plugin issue?

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Contributor voidcoders

    (@voidcoders)

    Hi,

    We are looking into this, thanks for letting us know. May I know if you clear your browser cache does it help?

    cipriann

    (@cipriann)

    Hi.
    We have the same problem at: https://www.baar.ro/info-certificat-de-daunalitate/
    The accordeon is not working.
    With Inspect in Chrome we get the following errors:

    frontend.min.js?ver=1.1.6:408 Uncaught TypeError: Cannot read property ‘querySelector’ of null
    at cbpHorizontalSlideOutMenu._init (frontend.min.js?ver=1.1.6:408)
    at new cbpHorizontalSlideOutMenu (frontend.min.js?ver=1.1.6:398)
    at frontend.min.js?ver=1.1.6:499
    at frontend.min.js?ver=1.1.6:501
    at frontend.min.js?ver=1.1.6:503

    void-cf7-elementor-editor.js?ver=1.0.0:115 Uncaught ReferenceError: elementor is not defined
    at void-cf7-elementor-editor.js?ver=1.0.0:115
    at dispatch (jquery.js?ver=1.12.4-wp:3)
    at r.handle (jquery.js?ver=1.12.4-wp:3)
    at Object.trigger (jquery.js?ver=1.12.4-wp:3)
    at Object.a.event.trigger (jquery-migrate.min.js?ver=1.4.1:2)
    at jquery.js?ver=1.12.4-wp:3
    at Function.each (jquery.js?ver=1.12.4-wp:2)
    at a.fn.init.each (jquery.js?ver=1.12.4-wp:2)
    at a.fn.init.trigger (jquery.js?ver=1.12.4-wp:3)
    at Frontend.init (frontend.min.js?ver=2.9.14:2)

    It happened when updating the plugins. I tried to deactivate it one by one, but still not working.

    I deactivated the Elementor Addons & Templates – Sizzify Lite.

    Also, I did rollback to Elementor plugin to a few previous versions. Still not working.

    Is there any solution?

    Thank you!

    smswerbetechnik

    (@smswerbetechnik)

    Hi. We have the same problem here on

    https://www.sms-werbetechnik.de/produkte/bannerrahmen/werbelifter/

    Full width stretching is not working. Precise error:

    at void-cf7-elementor-editor.js?ver=1.0.0:115
    at dispatch (jquery.js?ver=1.12.4-wp:3)
    at r.handle (jquery.js?ver=1.12.4-wp:3)
    at Object.trigger (jquery.js?ver=1.12.4-wp:3)
    at Object.a.event.trigger (jquery-migrate.min.js?ver=1.4.1:2)
    at jquery.js?ver=1.12.4-wp:3
    at Function.each (jquery.js?ver=1.12.4-wp:2)
    at a.fn.init.each (jquery.js?ver=1.12.4-wp:2)
    at a.fn.init.trigger (jquery.js?ver=1.12.4-wp:3)
    at Frontend.init (frontend.min.js?ver=2.9.8:2)
    main.js?ver=4.2.4:1 Uncaught Error: Uncaught ReferenceError: elementor is not defined – https://www.sms-werbetechnik.de/wp-content/plugins/cf7-widget-elementor/custom-editor/assets/js/void-cf7-elementor-editor.js?ver=1.0.0: 115
    at Object.error (main.js?ver=4.2.4:1)

    It does work though in the elementor editor itself.

    smswerbetechnik

    (@smswerbetechnik)

    I believe I found the reason for the plugin failing.

    There is an additional plugin downloadable for Elementor which is called
    “Void Contact Form 7 Widget For Elementor Page Builder” by voidCoders which create the error in Elementor. As soon as I disable this plugin everything works as expected.

    There was an update for this plugin lately so the reason is probably located there.

    Could you confirm this @yuvvraaj and @cipriann?

    cipriann

    (@cipriann)

    I deinstalled The Void …. plugin. It still does not work.
    I had to put all the text in the page, and keep only three small accordeon, to check it in the future.

    smswerbetechnik

    (@smswerbetechnik)

    After I emptied my browser cache I have the total disaster going on and cannot even use the editor at all.

    I get this error message.

    Love using Elementor? Join our growing community of Elementor developers: https://github.com/elementor/elementor
    editor.min.js?ver=2.9.14:7 Uncaught DOMException: Blocked a frame with origin “https://www.sms-werbetechnik.de” from accessing a cross-origin frame.
    at Editor.onPreviewLoaded (https://www.sms-werbetechnik.de/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.9.14:7:58831)
    at Editor.onPreviewLoaded (https://www.sms-werbetechnik.de/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.9.14:31:219893)
    at HTMLIFrameElement.dispatch (https://www.sms-werbetechnik.de/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp:3:12369)
    at HTMLIFrameElement.r.handle (https://www.sms-werbetechnik.de/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp:3:9088)

    yeshai

    (@yeshai)

    Had the same issue on a client website. Broke many Elementor components – animations, counters & sliders stopped working, images in archives misplaced. Disabling Void Contact Form 7 Widget For Elementor Page Builder solved all issues.

    yuvvraaj

    (@yuvvraaj)

    @voidcoders no I clear browser cache, I check in incognito mode of chrome, firefox but same issue

    yuvvraaj

    (@yuvvraaj)

    @smswerbetechnik currently I am using Void Contact Form 7 Widget For Elementor Page Builder Version 1.1.0 and
    WordPress version 5.4.2 and
    Elementor – 2.9.14
    Currently this plugin I have de-activated.

    • This reply was modified 3 months ago by yuvvraaj.
    Plugin Contributor voidcoders

    (@voidcoders)

    We have already released a fix for this issue on version 1.1.1. Please update to the latest version and it should fix the issue.

    yuvvraaj

    (@yuvvraaj)

    @voidcoders yes issue is resolved thank you

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.