Support » Plugin: Rank Math SEO – Best SEO Plugin For WordPress To Increase Your SEO Traffic » Elementor Gallery and images in sitemap.xml

  • Resolved dirkbeckersbe

    (@dirkbeckersbe)


    It seems that the Elementor gallery doesn’t output the images to the sitemap.xml

    Is this a known bug?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Rank Math

    (@rankmath)

    Hello @dirkbeckersbe

    Thank you for contacting the support.

    The gallery widgets are working perfectly fine. Here is a video screencast for you:
    https://i.rankmath.com/9gInqv

    If it’s not working or if there are any other steps to reproduce, please let us know.

    Also, assuming you are using the latest version of all the plugins and the themes (please update if not yet), it would seem like a conflict with one of the plugins or the theme you are using.

    To determine that, please follow this troubleshooting guide:
    https://rankmath.com/kb/check-plugin-conflicts/

    Only the site admin would know and your users won’t be affected by this troubleshooting.

    Looking forward to helping you.

    Thread Starter dirkbeckersbe

    (@dirkbeckersbe)

    It’s not the “Basic Elementor Gallery or the WordPress Gallery”
    I’m using the Elementor Gallery!

    There are 2 different Gallery widgets in Elementor…

    That one is not working with Rank Math
    Thanks

    Plugin Author Rank Math

    (@rankmath)

    Hello @dirkbeckersbe

    In the Elementor Gallery widget, images are used as a background: https://i.rankmath.com/2B0FEp

    Images that are used as a background are not considered in the calculations or in the Sitemaps.

    This is something you can raise with the Elementor’s team if they want to change the behavior, otherwise, there are 2 other gallery widgets in their plugin that you can use and they will be correctly recognized by the Rank Math plugin.

    Hope that clears the confusion. Thank you.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Elementor Gallery and images in sitemap.xml’ is closed to new replies.