Support » Plugin: LiteSpeed Cache » Elementor Exclude a CSS Class

  • Resolved reachdigital

    (@reachdigital)


    Hi,

    Is it possible to exclude a particular css class added to a widget/section in Elementor.
    My current issue is that for some reason, my footer social logos lose spacing when caching is on.

    I do have a div with a class “social-footer-icons” which I could exclude if possible.

    Here is the div with this class https://nimb.ws/4PZLwv

    Any ideas would be appreciated.

    Thank you

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support qtwrk

    (@qtwrk)

    Hi,

    is that inline CSS ? or inside of certain CSS file ?

    Also please check if you have enabled CSS minify , CSS combine , and HTML minify ?

    Best regards,

    Thread Starter reachdigital

    (@reachdigital)

    Hi @qtwrk

    I believe the CSS is created within Elementor and creates a files like post-11.css (https://www.reachdigital.com.au/wp-content/uploads/elementor/css/post-11.css) , so it not inline. Im not sure which one holds the social icons, that is why I wonder if you can exclue via a class and not a whole css file/url.

    I have deactivated LS Cache and they now come up as intend with spacing, you can see here https://nimb.ws/ofqOVD and on teh site https://www.reachdigital.com.au/

    I just updated to Version 3.5.2 of LiteSpeed Cache also.

    Thank your or your help.

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    Sadly no , can not exclude by class

    could you please try disable HTML minify if you have it enabled ?

    I also got a case where the social icon was separated to each other by using white space in HTML code , so in that case with HTML minify on , the white space is removed and caused issue , maybe you are in same case

    Best regards,

    Thread Starter reachdigital

    (@reachdigital)

    Hi @qtwrk ,

    Yes, turning OFF HTML minify , fixes this issue.

    Do you think this is something you will address/fix in future updates as I would like to minify HTML in the page.

    Thank you

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    Well , I will pass the case to our devs , but eventually it’s up to their assessment and evaluation.

    could you can try compare the main request size with and without HTML minify ?

    Best regards,

    Thread Starter reachdigital

    (@reachdigital)

    Thank you again,

    There has been a few others mentioning this issue but not sure if they use LS cache, it could be a HTML minify issue overall.

    Here is the comparison.

    Off https://gtmetrix.com/reports/www.reachdigital.com.au/Stl0aLFn
    ON https://gtmetrix.com/reports/www.reachdigital.com.au/W26OxskT

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    the size on main request is 20.5 KB and 20.6 KB

    HTML minify reduces like 0.1KB or maybe even less.

    you can safely keep it OFF without worry performance impact đŸ™‚

    Best regards,

    Thread Starter reachdigital

    (@reachdigital)

    Ok thank you, it may be of interets to show the devs, in the case it may be an easy fix.

    Thank you again for all your help, you are always full on useful info!

    Thank you

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Elementor Exclude a CSS Class’ is closed to new replies.