Support » Plugin: Elementor Website Builder » Elementor Editor Stuck on Loading Screen

  • Resolved pepperink

    (@pepperink)


    Hello,

    I am not a web designer, I am an just an illustrator, but with a number of self-taught years of running my own WordPress site. Elementor has been great, up until todays update. All of a sudden, I try to edit any pages and it just stays stuck on the loading screen.

    I have tried turning off ALL plugins – did not fix the issue

    I have tried running it on the twenty sixteen theme with all other plugins off – did not fix the issue

    I have updated the MEMORY LIMIT to 256MB – did not fix the issue.

    Currently running my test site with the ASTRA theme. Theme, Elementor Plugin, and WordPress are all at current versions.

    Here is the debug message from my system info:

    == Server Environment ==
    Operating System: Linux
    Software: Apache
    MySQL version: 5.5.51
    PHP Version: 5.5.36
    PHP Max Input Vars: 1000
    PHP Max Post Size: 128M
    GD Installed: Yes
    Write Permissions: All right
    Elementor Library: Connected

    == WordPress Environment ==
    Version: 4.9.4
    Site URL: http://test.pepperink.com
    Home URL: http://test.pepperink.com
    WP Multisite: No
    Max Upload Size: 128 MB
    Memory limit: 256M
    Permalink Structure: /%postname%/
    Language: en-US
    Timezone: America/New_York
    Debug Mode: Inactive

    == Theme ==
    Name: Astra
    Version: 1.2.6
    Author: Brainstorm Force
    Child Theme: No

    == User ==
    Role: administrator
    WP Profile lang: en_US
    User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.181 Safari/537.36

    == Active Plugins ==
    Elementor
    Version: 2.0.1
    Author: Elementor.com

    Header Footer Elementor
    Version: 1.0.12
    Author: Brainstorm Force, Nikhil Chavan

    Under Construction
    Version: 2.95
    Author: Web factory Ltd

    Wordfence Security
    Version: 7.1.1
    Author: Wordfence

    == Debug ==
    Errors:
    TypeError: Cannot read property ‘currentView’ of undefined
    at http://test.pepperink.com/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.0.1 – 2:88074
    2018-03-28 00:57 +00:00
    x 20 times

    TypeError: Cannot read property ‘errors’ of undefined
    at http://test.pepperink.com/wp-content/plugins/elementor/assets/js/editor.min.js?ver=1.9.8 – 2:114492
    2018-03-16 01:26 +00:00
    x 3 times

    You will notice I am getting TWO debug errors, however these seem to be above my skill level and I am not sure what they are telling me.

    I am hoping there is a bug in the newest update, and there will be a revised update in the next day or so…. but just in case not….ANY HELP PLEASE? Thank you in advance.

Viewing 5 replies - 91 through 95 (of 95 total)
  • I sent this to the author of Black Studio who created the plugin Black Studio TinyMCE Widget:

    I am the author of many web sites (FavaWorks.com). I use Elementor as the page builder for my web sites. I also had the plugin Black Studio TinyMCE Widget.
    For hours yesterday, I made attempts to fix a problem I was experiencing with Elementor. The editor was in a WHITE screen handicap that prevented me from editing any of my pages.
    It was only after deactivating each of the plugins, one by one, did I discover the problem. It was your Black Studio TinyMCE Widget that was the culprit. When I deactivated this plugins, Elementor miraculously recovered.

    I recommend you test and correct this plugin as others are also experiencing this – Look at Elementor forums and you’ll see what I am talking about.

    => I hope this is helpful to our Elementor users.

    David

    Hi,
    Yesterday I was here with the same purpose to find a solution to solve problems with Elementor. Today allow me to share the Steps of how I solve this Issue and hopefully this going to work with you also. So these are the Steps:

    1. Increase the memory limitation.

    Go to CPanel > PHP Version > Switch to PHP Version > find the Memory_Limit section > change or increase the Memory for example to 256 MB. (https://www.niagahoster.co.id/kb/mengubah-php-ini-dengan-htaccess-dan-php-selector) …sorry..hopefully, you understand the instructions.
    otherwise, ask your current Hosting company support to increase memory _limitation in the server side.

    2. Adding code : define( ‘WP_MAX_MEMORY_LIMIT’, ‘256M’ );

    Go to FILE MANAGER in the CPanel > public_html > edit file wp_config.php > add the code: define( ‘WP_MAX_MEMORY_LIMIT’, ‘256M’ ); under the code section: define( ‘WP_DEBUG’, false );

    example:
    define( ‘WP_DEBUG’, false );
    define( ‘WP_MAX_MEMORY_LIMIT’, ‘256M’ );

    …refresh the changes!

    info:
    https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

    3. Go to your WordPress Dashboard

    > Elementor > Setting > Advance > in my case I switched “disable” the loader methods..is up to you and the Editing Handle I set to “Show”.

    4. If you already installed a WordPress Caching Plugins such as
    WP Rocket. ..WP Super Cache. …W3 Total Cache. …WP Fastest Cache. …Comet Cache. …Cache Enabler. …Hyper Cache. and many more…

    You should DEACTIVATE during the Web design process !!!

    Good luck and thank you

    This issue with Elementor seemed to have returned with the latest update. My homepage won’t load. JazzyGDesign.com

    Same problem here too. I’ve tried everything that people have said here but still the same problem which been on-going for the last 3/4 weeks now.

    I did press F!2 and it came up with this

    Love using Elementor? Join our growing community of Elementor developers: https://github.com/elementor/elementor
    jquery-migrate.min.js?ver=1.4.1:2 JQMIGRATE: Migrate is installed, version 1.4.1
    editor.min.js?ver=2.5.4:2 Uncaught TypeError: Cannot set property ‘controls’ of undefined
    at Object.<anonymous> (editor.min.js?ver=2.5.4:2)
    at Function.each (load-scripts.php?c=1&load[]=underscore,shortcode,utils,jquery-core,jquery-migrate,backbone,wp-util,wp-backbone,media-models,moxiejs,plupload,wp-plupload,jqu&load[]=ery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable&ver=5.1:5)
    at Object.success (editor.min.js?ver=2.5.4:2)
    at i (load-scripts.php?c=1&load[]=underscore,shortcode,utils,jquery-core,jquery-migrate,backbone,wp-util,wp-backbone,media-models,moxiejs,plupload,wp-plupload,jqu&load[]=ery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable&ver=5.1:5)
    at Object.fireWith [as resolveWith] (load-scripts.php?c=1&load[]=underscore,shortcode,utils,jquery-core,jquery-migrate,backbone,wp-util,wp-backbone,media-models,moxiejs,plupload,wp-plupload,jqu&load[]=ery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable&ver=5.1:5)
    at Object.e.(/wp-admin/anonymous function) [as resolve] (https://www.bits-of-bitcoin.com/wp-admin/load-scripts.php?c=1&load%5B%5D=underscore,shortcode,utils,jquery-core,jquery-migrate,backbone,wp-util,wp-backbone,media-models,moxiejs,plupload,wp-plupload,jqu&load%5B%5D=ery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable&ver=5.1:5:29192)
    at common.min.js?ver=2.5.4:2
    at Array.forEach (<anonymous>)
    at success (common.min.js?ver=2.5.4:2)
    at Object.i.success (common.min.js?ver=2.5.4:2)

    I’ve tried my other websites and they all the same. I have Elementor pro on one website and standard on the others, but there is no difference.

    Time this was sorted out, can’t edit my pages now.

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    @kevin1877uk, jazzydesign, stonesweaver

    If you need support then per the forum guidelines please start your own topic.

    A lot more people will see your post, and that way you stand a good chance of getting the assistance you want. Despite any similarity in symptoms, your issue is likely to be completely different because of possible differences in physical servers, accounts, hosts, plugins, theme, configurations, etc. Thus one problem, on one setup is not indicative of the functionality and reliability of an application as a whole.

    Frequently Asked Questions

    Forum Guidelines

    You can do so here:

    https://wordpress.org/support/forum/how-to-and-troubleshooting/#new-post

    I’ll be archiving your post and mine to not spam the original poster and detract from their question.

    Thanks.

Viewing 5 replies - 91 through 95 (of 95 total)
  • The topic ‘Elementor Editor Stuck on Loading Screen’ is closed to new replies.