Support » Plugin: Elementor Page Builder » Elementor Editor Stuck on Loading Screen

  • Resolved pepperink

    (@pepperink)


    Hello,

    I am not a web designer, I am an just an illustrator, but with a number of self-taught years of running my own WordPress site. Elementor has been great, up until todays update. All of a sudden, I try to edit any pages and it just stays stuck on the loading screen.

    I have tried turning off ALL plugins – did not fix the issue

    I have tried running it on the twenty sixteen theme with all other plugins off – did not fix the issue

    I have updated the MEMORY LIMIT to 256MB – did not fix the issue.

    Currently running my test site with the ASTRA theme. Theme, Elementor Plugin, and WordPress are all at current versions.

    Here is the debug message from my system info:

    == Server Environment ==
    Operating System: Linux
    Software: Apache
    MySQL version: 5.5.51
    PHP Version: 5.5.36
    PHP Max Input Vars: 1000
    PHP Max Post Size: 128M
    GD Installed: Yes
    Write Permissions: All right
    Elementor Library: Connected

    == WordPress Environment ==
    Version: 4.9.4
    Site URL: http://test.pepperink.com
    Home URL: http://test.pepperink.com
    WP Multisite: No
    Max Upload Size: 128 MB
    Memory limit: 256M
    Permalink Structure: /%postname%/
    Language: en-US
    Timezone: America/New_York
    Debug Mode: Inactive

    == Theme ==
    Name: Astra
    Version: 1.2.6
    Author: Brainstorm Force
    Child Theme: No

    == User ==
    Role: administrator
    WP Profile lang: en_US
    User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.181 Safari/537.36

    == Active Plugins ==
    Elementor
    Version: 2.0.1
    Author: Elementor.com

    Header Footer Elementor
    Version: 1.0.12
    Author: Brainstorm Force, Nikhil Chavan

    Under Construction
    Version: 2.95
    Author: Web factory Ltd

    Wordfence Security
    Version: 7.1.1
    Author: Wordfence

    == Debug ==
    Errors:
    TypeError: Cannot read property ‘currentView’ of undefined
    at http://test.pepperink.com/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.0.1 – 2:88074
    2018-03-28 00:57 +00:00
    x 20 times

    TypeError: Cannot read property ‘errors’ of undefined
    at http://test.pepperink.com/wp-content/plugins/elementor/assets/js/editor.min.js?ver=1.9.8 – 2:114492
    2018-03-16 01:26 +00:00
    x 3 times

    You will notice I am getting TWO debug errors, however these seem to be above my skill level and I am not sure what they are telling me.

    I am hoping there is a bug in the newest update, and there will be a revised update in the next day or so…. but just in case not….ANY HELP PLEASE? Thank you in advance.

Viewing 15 replies - 76 through 90 (of 95 total)
  • Joe Bloggs

    (@joe-bloggs)

    Same here! In the middle of developing a site, out of the sudden stuck on loading screen. Just want to cry!! This is ridiculous!

    Not a single word from the Author??

    Plugin Support Ben Pines

    (@benpines)

    Joe Bloggs

    (@joe-bloggs)

    Yes I did (fiddle around with the plugins), but here’s what’s interesting.

    I’ve got Elementor installed as well as Elementor Pro and Ultimate Addons for Elementor.

    The first time around out of the sudden I got stuck on the loading screen with all three activated. So I deactivated only Elementor Pro leaving Elementor and the Ultimate Addons running.

    Problem seemed to be solved and again I could access the pages.

    But because I’ve already used some of the elements from Pro, I activated Pro again.

    Now again, I can’t access the pages.

    So this time around, I deactivated Elementor Pro again as well as the Ultimate Addons. Again, I can access the pages.

    So now second time around I reactivated Elementor Pro, but leaving the Ultimate Addons deactivated.

    Now this works for a change.

    So now with Elementor and Elementor Pro, I can access the pages, but the first time around I could only access the pages with Pro deactivated even though the Ultimate Addons stayed activated.

    Scared to touch anything now ..

    sandras21

    (@sandras21)

    I downloaded Elementor today and worked all morning fine, a few hours later when I returned, page is loading very long and when I change for one element colour code, I can´t change any other elements anymore, have to update, close and open again (when waiting 2 minutes to open the site). All requirements are ok, everything updated, tried safe mode for elementor, debug mode for the site, deactivated plugins..nothing helps. I use a free version of Elementor. Can someone advise how did you overcome those issues?

    cphilpot

    (@cphilpot)

    Bit of a long shot, but try creating a new htaccess file. Don’t forgot to make a backup of the original before doing so.

    lounix

    (@lounix)

    I been stuck with this Elementor for 48 hours with no solution until now.

    I checked the console error using the developer tool and found something denied access to elementor because of the x-frame options.

    While looking at the htaccess file , I found the line of code that denied the access:

    “Header always append x-frame-options DENY”

    I had to delete it to make Elementor load again.

    sandras21

    (@sandras21)

    My .htaccess file looked like normal, just in case created new, nothing changed…loading long and after editing style, can`t edit other section or column.

    Joe Bloggs

    (@joe-bloggs)

    Thanks @lounix really helpful.

    I’m currently having another issue on a different site. Not a huge issue, but it took a while to figure it out.

    When I edit a new fresh page, the Elementor button ‘Edit with Elementor’ shows up above the wysiwyg text editor, just like it normally does with a fresh page that hasn’t been edited with Elementor yet.

    When I click this button to start editing the page with Elementor, I get the Elementor loading pre-loader running inside the text editor window and it is getting stuck there forever.

    Normally, this pre-loader should load inside the text editor window just for a little while and jump into the full screen loading page with the green bar going from left to right on the top.

    So mine doesn’t, it keeps loading inside the text editor window.

    Until I click it.

    What I have to do is to click it. Not the button, but the preloader inside the text editor window, and then it jumps to the fullscreen and loads as usual.

    But without the extra click, it is stuck on loading inside the text editor window.

    scsiraidguru

    (@scsiraidguru)

    Hit F12 to see the errors.

    Hey @johnbassusa your website doesn’t even use Elementor. This is no place for cheap spammy comments!

    OK, so I don’t have much to add, only that I’d been working fine with elementor (free) for the past 2 months, all working fine on a new wordpress site in a subfolder on the server.

    Once the site was finished, put it live (kept it in subflolder, copied .htaccss and index.php to root. updated site urls in wordpress settings, updated permalinks etc)

    Site works fine but… can’t get the elementor editor to load for any page or post, just halts on grey elementor load screen. Tried all suggestions here within elementor (alternative load method, and set url) disabled a few plugins. Nothing helped.

    Switching from chrome to Firefox, can load elementor editor fine! Hmmm

    conradish,

    I think you might have installed a plugin at last right before going live with the website that is effecting your Elementor plugin for some reason.

    I would recommend to try deactivate one by one all plug in until you will find witch one is responsible.

    Hi Lotar,

    Thanks, but that’s not it, nothing installed prior to going live. I’ve also tried deactivating several plugins to fix the issue, again to no avail.

    What’s odd is that I can load elementor in firefox, but not chrome, and that others in this thread have experienced the same.

    @benpines I am able to create any type of template file (Single, Section etc.) but I cannot create ‘Page’.

    Every single time I am trying to create ‘Page’ template, I get a blank white screen.

    I have tried different browsers, same thing, any ideas?

    Conradish,

    Try to clear all cache present on google chrome, there is a couple of steps to to that, you can easily google it.

    Also have you tried to open elementor through another laptop still with Chrome? did it work in that case?

Viewing 15 replies - 76 through 90 (of 95 total)
  • The topic ‘Elementor Editor Stuck on Loading Screen’ is closed to new replies.