Support » Plugin: Elementor Page Builder » Elementor Editor Stuck on Loading Screen

  • Resolved pepperink

    (@pepperink)


    Hello,

    I am not a web designer, I am an just an illustrator, but with a number of self-taught years of running my own WordPress site. Elementor has been great, up until todays update. All of a sudden, I try to edit any pages and it just stays stuck on the loading screen.

    I have tried turning off ALL plugins – did not fix the issue

    I have tried running it on the twenty sixteen theme with all other plugins off – did not fix the issue

    I have updated the MEMORY LIMIT to 256MB – did not fix the issue.

    Currently running my test site with the ASTRA theme. Theme, Elementor Plugin, and WordPress are all at current versions.

    Here is the debug message from my system info:

    == Server Environment ==
    Operating System: Linux
    Software: Apache
    MySQL version: 5.5.51
    PHP Version: 5.5.36
    PHP Max Input Vars: 1000
    PHP Max Post Size: 128M
    GD Installed: Yes
    Write Permissions: All right
    Elementor Library: Connected

    == WordPress Environment ==
    Version: 4.9.4
    Site URL: http://test.pepperink.com
    Home URL: http://test.pepperink.com
    WP Multisite: No
    Max Upload Size: 128 MB
    Memory limit: 256M
    Permalink Structure: /%postname%/
    Language: en-US
    Timezone: America/New_York
    Debug Mode: Inactive

    == Theme ==
    Name: Astra
    Version: 1.2.6
    Author: Brainstorm Force
    Child Theme: No

    == User ==
    Role: administrator
    WP Profile lang: en_US
    User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.181 Safari/537.36

    == Active Plugins ==
    Elementor
    Version: 2.0.1
    Author: Elementor.com

    Header Footer Elementor
    Version: 1.0.12
    Author: Brainstorm Force, Nikhil Chavan

    Under Construction
    Version: 2.95
    Author: Web factory Ltd

    Wordfence Security
    Version: 7.1.1
    Author: Wordfence

    == Debug ==
    Errors:
    TypeError: Cannot read property ‘currentView’ of undefined
    at http://test.pepperink.com/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.0.1 – 2:88074
    2018-03-28 00:57 +00:00
    x 20 times

    TypeError: Cannot read property ‘errors’ of undefined
    at http://test.pepperink.com/wp-content/plugins/elementor/assets/js/editor.min.js?ver=1.9.8 – 2:114492
    2018-03-16 01:26 +00:00
    x 3 times

    You will notice I am getting TWO debug errors, however these seem to be above my skill level and I am not sure what they are telling me.

    I am hoping there is a bug in the newest update, and there will be a revised update in the next day or so…. but just in case not….ANY HELP PLEASE? Thank you in advance.

Viewing 15 replies - 61 through 75 (of 95 total)
  • I’m also seeing this problem. What fixes it for me is disabling Wordfence. Once I make my updates, I turn Wordfence back on.

    Help!!

    I’ve been using Elementor on the theme Bard and it’s stopped working for me have tried swapping to the twenty sixteen theme and it works on that one but that’s not the theme I want it’s all updated and just keeps loading and doesn’t bring me to edit page, can any one help??
    Thanks

    Hi graceeruane1,

    What version of elementor are you using and do you have the pro add on?

    If you was to roll back to a previous version does it start working again?

    Do use use CDN or adblocker in your browser?

    If you know how to use Google dev tools can you open it up (F12) and then click on edit with elementor on any page, in the console window it will probably show a red cross in the top right if you click that an error will display. Can you post that error back please.

    Hey Everyone!

    My name is Lari Hazanovich and I am new to all this subject.
    I am only 2 years in all the business of WordPress and Web Marketing.
    I must admit that I just love this Plugin!
    And it helps enormously in building a great, Responsive Website.
    I encountered the same problem in the 2.3.4 version of the plugin.
    I need your help, my dear friends.
    Specifically, I noticed that when I am trying to edit a post page on my site.
    It happened two days ago on my Website when I tried to edit a page on my Website,
    it went smoothly but when I went to edit further a Post Page I got the loading page of the Elementor Plugin.

    I really need your help, anybody who can help with the matter I really appreciate it!

    Sincerely,
    Lari

    • This reply was modified 11 months, 2 weeks ago by  Lari Hazanovich. Reason: Wrong word used ''add'' instead of ''edit''

    I’m also having trouble with my Front Page!!! I can’t edit it with Elementor. It’s just stuck in the loading screen.

    I can edit other pages, except the front page. Please help!

    Hi daneloctober

    The exact same thing was happening to me,could not edit certain existing and new pages. For me it was my adblocker in Chrome and rocket loader in CloudFlare causing the issues.

    You could post back any errors in the page displayed via Google DevTools, however it can be difficult to diagnose without access.

    I however have no affiliation to Elementor or WordPress, so you may want to direct your query direct to Elementor if the above options do not work for you.

    Hi, I;m facing Same issue check the pic to understand the problem https://imgur.com/a/wubjksU . Elementor and WP is fully update. WP version 5.0.

    Waiting for the solution

    Thank You!

    looks like admin elementor not replying anything….

    Hi Team,

    I’m having the same issue with the front page.
    It’s stuck in the loading screen.

    Please fix this.

    Kim

    Yea, this has been a nightmare of an issue. I have the Ozisti theme, a beautiful theme that uses Elementor, (not compatible with WPBaker Page builder – so can’t use that as a fallback). With that said it’s been about 3 weeks of back and forth, between theme author support, Elementor Pro supoort, and WPEngine hosting support, they each point to the other as a conflict.

    With that said, I have narrowed it down to be a theme conflict that needs to be resolved by their developer… I have a few more days for a fix, if not I must be issued a refund as I can not edit pages with their product or plugins.

    Sorry this wasn’t a solution, more of a heads-up.

    Good Luck.

    lotar82

    (@lotar82)

    Hello, I had the same problem, and i would like to share my experience:

    Loading page was stucked after migrating my website from my local host to my web host (I used Duplicator plugin).

    To fix the problem i have followed this guideline:

    My page is gray – Endless loading

    If you get a gray page when you try to edit with Elementor, it is probably due to a conflict with another plugin.
    In this case, deactivate each plugin one by one, besides Elementor and Elementor Pro to figure out which one is causing the issue.
    We strive to solve the incompatibility issues with other plugins as much as possible.

    If you have noticed an incompatibility with a plugin, please report this issue to us so that we can fix it.
    Sometimes, you can get this loading page because of an add-on installed on your browser. In this case, you can switch to another browser (It has to be Safari, Chrome, Firefox or Opera).

    The gray page can be also due to X frame restrictions. You can see if it is the issue by checking the error messages of your browser console (to do it, click right on your mouse, select “inspect” and then “console”. Error messages are written in red). In this case, you will have to change the X-Frame-Options from DENY to SAMEORIGIN.

    If you use Cloudflare, you will have to switch off Rocket Loader. When Rocket Loader is activated, it can take time to load the editor of Elementor and sometimes you will get stuck on the gray loading page.

    Basically I have disabled all plugins over than Elementor and the editor started working again!

    The Plugins interfering with Elementor editor were:

    1. Ocean Extra

    2. Premium Addons for Elementor

    hoping to be a good help.

    Cheers

    • This reply was modified 11 months ago by  lotar82.

    I just thought I wold try Elementor, on a new server (brand new wordpress install on a clean empty server using only twentynineteen) and it just doesn’t load. Grey screen.

    I had Litespeed, Pods, Classic Editor plugins but deactivated all of them. No difference. I had created a simple child theme for my edits but I even went back to “raw” twentynineteen. Nope!

    It’s weird to see pages and pages of people reporting this sort of error for nine months, does not give me confidence!

    Now someone suggester Beaver?….

    == Server Environment ==
    Operating System: Linux
    Software: Apache
    MySQL version: MySQL Community Server (GPL) v
    PHP Version: 7.2.12
    PHP Max Input Vars: 1000
    PHP Max Post Size: 200M
    GD Installed: Yes
    ZIP Installed: Yes
    Write Permissions: All right
    Elementor Library: Connected

    == WordPress Environment ==
    Version: 5.0.2
    Site URL: https://www.domain.tld
    Home URL: http://www.domain.tld
    WP Multisite: No
    Max Upload Size: 200 MB
    Memory limit: 256M
    Permalink Structure: /%postname%/
    Language: de-DE
    Timezone: Europe/Berlin
    Debug Mode: Active

    == Theme ==
    Name: OceanWP Child
    Version: 1.0
    Author: Nick
    Child Theme: Yes
    Parent Theme Name: OceanWP
    Parent Theme Version: 1.5.32
    Parent Theme Author: Nick

    == User ==
    Role: administrator
    WP Profile lang: de_DE
    User Agent: Mozilla/5.0 (Windows NT 10.0; rv:64.0) Gecko/20100101 Firefox/64.0

    == Active Plugins ==
    Classic Editor
    Version: 1.3
    Author: WordPress Contributors

    Duplicate Post
    Version: 3.2.2
    Author: Enrico Battocchi

    Elementor
    Version: 2.3.8
    Author: Elementor.com

    Email Address Encoder
    Version: 1.0.12
    Author: Till Krüss

    Enable Media Replace
    Version: 3.2.7
    Author: ShortPixel

    Google Pagespeed Insights
    Version: 4.0.1
    Author: Matt Keys

    iThemes Security
    Version: 7.2.0
    Author: iThemes

    MainWP Child
    Version: 3.5.3
    Author: MainWP

    MainWP Child Reports
    Version: 1.9.1
    Author: MainWP

    Ocean Extra
    Version: 1.4.30
    Author: OceanWP

    UpdraftPlus – Backup/Restore
    Version: 1.16.0
    Author: UpdraftPlus.Com, DavidAnderson

    WP Staging
    Version: 2.4.7
    Author: WP-Staging

    == Must-Use Plugins ==
    WP Staging Optimizer
    Version: 1.1
    Author: René Hermenau

    == Debug ==
    Errors:
    SecurityError: Permission denied to access property “elementorFrontend” on cross-origin object
    at https://www.domain.tld/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.3.8 – 2:0
    2019-01-06 20:04 +00:00
    x 4 times

    SecurityError: Permission denied to access property “elementorFrontend” on cross-origin object
    at https://www.domain.tld/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.2.7 – 2:0
    2019-01-06 19:26 +00:00
    x 8 times

    SecurityError: Permission denied to access property “elementorFrontend” on cross-origin object
    at https://www.domain.tld/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.3.8 – 2:0
    2019-01-06 19:14 +00:00
    x 3 times

    SecurityError: Blocked a frame with origin “https://www.domain.tld” from accessing a cross-origin frame.
    at https://www.domain.tld/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.3.8 – 2:99462
    2019-01-06 18:50 +00:00
    x 2 times

    SecurityError: Permission denied to access property “elementorFrontend” on cross-origin object
    at https://www.domain.tld/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.3.8 – 2:0
    2019-01-06 18:43 +00:00
    x 8 times

    This system info relates to WordPress v5.0.2 + OceanWP v1.5.32 + Elementor v2.3.8. To be sure I made a completely fresh WordPress v5.0.2 setup without any themes or plugins. Then I installed only one plugin – Elementor. And guess what – neverending grey screen.

    I spent hours and days of my spare time in recherche dealing with tis error. Finally a decision had to be made and so I changed the theme and the editor. I have to finish a project and my customer shurely won’t pay the time I spent to unfortunately find no solution. Bad luck.

    I hope the developers will find a way to fix this problem in the future for I am definitely not alone in the dark. But for now I have to say bye bye to Elementor. It’s a shame, because I’ve seen Elementor in the past as a very promising alternative to other editors. But I just need a reliable tool, even if I have to accept other disadvantages.

    just got the same issue. edit page with elementor stucks forever.
    theme: oceanwp pro with free elementor
    i was just thinking i am going to buy a pro license from elementor but… jesus christ, pls fix this. i am building 2 new websites right now and thought this is a good thing (oceanwp + elementor)….. but not sure anymore 🙁

    Odd these same issues keep cropping up yet no one wants to admit such issue exists.

    Elementor is a good page builder shame we can’t say the same about the support and devs ability to give users a explanation and fix.

    Pro is a nice but not essential add on and if the devs can’t sort the issues I wouldn’t recommend anyone pay for the upgrade.

    Happy to try and help anyone who may be having issues, with gifts for all 😉

    Let me know.

Viewing 15 replies - 61 through 75 (of 95 total)
  • The topic ‘Elementor Editor Stuck on Loading Screen’ is closed to new replies.