Support » Plugin: Elementor Website Builder » Elementor Editor Stuck on Loading Screen

  • Resolved pepperink

    (@pepperink)


    Hello,

    I am not a web designer, I am an just an illustrator, but with a number of self-taught years of running my own WordPress site. Elementor has been great, up until todays update. All of a sudden, I try to edit any pages and it just stays stuck on the loading screen.

    I have tried turning off ALL plugins – did not fix the issue

    I have tried running it on the twenty sixteen theme with all other plugins off – did not fix the issue

    I have updated the MEMORY LIMIT to 256MB – did not fix the issue.

    Currently running my test site with the ASTRA theme. Theme, Elementor Plugin, and WordPress are all at current versions.

    Here is the debug message from my system info:

    == Server Environment ==
    Operating System: Linux
    Software: Apache
    MySQL version: 5.5.51
    PHP Version: 5.5.36
    PHP Max Input Vars: 1000
    PHP Max Post Size: 128M
    GD Installed: Yes
    Write Permissions: All right
    Elementor Library: Connected

    == WordPress Environment ==
    Version: 4.9.4
    Site URL: http://test.pepperink.com
    Home URL: http://test.pepperink.com
    WP Multisite: No
    Max Upload Size: 128 MB
    Memory limit: 256M
    Permalink Structure: /%postname%/
    Language: en-US
    Timezone: America/New_York
    Debug Mode: Inactive

    == Theme ==
    Name: Astra
    Version: 1.2.6
    Author: Brainstorm Force
    Child Theme: No

    == User ==
    Role: administrator
    WP Profile lang: en_US
    User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.181 Safari/537.36

    == Active Plugins ==
    Elementor
    Version: 2.0.1
    Author: Elementor.com

    Header Footer Elementor
    Version: 1.0.12
    Author: Brainstorm Force, Nikhil Chavan

    Under Construction
    Version: 2.95
    Author: Web factory Ltd

    Wordfence Security
    Version: 7.1.1
    Author: Wordfence

    == Debug ==
    Errors:
    TypeError: Cannot read property ‘currentView’ of undefined
    at http://test.pepperink.com/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.0.1 – 2:88074
    2018-03-28 00:57 +00:00
    x 20 times

    TypeError: Cannot read property ‘errors’ of undefined
    at http://test.pepperink.com/wp-content/plugins/elementor/assets/js/editor.min.js?ver=1.9.8 – 2:114492
    2018-03-16 01:26 +00:00
    x 3 times

    You will notice I am getting TWO debug errors, however these seem to be above my skill level and I am not sure what they are telling me.

    I am hoping there is a bug in the newest update, and there will be a revised update in the next day or so…. but just in case not….ANY HELP PLEASE? Thank you in advance.

Viewing 15 replies - 31 through 45 (of 95 total)
  • An update to both Elementor 2.1.4. and Elementor Pro 1.9.5 helped me with this problem.

    mounttabormusicschool

    (@mounttabormusicschool)

    I’m dealing with the same issue. Total amateur building a website for my school… it was going so smoothly at first with Elementor and now I can’t get it to load at all. I’ve tried every browser and even a variety of computers.

    This helped me: dashboard/elementor/settings/advanced/Switch Editor Loader Method

    Worth a try, let us know if it worked?

    robertpeetphotography

    (@robertpeetphotography)

    I have come across this problem today (Wednesday). It worked fine on Monday. Updating Elementor and deactivating other plugins has made no difference. I’ve not updated or installed any new plugins since Monday anyway :). Unfortunately the dashboard/elementor/settings/advanced/Switch Editor fix mentioned above made no difference.

    I don’t have pro, just standard.

    I’m not a developer and indeed don’t have any webdevelopment experience at all. All jargon to me.

    Any thoughts?

    @peteraloha method worked for me. Thanks buddy.

    WooHoo.

    Thanks peteraloha, It worked. I hope Next steo is to try loading templates.

    On my pages Elementor is loading and loading, can’t edit anything. I can see error message

    RangeError: Max value for this device is out of range. at https://www.northernlightsriders.fi/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.0.16 – 2:189687 2018-09-19 09:36 +00:00

    Any idea?

    Hello guyz, Hope everyone is not like me. 3 working day my elementor is massed up with this freezing Elementor loading

    Hello. You can cost deactivate all of your plugin. Everything will be fine

    hi, any help me. my Mr.Singh. my elementor page builders, not open edit page show this mesage

    show my all data

    == Debug ==
    Errors:
    TypeError: Cannot read property ‘stretch’ of null
    at http://justtheme.net/wp-content/plugins/elementor-pro/assets/js/frontend.min.js?ver=2.1.9 – 2:23338
    2018-10-08 15:02 +00:00

    Boaz

    (@boazpojo)

    Hi @mrsinghr,

    Can you please contact our tech support?
    It sounds like an Elementor Pro related issue.

    tedandre

    (@tedandre)

    Elementor is freezing when attempting to upload new .json files to the library, which seems to be related to a recent update.

    Loading anything else (pre-existing templates, blocks, and pages) seems fine.

    What is the workaround?

    Elementor version: 2.2.5

    Hi folks,

    I have wasted a whole day to figure that crazy mess-up (completely messed up my website).

    And finally found a temporary solution to make the site work again and also continue using with the last version of Elementor.

    The problem was (and still) a conflict between Elementor and Chrome. I don’t know why it happens but I hope to have time to figure it out when I will have some spare time…

    Anyway, what worked for me is:
    1. Downloading Microsoft Explorer Edge – Elementor working just fine (but I personally prefer Chrome).
    2. Because I am using Cloudflare I faced issue with the permalinks and found a solution on the forums – just go to settings-general and add www (after the http:// or https://) to your WordPress Address (URL) and Site Address (URL).
    3. Now refresh your website caching and purge the caching on Cloudflare site for your website.
    4. Preview your website on all platforms and fix bugs (if you found some).

    That’s it hope I manage to help someone with that.

    Perhaps this will help someone: After spending several hours and doing all of the above and more without success, I realised that the problem was simply that I had the index.htm file from my old site in the directory. When I got rid of that, Elementor loaded fine.

    It’s definitely a chrome thing. Everything was fine yesterday, today I just get a blank page when elementor loads up. Trying it in Firefox makes it work fine.

Viewing 15 replies - 31 through 45 (of 95 total)
  • The topic ‘Elementor Editor Stuck on Loading Screen’ is closed to new replies.