Support » Plugin: Elementor Website Builder » Elementor Editor Stuck on Loading Screen

  • Resolved pepperink

    (@pepperink)


    Hello,

    I am not a web designer, I am an just an illustrator, but with a number of self-taught years of running my own WordPress site. Elementor has been great, up until todays update. All of a sudden, I try to edit any pages and it just stays stuck on the loading screen.

    I have tried turning off ALL plugins – did not fix the issue

    I have tried running it on the twenty sixteen theme with all other plugins off – did not fix the issue

    I have updated the MEMORY LIMIT to 256MB – did not fix the issue.

    Currently running my test site with the ASTRA theme. Theme, Elementor Plugin, and WordPress are all at current versions.

    Here is the debug message from my system info:

    == Server Environment ==
    Operating System: Linux
    Software: Apache
    MySQL version: 5.5.51
    PHP Version: 5.5.36
    PHP Max Input Vars: 1000
    PHP Max Post Size: 128M
    GD Installed: Yes
    Write Permissions: All right
    Elementor Library: Connected

    == WordPress Environment ==
    Version: 4.9.4
    Site URL: http://test.pepperink.com
    Home URL: http://test.pepperink.com
    WP Multisite: No
    Max Upload Size: 128 MB
    Memory limit: 256M
    Permalink Structure: /%postname%/
    Language: en-US
    Timezone: America/New_York
    Debug Mode: Inactive

    == Theme ==
    Name: Astra
    Version: 1.2.6
    Author: Brainstorm Force
    Child Theme: No

    == User ==
    Role: administrator
    WP Profile lang: en_US
    User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.181 Safari/537.36

    == Active Plugins ==
    Elementor
    Version: 2.0.1
    Author: Elementor.com

    Header Footer Elementor
    Version: 1.0.12
    Author: Brainstorm Force, Nikhil Chavan

    Under Construction
    Version: 2.95
    Author: Web factory Ltd

    Wordfence Security
    Version: 7.1.1
    Author: Wordfence

    == Debug ==
    Errors:
    TypeError: Cannot read property ‘currentView’ of undefined
    at http://test.pepperink.com/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.0.1 – 2:88074
    2018-03-28 00:57 +00:00
    x 20 times

    TypeError: Cannot read property ‘errors’ of undefined
    at http://test.pepperink.com/wp-content/plugins/elementor/assets/js/editor.min.js?ver=1.9.8 – 2:114492
    2018-03-16 01:26 +00:00
    x 3 times

    You will notice I am getting TWO debug errors, however these seem to be above my skill level and I am not sure what they are telling me.

    I am hoping there is a bug in the newest update, and there will be a revised update in the next day or so…. but just in case not….ANY HELP PLEASE? Thank you in advance.

Viewing 15 replies - 1 through 15 (of 95 total)
  • turgsaysno

    (@turgsaysno)

    I am having the same problem. I tried the suggested troubleshooting using the steps outlined in the KB article and nothing worked. It worked fine this morning when I updated my plugin and then proceeded to update my page, however, when I came back to my site to edit again tonight, I couldn’t get it to load. The loading bar indicates that it is trying to load the page, but it just sits on the loading page with the Elementor loading logo.

    Any help or insight would be great. In the mean time, I have rolled back to version 1.9.8 and got Elementor to load properly. Me thinks it’s a version update issue.

    mongkolrerg

    (@mongkolrerg)

    I think this bug form file editor.min.js ver 2.0.1,
    I try to replace that with editor.min.js from ver 2.0.0

    waterbod

    (@waterbod)

    Hi

    I’m having a similar problem. I can only edit my homepage with Elementor but it won’t load any other pages, it just hangs.

    sotte

    (@sotte)

    Same problems…

    untamedmainer

    (@untamedmainer)

    Same here.

    I did the same as @turgsaysno and rolled back to 1.9.8 and was able to edit my pages again, although I noticed the debug errors are the same.

    essaouirakiteparadise

    (@essaouirakiteparadise)

    Hi,

    Same problems, i can just upload some pages, the others are stuck. The layout of my website is completly destroyed. Thanks Elementor…

    Plugin Author Yakir Sitbon

    (@kingyes)

    Update to 2.0.2 to fix this issue.

    turgsaysno

    (@turgsaysno)

    I can confirm that the fix has been applied in the version 2.0.2 update. Thank you guys for promptly addressing the issue.

    Thread Starter pepperink

    (@pepperink)

    Thank you very much. Currently I went back to 1.9.7 just to get it running again. I will give it a few days to make sure that 2.0.2 is running smoothly before I update.

    Thank you again for the quick response on this.

    peteraloha

    (@peteraloha)

    Still having issues even though I am running 2.0.2 and the Pro plugin.
    Here is what happens:

    Is is an ELEMENTOR PRO issue? –
    – Elementor opens fine in existing pages/posts
    – Elementor does NOT open in *new* pages/posts
    – If titled,published and updated, Elementor opens in new posts/pages,even seems to open FASTER than it did before

    Any ideas? Anybody also has this issue?

    peteraloha

    (@peteraloha)

    PS: I can *always* load when I first give a page title, publish, enter a few letters of content and “update”……………Elementor loads FAST and RELIABLY! – What seems to really matter is that I click on the “content” area in the body of the page. On one occasion that crashed my FF browser, but in 90% of the time it works. There must still be a glitch in the update, and I am curious if the Elementor Creators are still working on it? Please update us………..this can happen, but it is good to know what might be going on from the source.

    In my panic, I worked through my host and almost restored and would have lost a half day’s work. Really glad about this thread, thanks everyone. Keep posting and describing what you are experiencing, it helps the developers to fix it!

    Peter

    peteraloha

    (@peteraloha)

    By the way, I am using the “Page Builder Framework” with Premium Plugin, and they also just had a major update, so that is why I am a bit lost as to what is the issue.

    Thanks,

    Peter

    peteraloha

    (@peteraloha)

    Sorry, one last detail: When I load Elementor into a page that has already been created, it *loads super fast* (faster than it did before the upgrade)! the issue is with *new pages*

    sotte

    (@sotte)

    Currently I went back to 1.9.8 Pro. With 2.0.2 I have problems on saving. It seems there are are problems with 3rd party plugins like Elementor Addons & Widgets and Essential Addons for Elementor – Pro. I am waiting for 2.0.4 or 2.0.5…

    • This reply was modified 3 years ago by .
    peteraloha

    (@peteraloha)

    Awaiting a response from Elementor on this thread, as it seems different folks have different issues – however, the loading seems to be an issue with a number of users. I have arrived/confirmed this through trial-and-error:

    here we go: Tireless experimentation, got me here:
    [using Elementor Pro 2.0.2]

    – Elementor *hangs* with the loading Icon in the body of a page/post when those are not named or published
    – Elementor loads *very promptly* (seconds) When I click on the elementor loading icon *after naming and publishing the page/post! (could be simply clicking in body of page/post)

    Experiment with this and let us know if you can confirm this protocol, or, improve it according to your findings. For my needs, it is offering a work-around that let’s me return to getting work done :-)…………………

    Curious to hear if I am the only one with this particular situation?

    Peter

Viewing 15 replies - 1 through 15 (of 95 total)
  • The topic ‘Elementor Editor Stuck on Loading Screen’ is closed to new replies.