Support » Plugin: Elementor Page Builder » Elementor doesn’t work

  • Resolved crael

    (@crael)


    Hello,

    I’d just updated elementor and the wordpress version (4.9.9 to 5.0.3) and elementor doesn’t work now. It suggest me to activated Safe Mode but I can’t do nothing after that. I tried to:
    – Disable all the plugin
    – Switch theme
    – Switch Browser
    – Save my permalinks one more time
    – Disable rocket loader
    – Switch front-end editor loader method

    I got this on the information system:

    == Log ==
    :
    PHP: showing 20 of 35PHP: 2019-01-14 18:22:14 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/88658.js_gzip_meta_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 18:22:14 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/910e7.css_gzip_meta_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 18:26:54 [notice X 13][/home/curiosity/whisperingfuture.com/wp-content/plugins/ocean-extra/includes/widgets/custom-menu.php::235] Undefined index: target [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 18:29:27 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/affbe.js_gzip_meta_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 18:32:35 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/9f110.js_gzip_meta_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 18:36:31 [notice X 6][/home/curiosity/whisperingfuture.com/wp-login.php::1079] Undefined variable: error [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 18:36:32 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/bee59.css_gzip_meta_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 18:36:33 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/df983.js_gzip_meta_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 18:39:11 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/4ffe0.js_gzip_meta_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 18:47:01 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/17d34.css_gzip_meta_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 18:47:40 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/362cd.css_gzip_meta_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 18:47:41 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/10fb3.js_gzip_meta_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 18:47:49 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/0b76b.js_gzip_meta_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 18:47:54 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/506c8.js_gzip_meta_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 18:48:00 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/36ce3.css_gzip_meta_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 18:50:52 [notice X 1][/home/curiosity/whisperingfuture.com/wp-includes/SimplePie/Registry.php::215] Non-static method WP_Feed_Cache::create() should not be called statically [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 19:27:54 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/Cache_File_Generic.php::78] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/page_enhanced/whisperingfuture.com/wp-content/plugins/wp-asset-clean-up/freemius/assets/css/admin/plugin-upgrade-notice.css/_index_ssl.html_gzip_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 19:28:51 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/2f8b8.css_gzip_meta_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 19:28:54 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/cd7fc.js_gzip_meta_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 19:28:56 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/9a0fe.js_gzip_meta_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]

    JS: showing 7 of 7JS: 2019-01-14 17:04:47 [error X 3][https://whisperingfuture.com/wp-admin/js/editor.min.js?ver=5.0.3:1:459] w is undefined
    JS: 2019-01-14 17:04:47 [error X 3][https://whisperingfuture.com/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.4.0:2:207442] e.editor is null
    JS: 2019-01-14 17:05:31 [error X 19][https://whisperingfuture.com/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.4.0:2:207624] tinymce is not defined
    JS: 2019-01-14 17:20:34 [error X 2][https://whisperingfuture.com/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.4.0:2:82730] elementorFrontend.elements is undefined
    JS: 2019-01-14 17:48:31 [error X 2][https://whisperingfuture.com/wp-admin/js/editor.min.js:1:459] Unable to get property \’get\’ of undefined or null reference
    JS: 2019-01-14 17:48:31 [error X 2][https://whisperingfuture.com/wp-content/plugins/elementor/assets/js/editor.min.js:2:207442] Unable to get property \’on\’ of undefined or null reference
    JS: 2019-01-14 17:48:40 [error X 4][https://whisperingfuture.com/wp-content/plugins/elementor/assets/js/editor.min.js:2:207546] \’tinymce\’ is not defined

    I don’t know how to fix that problem, if someone can help me please.

    Crael

    The page I need help with: [log in to see the link]

Viewing 7 replies - 16 through 22 (of 22 total)
  • @logologics

    Well the problem is not completly solved. I don’t have to enable the safe mode, but I can edit the text widget only in HTML and I don’t have acces to the style and advanced section. Also after I can’t edit another widget…

    But yes, since I’d clear the cache (I keep W3TC), it’s better…

    Crael

    Strange situation, not sure but the cache thing seems to be the bad guy somehow.

    PHP: showing 20 of 35PHP: 2019-01-14 18:22:14 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/88658.js_gzip_meta_old): No such file or directory [array

    ok after a week of test, nothing happen… I tried a lot to fix the cache problem, but it doesn’t seems to work also.

    Here is my system information in elementor:

    JS: showing 7 of 7JS: 2019-01-21 03:23:22 [error X 50][https://whisperingfuture.com/wp-admin/js/editor.min.js?ver=5.0.3:1:459] w is undefined
    JS: 2019-01-21 03:23:22 [error X 50][https://whisperingfuture.com/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.4.2:2:209243] e.editor is null
    JS: 2019-01-21 03:23:26 [error X 81][https://whisperingfuture.com/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.4.2:2:209425] tinymce is not defined
    JS: 2019-02-05 14:12:54 [error X 3][https://whisperingfuture.com/wp-content/plugins/elementor/assets/js/editor.min.js:2:74603] setting getter-only property \”type\”
    JS: 2019-02-12 19:37:56 [error X 1][https://whisperingfuture.com/wp-admin/js/editor.min.js:1:459] Unable to get property \’get\’ of undefined or null reference
    JS: 2019-02-12 19:37:56 [error X 1][https://whisperingfuture.com/wp-content/plugins/elementor/assets/js/editor.min.js:2:209372] Unable to get property \’on\’ of undefined or null reference
    JS: 2019-02-12 19:38:00 [error X 1][https://whisperingfuture.com/wp-content/plugins/elementor/assets/js/editor.min.js:2:209476] \’tinymce\’ is not defined

    PHP: showing 1 of 1PHP: 2019-01-21 04:38:48 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/sucuri-scanner/src/cache.lib.php::398] file_put_contents(): Filename cannot be empty [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]

    If someone have an idea…

    Crael

    Hi Crael,
    not sure if it’s your case, however elementor didn’t work for me either.
    I had a similar issue and had to use it in ‘safe mode’.

    I found out that the error was caused by insufficient resources. I simply added some extra memory. Here’s what I did:
    – opened cPanel
    – found MultiPHP INI Editor
    – changed memory_limit to 256M
    By doing this every error disappeared like snow in the sun.

    I hope it helps.

    @patedge thanks for your reply.

    I’m already at 256M memory limit, I tried more, but nothing happen also…

    Crael.

    upload_max_filesize = 768M
    post_max_size =768M
    memory_limit = 768M
    max_execution_time = 300

    I gave my Ubuntu server 2 vCPUs and 3GB of RAM. I think something with PHP 7.3 is causing it.

    I’m not using PHP 7.3, but yes I tried to use other version of it.

    Crael

Viewing 7 replies - 16 through 22 (of 22 total)
  • The topic ‘Elementor doesn’t work’ is closed to new replies.