Support » Plugin: Elementor Page Builder » Elementor doesn’t work

  • Resolved crael

    (@crael)


    Hello,

    I’d just updated elementor and the wordpress version (4.9.9 to 5.0.3) and elementor doesn’t work now. It suggest me to activated Safe Mode but I can’t do nothing after that. I tried to:
    – Disable all the plugin
    – Switch theme
    – Switch Browser
    – Save my permalinks one more time
    – Disable rocket loader
    – Switch front-end editor loader method

    I got this on the information system:

    == Log ==
    :
    PHP: showing 20 of 35PHP: 2019-01-14 18:22:14 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/88658.js_gzip_meta_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 18:22:14 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/910e7.css_gzip_meta_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 18:26:54 [notice X 13][/home/curiosity/whisperingfuture.com/wp-content/plugins/ocean-extra/includes/widgets/custom-menu.php::235] Undefined index: target [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 18:29:27 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/affbe.js_gzip_meta_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 18:32:35 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/9f110.js_gzip_meta_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 18:36:31 [notice X 6][/home/curiosity/whisperingfuture.com/wp-login.php::1079] Undefined variable: error [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 18:36:32 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/bee59.css_gzip_meta_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 18:36:33 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/df983.js_gzip_meta_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 18:39:11 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/4ffe0.js_gzip_meta_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 18:47:01 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/17d34.css_gzip_meta_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 18:47:40 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/362cd.css_gzip_meta_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 18:47:41 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/10fb3.js_gzip_meta_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 18:47:49 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/0b76b.js_gzip_meta_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 18:47:54 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/506c8.js_gzip_meta_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 18:48:00 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/36ce3.css_gzip_meta_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 18:50:52 [notice X 1][/home/curiosity/whisperingfuture.com/wp-includes/SimplePie/Registry.php::215] Non-static method WP_Feed_Cache::create() should not be called statically [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 19:27:54 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/Cache_File_Generic.php::78] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/page_enhanced/whisperingfuture.com/wp-content/plugins/wp-asset-clean-up/freemius/assets/css/admin/plugin-upgrade-notice.css/_index_ssl.html_gzip_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 19:28:51 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/2f8b8.css_gzip_meta_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 19:28:54 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/cd7fc.js_gzip_meta_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]
    PHP: 2019-01-14 19:28:56 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/9a0fe.js_gzip_meta_old): No such file or directory [array (
    ‘trace’ => ‘
    #0: Elementor\Core\Logger\Manager -> shutdown()
    ‘,
    )]

    JS: showing 7 of 7JS: 2019-01-14 17:04:47 [error X 3][https://whisperingfuture.com/wp-admin/js/editor.min.js?ver=5.0.3:1:459] w is undefined
    JS: 2019-01-14 17:04:47 [error X 3][https://whisperingfuture.com/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.4.0:2:207442] e.editor is null
    JS: 2019-01-14 17:05:31 [error X 19][https://whisperingfuture.com/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.4.0:2:207624] tinymce is not defined
    JS: 2019-01-14 17:20:34 [error X 2][https://whisperingfuture.com/wp-content/plugins/elementor/assets/js/editor.min.js?ver=2.4.0:2:82730] elementorFrontend.elements is undefined
    JS: 2019-01-14 17:48:31 [error X 2][https://whisperingfuture.com/wp-admin/js/editor.min.js:1:459] Unable to get property \’get\’ of undefined or null reference
    JS: 2019-01-14 17:48:31 [error X 2][https://whisperingfuture.com/wp-content/plugins/elementor/assets/js/editor.min.js:2:207442] Unable to get property \’on\’ of undefined or null reference
    JS: 2019-01-14 17:48:40 [error X 4][https://whisperingfuture.com/wp-content/plugins/elementor/assets/js/editor.min.js:2:207546] \’tinymce\’ is not defined

    I don’t know how to fix that problem, if someone can help me please.

    Crael

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 22 total)
  • I just updated Elementor today and I’m having the same problems aswel. I’m not sure how to fix it. I tried all the same suggestions and nothing happened.

    I had to roll back to previous version of Elementor and it started working again. At least until the problem is fixed.

    David

    I tried to roll back to previous version also, but it doesn’t work at all, it doesn’t even load now.

    Hi, we have some clients who are getting this error as well. Is there any resolution available?

    I did a plugin conflict test and it was a conflict with Remove query strings plugin.

    I disabled it and the new elementor update is working now

    I already did a plugin conflict test, it doesn’t work for me.

    And the updates today doesn’t fix the problem either.

    Sorry ><

    I have the same problem. All the content of the site looks fine, but I can’t edit it. I can’t find any solution…

    I had the same issue recently and I managed to fix it.
    In my case the problem was either Element Pack and Essential Addons for Elementor.

    Disabling all the modules except the only few I use (Modal and Dual Button), Elementor went back to normal.

    If you have one of the above mentioned plugins, that’s your issue.

    I hope it helps!

    Pat

    I have already disable all the plugin, including those one, I re-try, and it doesn’t change anything ><

    Crael.

    crael

    (@crael)

    Hello,

    Still doesn’t work after the last update…

    cpliso

    (@cpliso)

    Same as @crael. Today’s update has not fixed the issue. Very strange, Elementor was working great till 16th January. Now when i click on “Modify with Elementor” nothing happens.

    What should i do ?

    Ok now it still asking me for loading in safe mode, evrything seems to work fine instead of the text editor. When I’m trying to edit this widget, everything is broken…

    Crael

    Hi,

    In your error log this pops out:

    PHP: 2019-01-14 18:22:14 [warning X 1][/home/curiosity/whisperingfuture.com/wp-content/plugins/w3-total-cache/lib/Minify/Minify/Cache/File.php::56] unlink(/home/curiosity/whisperingfuture.com/wp-content/cache/minify/910e7.css_gzip_meta_old): No such file or directory [array (
    โ€˜traceโ€™ => โ€˜

    Looks like W3total cache is causing issues?
    I used this years ago, but did not like it, gave all sorts of issues back then.

    Have you cleared all cache and left over of this plugin ( I found it a very hard to completely remove all of it back then ) before deactiving it?

    Aha, I investigated your sourcecode and found this:

    https://ajax.cloudflare.com/cdn-cgi/scripts/cb7744ae/cloudflare-static/rocket-loader.min.js

    The rocketloader in Cloudflare is a known issue causer.
    https://docs.elementor.com/article/360-elementor-cloudflare-rocket-loader

    Please turn that feature off in Cloudflare, clear ALL cache and see if this helps.

    Annie

    • This reply was modified 9 months, 3 weeks ago by LogoLogics.

    @logologics thanks for your answers ๐Ÿ™‚

    So I did what you said, the weird thing is Elementor doesn’t ask me to enable the safe mode, but I still have the same problem.

    I can edit everything fine instead of the text editor (well I can edit it in html only, but I don’t have the acces to the style edition…). And again after that, I can’t edit anything.

    I know about the rocket loader issues, but I did put rules to load elementor without it.

    But it seems that the cache was a problem.

    Crael

    @crael

    Ok, so you say `it seems that the cache WAS a problem.
    Do you mean it is solved now by clearing cache or diabling W total cache=

    Annie

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Elementor doesn’t work’ is closed to new replies.