WordPress.org

Support

Support » Themes and Templates » Elegant themes tim thumb version not working on cloud hosting

Elegant themes tim thumb version not working on cloud hosting

Viewing 9 replies - 1 through 9 (of 9 total)
  • Chip Bennett

    @chipbennett

    Theme Review Admin

    As Elegant Themes is a commercial Theme shop, that provides commercial support for their products, you should consult their support offerings.

    Also: TimThunb should be considered as an inherent security risk on any WordPress site. I strongly recommend against using any Theme or Plugin that incorporates TimThumb.

    Some ISP are not supporting TimThumb and blocking it, due to the recent security issue.

    This one might be a WordPress settings issue rather than a premium theme one, could be as simple as Settings > Permalinks and just pressing ‘Save’ to rebuild the links!

    HTH

    David

    @chip thank mate, I realise this is a premium theme but my account with them expired, and I got no support the whole year I had it, and now the owner denies support unless I sign up again so don’t think it’s quite fair. The theme uses it’s own version of image resizing based on timthumb, which has patched the security issue so no worries there.

    @adeptris Thanks mate, I’ve tried resetting the permalinks to no avail.

    Looks like my only option is to rebuild the theme in those parts to just use images inserted into posts, though would of liked to avoid that as it is a fair bit of work.

    Any other ideas out there?

    I have see and answered this before where there is an extra slash or slash is missing from the website url, or there is no http://

    Check the Settings > General > WordPress Address (URL) and Site Address (URL)

    These should be in the format http:// siteaddress .extention, with no trailing slash

    Like http://asasigns.com.au

    You have a strange www// before the ‘/wp-content` so it looks like a setup issue!

    HTH

    David

    Just done a quick search and found this topic, it is 3 years old though:

    At the end of the instructions it says “If you have problems with missing images that you’ve uploaded, you need to change the path to the images on every post directly on your SQL database.”

    HTH

    David

    Thanks David, but I changed all the urls in the database already and as you can see all the regular images work, it is only the images generated by the thumbnail php script. I’m not sure why it is adding the extra trailing slash as I have even searched the database for this error, but it is not present, so I am certain it is something to do with the php script that resizes and displays the featured thumbs.

    You could post the script up on http://pastebin.com you might get some more answers!

    David

    Still no luck with this can anyone help out on this.

    here is the URL http://asasigns.com.au/

    I just can’t get the images to load from the script used to auto resize images. should i just rebuild the theme to use another method?

    esmi

    @esmi

    Forum Moderator

    I’m sorry but as you are using a commercial theme, you need to seek support from the theme’s vendors.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Elegant themes tim thumb version not working on cloud hosting’ is closed to new replies.