WordPress.org

Support

Support » Themes and Templates » [Resolved] Elegant Themes – Divi – Page Builder not working

[Resolved] Elegant Themes – Divi – Page Builder not working

  • I have downloaded the Divi theme from Elegant Themes.

    All was going well, I loved the theme. After a while Page Builder stopped showing when I was editing a page. After lots of messing around and restarting my computer it came back again.

    That was yesterday, same happened today. The Page Builder modules disappear when I go to edit the page leaving me stranded. I thought it might be Safari so I tried it on Chrome, same issue. I then tried it on another Mac. Same issue. I have also re-installed WP and also re-installed the theme to no avail.

    Any ideas?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Hey,

    I was having the same problem. I updated my WP and it started working. Maybe you can also try and do it.

    Nope! I am already on WP 3.8.2. I reinstalled it but it didn’t help. I am doomed to see sudden disappearance of part of the page builder modules in my home page (theme DIVI from Elegant Themes). I had made a small change in the content and clicked ‘update’ when this happened. Now half of the page content is missing. When I reload the home page in WP control panel, it endlessely shows a small moving circle in the center (indicating waiting for the missing modules to load).

    Im having the same issues… and I have a clean install – only DiVi and elegant builder installed.

    Anyone know whats up with this?

    I am having the same problem but I have Divi version 1.3 installed. What version is everyone else using? The current version is 1.9.1

    same problem. Worked fine then one minute it just stopped, just keep getting a spinning graphic. any updates on this?

    esmi

    @esmi

    Forum Moderator

    I’m sorry but as you all appear to be using a commercial theme, you need to seek support from the theme’s developer/vendor. We do not support commercial products here.
    Try http://www.elegantthemes.com/forum/

    esmi,
    my membership just expired and now I am stick literally the same problem on the DIVI theme,
    it sucks if I have to take membership again just to get an answer for this.

    Some solace that many others are having the same problem hopefully someone can explain what’s going on.

    I was experiencing the problem running Divi version 1.3 on a couple wordpress installs. A couple 3.8.3 and one on 3.9. I just renewed my membership and updated to Divi 1.9 on all my sites and the everything is working great. I highly recommend renewing you membership and subscribing to the newsletter with Elegant Themes. $90/yr. is well worth their services. Below is the current change log:

    version 1.9.1 ( updated 04-21-2014 )
    - Fixed Page Builder issues in IE9 and IE10
    	* et-pagebuilder/js/admin.js
    - Bumped version number
    	* style.css
    
    version 1.9 ( updated 04-17-2014 )
    - Corrected js files version number
    	* et-pagebuilder/et-pagebuilder.php
    - Bumped version number
    	* style.css
    
    version 1.8 ( updated 04-15-2014 )
    - The theme is compatible with WordPress 3.9 now
    	* et-pagebuilder/js/admin.js
    	* et-pagebuilder/css/style.css
    
    version 1.7 ( updated 03-06-2014 )
    - Fixed the issue with Blog and Portfolio modules pagination on static frontpage
    - Fixed the issue with video background in a section, overlaying any content within the section
    	* functions.php
    - Fixed mega menu styling at 960 breakpoint
    - Adjusted slider arrow positioning at small sizes
    - Improved readability of slider text
    - Fixed slider padding issue at mobile breakpoint
    - Consolidated header styles
    - Adjusted newsletter styling for added consistency
    - Changed Blurb & Toggle headings for improved hierarchy
    - Adjusted WooCommerce headings for added consistency
    - Adjusted portfolio headings for added consistency
    - Styled the search widget
    - Bumped version number
    	* style.css
    
    version 1.6 ( updated 02-26-2014 )
    - Added the slide link to heading in the Slider module
    - Fixed the issue with the separator symbol, appearing in the wrong place, when some items are disabled in the post info section.
    - Fixed validation errors in slider and section modules
    - Added "New Message From 'Site Name' - 'Contact Form Title'" to the email title field
    	* functions.php
    - Fixed the issue with resizing of images that have the x symbol between width and height values in the filename
    - Fixed the issue with .jpeg images and uppercase extensions in cached files
    - The theme doesn't strip slashes from custom css now, when saving the option to the database
    - Removed buzz shortcode ( Google retired Buzz )
    - Fixed ePanel SEO home options not appearing on static front page
    - Better compatibility with WordPress SEO and All In One SEO Pack plugins. ePanel SEO is disabled if these plugins are active now.
    	* epanel/core_functions.php
    	* epanel/custom_functions.php
    	* epanel/shortcodes/shortcodes.php
    - Disabled lazy loading animations on mobile devices
    - 'Slide Text Color' option affects navigation arrows and controls color now in the Slider Module
    	* js/custom.js
    	* style.css
    - Fixed the issue with "Disable Top Menu Links" option in ePanel
    	* js/custom.js
    - Fixed WooCommerce styling issues
    - Fixed the issue with post content, visible in tiled blog posts at 320 breakpoint
    - Fixed the issue with Portfolio module images not visible in IE8
    - Fixed the issue with mediaelementjs videos not displaying correctly in full-screen mode in IE10 and IE11
    - Fixed tiled blog post styling in 1/4 column at 480 and 320 breakpoints
    - Fixed Contact form module styling at 768px breakpoint
    - Bumped version number
    	* style.css
    
    version 1.5 ( updated 02-18-2014 )
    - Fixed 'Your theme has bundled outdated copies of WooCommerce template files' warning message
    	* functions.php
    	* deleted woocommerce folder
    - Fixed Review form styling
    - Bumped version number
    	* style.css
    
    version 1.4 ( updated 02-11-2014 )
    - Fixed WooCommerce Sidebar Error
    - Added Anti Aliasing
    - Fixed the issue with megamenu dropdown links visibility
    - Fixed Counters animation in Firefox
    - Fixed a typo in Porfolio module title
    - Fixed 'multiple sliders on one page' issues
    - Fixed the issue with hidden checkboxes and radio elements
    
    List of modified files:
    * style.css
    * js/custom.js
    * et-pagebuilder/et-pagebuilder.php
    * functions.php
    
    version 1.3 ( updated 01-14-2014 )
    - Fixed the issue with multiple categories selected in the Portfolio module
    - Fixed the issue with the Contact Form module, not using the Email setting
    - Fixed the issue with the More Tag in the Blog module
    - Added 'Fixed Navigation Bar' option
    - Added 'Automatic slider animation' option
    - Added id and class options to modules. Defined et-hide-mobile class, it can be used to hide the module on mobile devices.
    - Fixed validation issues with Contact form and top menu
    - Fixed Color Schemes options not saving in the Customizer
    - Fixed Text Orientation in the Blurb module
    - Fixed the issue with Footer Widget Areas not styled in the Sidebar module
    - Fixed the issue with dropdown menu not showing in Safari and iPad in landscape mode
    - Removed Cropping from standard blog posts featured images
    - Slider arrows are shown at all times on mobile devices now
    - Added 'Image Vertical Alignment' option to the Slider module
    - Added localization for the Subscribe Module
    - Added link to the Blurb module image
    - Added 'open in a new window' option to the Image module
    - Added 'Text orientation' option to the Fullwidth Header module
    - Applied fitVids jQuery plugin to all videos
    - Added 'No Animation' option to Image and Blurb modules
    - Fixed 'Bottom To Top' animation
    - Fixed Pricing tables columns structure in 1/3, 2/3, 1/4, 1/2 columns
    - Removed cropping from the main product image
    - Removed default iOS form elements styling
    - Fixed Calendar widget styling
    - Fixed video embedding issues
    - Fixed the issue with sub menu, displayed behind embedded videos
    - Fixed 1/3 and 1/4 tab modules display on mobile breakpoints
    - Fixed 3.8 admin bar front-end styling on mobile devices
    - Fixed Products pages styling
    - Fixed Blog module styling in 1/4 column
    - Fixed pagination styling for blog/shop/portfolio pages
    - Fixed the issue with Slide Video not displaying in Firefox
    - Fixed slider description text width at mobile sizes
    - Fixed pricing table styling at 768px breakpoint
    - Fixed 1/3 and 1/4 column styling at 768px breakpoint
    - Fixed shop module styling at 768px breakpoint
    - Fixed slider module youtube videos size for all columns
    - Fixed the issue with pagination on search pages
    
    List of modified files:
    * epanel/options_divi.php
    * epanel/post_thumbnails_divi.php
    * et-pagebuilder/et-pagebuilder.php
    * functions.php
    * header.php
    * includes/functions/sidebars.php
    * index.php
    * js/custom.js
    * lang/de_DE.mo
    * lang/de_DE.po
    * lang/en_US.mo
    * lang/en_US.po
    * lang/ru_RU.mo
    * lang/ru_RU.po
    * page.php
    * single.php
    * style.css
    
    version 1.2 ( updated 12-23-2013 )
    - Now you can update Elegant Themes in the Dashboard: https://www.elegantthemes.com/members-area/documentation.html#updater
    	* epanel/custom_functions.php
    - Bumped version number
    	* style.css
    
    version 1.1 ( updated 12-11-2013 )
    - Fixed errors with the theme on some servers
    	* et-pagebuilder/et-pagebuilder.php
    - Fixed issues with saving layouts with no modules
    	* et-pagebuilder/js/admin.js
    - Fixed Search Icon bug in Firefox
    	* style.css
    - Fixed the issue with flashing image in the slider with video preloader
    	* functions.php
    	* js/custom.js
    
    version 1.0
    
    - initial release

    I can confirm that Divi 1.9 is compatible with WordPress 3.9

    I had the problem of the page builder not loading, but this was fixed after I updated DIVI.

    I think it has something to do with the older versions of DIVI not being compatible with Wordpres 3.9.

    My problem is fixed now.

    I am using latest version of divi theme and wordpress. But the page builder is not working and showing. Then I checked the plugins by deactive one by one. Finally I found “InfiniteWP – Client” plugin. When I deactivated the plugin then the DIVI page builder is working well.

    Thanks,
    Toihid

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] Elegant Themes – Divi – Page Builder not working’ is closed to new replies.
Skip to toolbar