Support » Plugin: WooCommerce » Either “offers”, “review”, or “aggregateRating” should be specified error

  • Resolved billium99

    (@billium99)


    Hello! Nearly every WooCommerce shop I manage is getting Google Search Console errors “Either “offers”, “review”, or “aggregateRating” should be specified”

    And I’m getting warnings such as “Missing field “sku”

    Missing field “description”

    Missing field “image”

    Missing field “url”

    Missing field “priceValidUntil”

    Another 7 month old thread says this was resolved with an update, and I am running well-past the versions identified in that thread.
    3.7.1 currently.

    But these are functional Woo products. Any idea what this issue is and why it keeps cropping up?

    Thanks

    Bill

    The page I need help with: [log in to see the link]

Viewing 10 replies - 16 through 25 (of 25 total)
  • Sn00z389

    (@webmakers2011)

    Hi all, yes this is not a good fix for that… For many years Woocommerce fails to make good rich snippets and I think it should be a top priority, since we do not have our reviews in Google anymore.

    Also, we have never got the price and the stock status in Google either, so this is a must for next version of WC.

    Plugin Support madeincosmos

    (@madeincosmos)

    Automattic Happiness Engineer

    Hi everyone,

    Thank you for your explanations, and for all the troubleshooting you’ve done so far. I reproduced the errors in search console on a clean installation, so this is a different problem than we thought at first. I’ve reopened the GitHub issue so that our developers can check this again. You can keep track of the progress here:

    https://github.com/woocommerce/woocommerce/issues/24862

    Thanks!

    same problem here.

    Really need a fix asap because my site is dopping dramatically 🙁

    I can confirm that the temporary functions.php solution posted above does resolve the issue.

    So it’s just a case of making sure that the permanent fix is rolled out to the next stable release of the WooCommerce plugin.

    Arysto

    (@arysto)

    Either “offers”, “review”, or “aggregateRating” should be specified error I have the same issue including on pages with reviews.

    Plugin Support Amanda

    (@amandasjackson)

    The fix will be released in the next version of WooCommerce:

    https://github.com/woocommerce/woocommerce/issues/24862#issuecomment-553868961

    I did not have errors until I updated to 3.8 ….

    ‘offers’, ‘review’ of ‘aggregateRating’ moet zijn gespecificeerd
    Voor het eerst gedetecteerd: 27-11-2019
    Status: Fout

    So, you might have fixed something but you also seem to have broken something.
    I never had errors before, not an any woocommerce installation I manage.

    Adding: besides upgrading to woocommerce 3.8 there also was for the first time a review on a product. So this 2 events (upgrade + first review) might have somewhere an impact why now getting errors.

    Another update: It is actually the product reviewed that gets the error in search console…

    • This reply was modified 2 weeks, 1 day ago by Pascal77.
    • This reply was modified 2 weeks, 1 day ago by Pascal77.
    Pascal77

    (@pascal77)

    3.8.1 => fixed, only have 2 warnings with product now.

    Good work!

    Morgan Hvidt

    (@morganhvidt)

    I’ve just updated to the released WooCommerce 3.8.1.
    I can confirm the update fixed the schema error 😄

    Plugin Support Amanda

    (@amandasjackson)

    @morganhvidt @pascal77

    Wonderful! Thanks for the update and letting us know that the released fixed the issue 🙂

Viewing 10 replies - 16 through 25 (of 25 total)
  • You must be logged in to reply to this topic.