[EGA 2.0] Problems with accentuated letters in file names for encoded URLs (3 posts)

  1. JohanPirlouit
    Posted 2 years ago #

    Hi everyine, hi EmmanuelG,

    Again thank you for your plugin ;-)

    Though it is not good to do it, more and more people use accentuated letters regarding their language (letters such as "àéèïôù" in french) in the names they give to their files.

    WordPress allows the use of localized alphabets (at least WP 3.6+) but EG-Attachments currently filters it in the attachement URL making some "404 not found" result...

    For example, a file originally named "Visuel séjour désert.pptx" is renamed "Visuel-séjour-désert.pptx" by WP and is filtered as "Visuel-sejour-desert.pptx" by EG-Attachments, so the document can not be found.

    The problem occurs only when the link setting is set to "Direct" (default setting) in the General EG-Attachments settings. Two other settings ("Permalink" and "File") are OK.

    Is it a bug or a WP issue?

    I use WP 3.7.1 and EG-Attachments 2.0.0. I currently work on a developpement website so it is not online yet...



  2. emmanuelg
    Plugin Author

    Posted 2 years ago #


    It's a WP issue for a long time.

    I know that a ticket is opened on this subject. But the resolution was postponed to WP 3.8.

    However, I will add a workaround in the coming version (I have to test it)


  3. emmanuelg
    Plugin Author

    Posted 1 year ago #


    I added a filter to manage special characters, in the version 2.0.1.


Topic Closed

This topic has been closed to new replies.

About this Plugin

  • EG-Attachments
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic