Support » Fixing WordPress » edit.php and theme editor

  • Resolved emarsh


    I have a few possibly related problems.
    I had the blank page problem that otherse have reported, but I modified .htaccess to allow 16MB for PHP and that has gone away, but I still cannot access edit.php. It is totally blank.

    I also have a new problem with theme editor and template.php. Theme editor does not see files for Connections, although it did before. It says the theme file are in /, but won’t let me edit. If I delete connections, it lets me edit WP Default and Classic Themes. With connections in there, I can edit Classic but not default. Same thing happens in template.php, when I click on “Files”. I get the following error in a pink bubble:

    Oops, no such file exists! Double check the name and try again, merci.

    I am running 2.0.4 and haven’t changed anything recently.

Viewing 10 replies - 1 through 10 (of 10 total)
  • I wish I had answers for you because the same thing happened to me last night. I’ve been messing around with permissions etc since then and I still can’t edit anything. It worked fine two days ago and now it will only show style.css in the file and theme editor. I try to click on header.php to edit and it just refreshes back to style.css.

    When I try to edit the header.php directly through .ftp client, it pulls it in a link instead of editable text. I’ve tried everything I can think of; of course recognizing I have limited experience!

    Btw…this is a new install of WP 2.0.4 and it worked fine two days ago. The only difference between two days ago and now is I blogged three times. *scratches head*

    Any suggestions would be appreciated. Is it possible that a plugin wrote something to one of the files? I’ve double checked all the permissions and oddly enough the only one that pulls up funky is header.php. If I view it on the .ftp client the text shows up, but if I pull it to edit, it comes up with only two page links and I can’t edit. Yes I tried a fresh re-stall of that file. Same problem. That’s why I’m thinking it could be a plugin.

    I just don’t get it. I want to be able to manage my posts, but it just won’t load, and the theme thing makes me a little antsy too. Does anyone have any clue as to what this could be?

    Have you contacted your host to see if they’ve changed the mod_security ruleset recently? I don’t KNOW that that’s the problem, but some of the wonkiness I’ve been having lately is directly attributable to that.

    yeah, i did, and they say nothing has changed.

    I had same problem tonight and was convinced it had to be one of my plugins. I turned off the most reacent one by one until I found it was Post Tools. tested it over and over

    activated = broken, deactivated = fixed, activated = broken..

    u get the picture.

    no idea what it is about this plugin that breaks theme-editor.php perhaps it is an htaccess thing.. i didn’t bother looking into it since post tools was useless for me anyway

    Intersting. I don’t have post tools, but I have disabled most of my plugins, but nothing seems to work. I was thinking about putting another htaccess in the subdir for edit.php and see what happens. Confusing and frustrating.

    This is frustrating. I am hoping the next upgrade might fix this. In the meantime, take a look at my .htaccess and tell me if I put the memory thing in the right place.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    # Redirect FeedBurner to your own Feed
    RewriteBase /blog/
    RewriteRule ^feedburner_885568/?$ /blog/feed/ [R,L]
    RewriteCond %{HTTP_USER_AGENT} ^FeedBurner.*$
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]
    # Feed Redirect Rules will go here
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]
    php_value memory_limit "24M"
    # END WordPress

    I have Post Tools! I just deactivated that plugin and voila, my problem was fixed! Thanks so much!

    I hope you get your problem resolved “emarsh” as well!

    Nope, not fixed yet. I just upgraded to 2.0.5 and same problem. I was able to get an error message on clicking “manage” though:

    Fatal error: Allowed memory size of 25165824 bytes exhausted (tried to allocate 40 bytes) in /home/erikmar/public_html/blog/wp-includes/functions.php on line 1471

    Does anyone know what this means or how to fix it?

    I changed the PHP memory thing up to 32MB and that did the trick. Seems a little excessive, but it’s working.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘edit.php and theme editor’ is closed to new replies.