Support » Plugin: Editorial Calendar » Editorial Calendar 1.3 Broken in Chrome?

  • I just installed the latest update to the wonderful Editorial Calendar Plugin.

    I find that in Chrome (but not in Firefox nor in IE), the calendar will no longer show any posts in the daily boxes.

    On top of this, using the navigation arrows in the top line, which should switch between various sets of three weeks each, will only work for the first few clicks. After that, clicking the arrows will no longer move the screen to another set, and further clicking destroys the whole table, eventually leaving a large blank rectangle where the days and weeks used to show.

    Because the problem is completely new and restricted to Chrome, I’m thinking it might be some bug in the new update. But if there is something at my end I could do to fix this, I would of course be grateful for any advice.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Zack Grossbart


    Thank you for using the Editorial Calendar. I’m sorry you’re seeing this issue.

    I’ve tested the latest version of the calendar using Chrome 10.0.612.3 dev on Windows 7 and everything is working well for me. What version of Chrome are you using and what operating system?

    You can find your Chrome version by clicking on the little wrench and selecting About Google Chrome.

    Thank you,

    Thank you for your response!

    I’m working with Windows 7 and Chrome 8.0.552.224 .

    Here are three pics to show what I’m talking about:

    In IE, the calendar properly displays several posts, both drafted and published:

    In Chrome, the first view of the calendar shows the same days and weeks, but omits all posts:

    Still in Chrome, and after using the arrows in the top row to move backwards and forwards in time for a while, the calendar table looks erased:

    Thank you for your time and effort, Stephen

    Plugin Author Zack Grossbart


    It looks like the dev version of Chrome is a bit ahead of the stable release.

    I just tried this using Chrome 8.0.552.224 on Windows XP and didn’t see any issues.

    There are two more things to try.

    The Editorial Calendar comes with a set of unit tests. You can access them by adding the parameter qunit=true to the end of the URL for the calendar. If your normal URL for the calendar is:

    Then the unit test URL is:

    All you need to do is access this page and the unit tests will show up below the calendar. You’ll see the calendar jump around while the tests run. They should take less than 30 seconds. If you could run these tests and see if they all pass that would help us diagnose the problem.

    The second place to look is the JavaScript console. If you click on the little wrench and select Tools > JavaScript console a new window will pop up. On the bottom of that window there will be a console. Look for errors in there and let me know what you find.

    Thank you very much for helping me debug this issue.


    So three things happened with the unit test:

    1) A red rectangle came up: “Looks like somebody already moved this post. Unit test post” (or something similar; it only showed up for a short moment).

    2) The following results appeared:

    Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/534.10 (KHTML, like Gecko) Chrome/8.0.552.224 Safari/534.10
    Move to today and check visible dates (0, 2, 2)
    Move 1 week in the future and check visible dates (0, 2, 2)
    Move 4 week in the future and check visible dates (0, 2, 2)
    Move 8 week in the past and check visible dates (0, 2, 2)
    Create a new post (0, 3, 3)
    Get post information (0, 2, 2)
    Change the date of an existing post (0, 2, 2)
    Make a second change to the date of an existing post (0, 2, 2)
    Edit the content of an existing post and mark it as scheduled (0, 2, 2)
    Try to change a post date and fail because of a concurrency conflict (0, 2, 2)
    Delete the post created for testing (0, 1, 1)
    Tests completed in 14064 milliseconds.
    22 tests of 22 passed, 0 failed.

    test markup

    3) The calendar started working again as it should directly after running the tests. So far, I have been unable to recreate the previous errors, even by logging out and back into the dashboard. I’m glad, of course, although unsure whether the bugs will return in the future, since I’m not sure how this got rid of them.

    The only error listed in the java script console is a
    “Failed to load resource: the server responded with a status of 404 (Not Found)”
    on …/wp-content/plugins/edcal/lib/qunit.css . No errors appeared there during the previous malfunctions of the calendar before running the unit tests.

    Plugin Author Zack Grossbart


    The red rectangle is normal. One of the tests is testing what happens if you edit a post at the same time as someone else. In that case you get the error you saw.

    It looks like all the tests have passed, but I have no idea why running those tests would fix this issue. You don’t see any issues with Chrome now, right?

    Right. I have been trying a number of things today since running the tests, and I have not seen any problems whatsoever. I am a bit torn between my joy over having a working calendar back in Chrome, and my uneasiness in not knowing what went wrong and how it got fixed.

    If I do see another problem, I’ll post it here.

    Meanwhile, let me say again how immensely useful this tool is for my blogging practice; it makes a great difference, which these small problems helped drive home for me, and I’m really grateful.

    I had a similar problem and realized it started happening after I added a filter to the time() function. I was using a timeago function to give my posts the look and feel of “1 day ago”. After adding add_filter(‘the_time’, ‘timeago’) The calendar stopped working.

    Commenting this filter out, and boom everything worked as planned.

    Interesting. But I wasn’t doing anything of the kind when the same problem happened on my blog.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Editorial Calendar 1.3 Broken in Chrome?’ is closed to new replies.