Support » Plugin: CKEditor WYSIWYG for Gravity Forms » Editor won’t display in HTML and out-of-the-box for PARAGRAPH

  • Resolved emmashwp

    (@emmashwp)


    Hi!

    Everything was working before but now : Editor won’t display anymore in my HTML fields… Also, if I activate editor in PARAGRAPH fields, I can’t enter text in the editor (lock/disabled)… I can enter text in the old textarea field and my text is display under the visual editor… so weird.

    Can you help me please??

    Thanks!

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author ovann86

    (@ovann86)

    Hi,

    I think I see what the issue is – a misplaced bracket in the JavaScript.

    I’ll push out a fix in version 1.9.1 shortly – let me know if it helps.

    Sorry… same problem again :/

    Please see printscreens of HTML and Paragraph fields: https://s12.postimg.org/bc4mw4mot/problem.jpg

    Thanks!

    Plugin Author ovann86

    (@ovann86)

    Can you confirm that ‘Enable in form editor’ is ticked in the Forms -> Settings -> WYSIWYG CKEditor settings page?

    The CKEditor I see in that picture is just a ‘preview’ – to show the field is CKEditor enabled for the front end form.

    To get the CKEditor in the form editor (for making HTML in the description easier) it should be as simple as ticking ‘Enable in form editor’. Which I thought it was by default, but I’m starting to have doubts.

    Any idea?

    Plugin Author ovann86

    (@ovann86)

    It’s a bit hard without being able to see. There could be a JavaScript error that’s preventing the editor from loading?

    Do you know how to open up the browser debug console to check for error messages?

    Basically, open the form/page
    Hit F12 on your keyboard
    A pane should appear at the bottom
    A part of the new pane will be a ‘console’ – it’ll be mostly empty until you start doing things like editing fields.
    Open the HTML field and note and errors. Could be a conflict or failure to load a required resource?

    No error at all in the console… I also try the debug mode and no error… I try disabled other plug-in and no difference…

    And when I disabled the extension CK, the display of a paragraph field continue to be weird :
    http://s9.postimg.org/w2oex1se7/problem3.jpg

    Maybe I should contact GF?

    Plugin Author ovann86

    (@ovann86)

    Hey,

    I’ve worked out what the issue is.

    It stemmed from a combination of adding the ability to configure the CKEditor toolbar on a per-field basis as well as moving the JavaScript to an external file.

    This issue only happens when a new form has been created or no fields have been CKEditor enabled.

    I’ll push out an update shortly that should fix it up.

    Ok!! Thanks and let me know when the update will be available!

    Yeah!! The update resolve the problem!! Thanks a lot!! 🙂

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Editor won’t display in HTML and out-of-the-box for PARAGRAPH’ is closed to new replies.