Support » Plugin: Lively Chat via SMS » editor role vistor notification

  • Hi there,

    Brilliant plugin, thanks for sharing with us all!

    Quick question, I have the basic free version and I have set an editor as the Agent however when logged in as an editor, no new visitor appears when someone starts a session. i.e. under the visitors tab the name of the person and the green circle wont appear.

    Any help would be great.

    Thank You!

    https://wordpress.org/plugins/lively-chat-support/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author remetric

    (@dallas22ca)

    Thanks!

    I think I’ve found the issue. It’s on line 70 of lively-chat-support/shared/includes/functions.php. Change it from:

    } else if (LIVELYCHATSUPPORT_ADMIN == true) {

    To:

    } else if (current_user_can("can_livelychatsupport")) {

    I’ll change it in the next version, but this will let you to make the change immediately.

    Plugin Author remetric

    (@dallas22ca)

    Hi Dallas, thank you for your speedy response and direction.

    I can confirm that the line above does indeed work and the editor role can now converse.

    Thank you for your help!

    I have the same problem- I need to be able to allow a person with “Editor” or non-administrator WordPress role to be able to communicate with the Lively Chat users.

    I have checked the “Lively Chat Access” for the user in question. If I change that user to any other role in WordPress other than “Administrator”, they can access Lively Chat, but the never see the green circle and user names to initiate live chats. As soon as I change that role to a WordPress “Administrator” they can then see the users and reply to chats.

    I have to be able to allow a receptionist to monitor the Lively Chats so they can respond in a timely manner. Of course I can not allow them to have WordPress “Administrator” access.

    I changed line 70 of the lively-chat-support/shared/includes/functions.php file to:

    FROM:
    } else if (LIVELYCHATSUPPORT_ADMIN == true) {

    TO:

    } else if (current_user_can(“can_livelychatsupport”)) {

    But it still does not work. Once I change them back to “Administrator” everything works…

    HERES MY ENVIRONMENT:
    Lively CHat Version 1.0.41
    Wordpress Version: 4.2.1

    Plugin Author remetric

    (@dallas22ca)

    When the receptionist is logged in, they will only see chats that are directed to her. You could try de-activating all other Agents (on the Agents page). This should direct all new visitors to her.

    Multi-agent support has not been as robust as I’d like it. I’m releasing the next version in the coming weeks and it will be much more intuitive. Thanks.

    I only have the single agent version…. I just need to be able to create a user in WordPress with a limited role like subscriber or author or editor. (so they don’t damage anything) that will be able to interact with the Lively Chat visitors. Right now as it is, Lively Chat requires a user to have an “Administrator” role to be able to conduct conversations with the Lively CHat visitors…

    Plugin Author remetric

    (@dallas22ca)

    Is the receptionist checked off in te Agents tab? If not, uncheck the currently checked agent and do so.

    THe only agent i have is the default agent— and its “active” is that agent only linked to a single WordPress user? Is it linked via email address?

    Plugin Author remetric

    (@dallas22ca)

    You’ll want to make the receptionist the default and active agent. It’s linked to a WP User, not email address.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘editor role vistor notification’ is closed to new replies.