Support » Plugin: Loco Translate » Editor not showing

  • I have been using Loco Translate for a few weeks on a new site. Translating was easy because of Loco Translate.

    Now I have a problem, when I click ‘edit’ to translate some more in Dutch, the editor won’t show up. I have no idea what to do. Can you please help me out?

Viewing 12 replies - 16 through 27 (of 27 total)
  • I have exactly the same problem like @ckroesbergen
    The same thing as on the image previously uploaded.
    Translations seem to be there but I can’t edit them as the working area is off.
    Wordpress 4.6.1. Loco 2.01

    Hello, i ‘ve got an issue too, the editor is not fully shown; i just see 16px of its width, how can i solve it?

    thanks in advance

    Hello, I have the same issue.

    I tried to find error by myself. I tried to use 2.0.11, 2.0.10, and 2.0.9 releases. Only release 2.0.9 works as expected. Higher versions do not work. It means editor is hidden and there aren’t any error messages in browser’s console.

    I have conducted experiment. I installed version 2.0.10 and replaced two files from version 2.0.9:

    1. /pub/js/editor.js
    2. /pub/js/min/admin.js

    In such conditions editor works perfectly. But I think, it is little bit wierd way to use version 2.0.10 with two old files.

    So I hope, perhaps it will help developer(s) to find solution as soon as possible.

    Thank you, and wait for fixing.

    Additional question…

    Where can I get source code of “/pub/js/min/admin.js” file?
    Minimized version of this file in svn-repo is extrimely unfriendly, therefore I cannot understand how this script works and how to find bug.

    Plugin Author Tim W

    (@timwhitlock)

    I have been waiting for someone to provide reliable steps to reproduce this error. As soon as I can catch it, I will fix it.

    It’s interesting to know that versions before 2.0.10 work as expected, but I’m still none the wiser as to how I can see this happening for myself.

    I assume you’ve already tried the last suggestion in this thread, of disabling all other plugins to eliminate conflicts.

    Please explain how I can catch this bug in action.

    Today I cannot disable all plugins on my site because of many reasons. But I will try to do that.
    Anyhow it will take many time to get permission to stop all plugins on site.

    Meanwhile I prepared one simple test which may helps to find buggy place.

    I have beautified file “/pub/js/min/admin.js” from release 2.0.10.
    Then I have inserted two lines of “console.log()” into this code
    to highlight places where work main blocks of this script:

    
      ...
      var k = function() {
        var f = {};
        return {
          register: function(c, h) {
            console.log( ' ~ Register: ', c, h );
            f[c] = h;
          },
          require: function(c, h) {
            console.log( ' ~ require: ', c, h );
            var n = f[c];
            if (!n) throw Error('CommonJS error: failed to require("' + h + '")');
            return n
          }
        }
      }();
      ...
    

    My version of file “admin.js” you can download from
    https://github.com/lightsunday/loco-issue/archive/master.zip“.

    Then I run page “/wp-admin/admin.php?path=plugins%2Fbukopie%2Flanguages%2Fbukopie-ru_RU.po&bundle=bukopie%2Fbukopie.php&domain=bukopie&page=loco-plugin&action=file-edit” in browser.
    “Bukopie” it is name of my plugin but it can be any plugin of WP.

    Then I copied report from console and paste into “report.txt” to send you.

    Maybe you advise me to insert another js-code into admin.js to verify some important stages of this script?

    • This reply was modified 4 years, 2 months ago by trickymage.
    Plugin Author Tim W

    (@timwhitlock)

    Thank you for your efforts, but I don’t see the purpose of your experiment here. If there was a problem with the dependency loading order, then I would get the same error too.

    I can’t engage in second-hand debugging, especially on a minified script. I don’t provide the original source because it’s compiled from the core Loco code case. You won’t be able to run it, and I won’t be making it public anyway.

    I’m very please you’re so keen to help, but please divert your energy into providing steps to reproduce the error. This is the one and only way the issue will be solved.

    If you cannot disable your plugins, then I strongly recommend you set up a local development version of your site.

    I had exactly this same issue.
    I disabled all other plugins and the Loco Editor started to work again.
    I enabled one by one and I found the issue, to me It’s
    “FB Messenger Live Chat” plugin by ZotaBox that when enabled is causing the Loco Translator Editor tab not to work

    Plugin Author Tim W

    (@timwhitlock)

    Thanks. We’re getting somewhere. Yes, I can confirm this.

    The fb-messenger-live-chat loads its stylesheets into all admin pages (whether relevant or not) and doesn’t namespace its CSS rules. In this particular case a style called “.loading” is breaking Loco’s elements.

    I can take steps to try and protect against this sort of thing, but really the author should avoid breaking other plugins. I will report it to them as a bug and then make some changes to my own dev branch.

    I’ll post back when there’s a fix.

    Plugin Author Tim W

    (@timwhitlock)

    @impressao3d The dev branch has a fix for your particular conflict. Please try it out.

    I also reported the issue to @zotabox.

    Thank you @timwhitlock, your work and dedication is incredible. All I really had to do was disable the plugin and do the needed translations, which is a pontual thing that only needs to be done once or twice and wont be necessary anymore.
    Thank you once again for your help, much love to you and to Loco Translate

    Yes! Revision “@1615875 – .loading class for conflict avoidance” works now!
    Thank you to author and @impressao3d!

Viewing 12 replies - 16 through 27 (of 27 total)
  • The topic ‘Editor not showing’ is closed to new replies.