WordPress.org

Support

Support » Plugins and Hacks » editor monkey problem

editor monkey problem

  • I unsuccessfully installed editor monkey and after deleting the plugin it seems to have messed up my write toolbar buttons. The buttons are all different and I would like to convert them back to default. Does anyone know how to do this?

Viewing 10 replies - 1 through 10 (of 10 total)
  • looks like editor monkey hides the default quicktags. does anyone know how to unhide them?

    Uh, yeah I have the same problem. I backed up my site. Deleted it all and re-installed wordpress and put my old config file and theme files back into the new install. And I STILL get the messed up toolbar buttons !!! How is this possible?

    You’ll need to delete ALL references to EditorMonkey in the wp database tables using PHPMyAdmin. You’ll find them in wp-options (don’t forget active_plugins – be careful with that one) and user_meta.
    For some reason they aren’t automatically deleted with the plugin.

    I’ve done all this and still dont’ have my toolbar buttons back. I’ve searched the plugin forum, I’ve searched Google et al, and nowhere can I find any kind of uninstall procedure outlined. This plugin has to be the most annoying ever! I can see no trace of it in phpmyadmin and STILL I don’t have WordPress back as I want it! Help!

    Solved it… Aha! Right, okay, follow Bricolou’s sound advice and take great care in doing so. But that’s not all you have to do.

    No matter what you have set up under writing options on your dashboard, the default rich-text editor won’t come back until you go into wp_usermeta and edit rich_editing manually back from ‘false’ to ‘true’.

    Do that, and your installation is returned to as it should be. I do hope that helps people get away from this appallingly intrusive plugin. It’s frankly unforgiveable that the plugin creator doesn’t at least provide a detailed outline for what to do if you want to uninstall. Sure, it’s too complicated for your average user anyway but SOME degree of documentation, clear as can be, would go a long way to addressing the loathing this plugin inspires when you can’t get rid of it properly…

    spicycauldron, after following bricolou’s advice, and checking yours my ‘rich_editing’ is set to true, yet it doesn’t load the rich text editor still. Instead I get text buttons and the editor itself shows code… new to wordpress so I’m not sure what ‘mode’ that is, or if its a seudo-mode.

    The other odd thing, is that the wp-includes version of tinymce doesnt seem to be loading still, as I’ve actually edited the buttons just to see if that would change anything, ie. adding ‘underline’ etc.. and they don’t load either, just the standard install so I’m not sure where its loading the tinymce gzip file from??? Can anyone help, Editormonkey has really done a number on my install.

    I to have had the exact same issue as tinycg. I’m stuck as well after editing the DB and removeing anything connected to monkey stuff. No luck yet.

    I just went into the database and ran the optimize and repair functions within MyPHPAdmin. I had to do that, then logout and clear the cache/cookies. After logging back in TinyMCE was working again.

    It seems there are half a dozen database entries that stay after installing EditorMonkey, those have to be removed manually, then repair/optimize the database.

    How I can repair/optimize the database ? Sorry I’m a beginner.

    Anybody can help me ?

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘editor monkey problem’ is closed to new replies.