Support » Plugin: Wordfence Security - Firewall & Malware Scan » Editor Level User Problems on Catalogue Plugin

  • Resolved ahiaruhe

    (@ahiaruhe)


    Have been using Ultimate Product Catalogue for a couple of years happily with Wordfence acivated.

    http://www.etoilewebdesign.com/plugins/ultimate-product-catalog/

    Suddenly the Editor user is unable to upload new product – they get a 403 error page. Admin level user can upload product without issue.

    De-activating Wordfence enables Editor user to upload product.

    Is there a setting in Wordfence which can solve this?

    Thankyou

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi ahiaruhe,
    This could be related to the “Malicious File Upload (Patterns)” firewall rule, try unchecking this rule in (Wordfence > Firewall => Rules) and re-check this issue.

    If this was the case, then please let me know more information about what exactly the editor user was trying to upload? (like: file size & extension) also is this issue reproducible using the free version of the “Ultimate Product Catalog” plugin? and if yes, please let me know how to reproduce it?

    Thanks.

    Hi

    No, that made no difference at all I’m afraid. The user was was just trying to add a product with a product image .jpg approx 190kb

    I have Pro version installed so unsure how it behaves using Free version.

    Thanks

    Simon

    Hi Simon,
    I tired to reproduce this issue but it seems that on the free version “editor” user can’t add products, please try to upload another product image and share with us a screenshot of the 403 error page.

    Thanks.

    Hi Wfalaa

    Yes, that’s correct, Editor user will not have access to UPC free version 🙂

    [url=http://postimg.org/image/ura4ud9v7/][img]http://s13.postimg.org/ura4ud9v7/Screen_Shot_2016_09_20_at_8_49_28_AM.jpg[/img][/url]

    [url=http://postimg.org/image/6c1wtbayb/][img]http://s13.postimg.org/6c1wtbayb/Screen_Shot_2016_09_20_at_8_51_40_AM.jpg[/img][/url]

    Thankyou

    Simon

    Hi Simon,
    Please go to (Wordfence > Live Traffic) and filter the traffic by “Blocked By Firewall”, you should see the blocked request there along with more information about why it was blocked, also you should be able to click on “Whitelist param from Firewall” to whitelist this request.

    Turning the “Firewall Status” to “Learning Mode” then performing the same action again should whitelist it in the future, you can revert it back to “Enabled and Protecting” after that.

    Let me know how it goes,
    Thanks.

    Thankyou, that worked for me. I will get my client to add a product with the firewall in Learning Mode and see what happens.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Editor Level User Problems on Catalogue Plugin’ is closed to new replies.