Support » Alpha/Beta/RC » Editor Issue in Widgets and Font Awesome Icon not displaying in UI

  • Hi Team,

    I have been testing WP 5.8 RC version recently. I got some issues with the editor, How can I get back to my old editor in Appearance > Customize > Widgets. I have tried classic editor plugins but it didn’t work well. How can I change it via code? And I have another issue as well. As I have used Fontawesome icons in UI, but they don’t seem to appear. Is there any specific reason for that?

    Regards,

Viewing 4 replies - 1 through 4 (of 4 total)
  • Are all fonts missing? Check out its documentation:

    https://fontawesome.com/v5.15/how-to-use/on-the-web/using-with/wordpress

    Hi @sakchi!

    Can you provide some more specific details?

    • When you say “classic editor plugins”, are you using the Classic Editor plugin, or the Classic Widgets plugin?
    • Can you link to screenshots of before and after?
    • Are the icons through your theme or a plugin?
    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Plugin Review Team Rep

    As I have used Fontawesome icons in UI, but they don’t seem to appear. Is there any specific reason for that?

    Just to be clear here, FontAwesome has never been a part of WordPress core, so this was likely another plugin’s addition.

    Hi,

    • On one hand, in WP admin you see icons : they are called “Dashicons” and they are in wordpress core installed
    • A WP plugin called “Awesome font” gives you (another) set of icons, not placed in the WP core (https://fontawesome.com/icons)

    If you want to use the “DashIcons” (wp admin icons) on front end, then put this in functions.php :

    
    	/********************************************************/
    	// Adding Dashicons in WordPress Front-end
    	/********************************************************/
    	add_action( 'wp_enqueue_scripts', 'load_dashicons_front_end' );
    	function load_dashicons_front_end() {
    		wp_enqueue_style( 'dashicons' );
    	}

    If you want to use AwesomeFont icons you should install either the WP plugin (https://wordpress.org/plugins/font-awesome/) or probably the js basic plugin (not optimize for WP, but in fact, I never tested it), then you can use :

    <i class="fas fa-arrow-left"></i>

    where fa-arrow-left is the name of the desired icon, that you can you find on AwesomeFont website -> icons.

    For me, WP 5.8 + classic editor + AwesomeFont won’t work well in admin sections. The AwesomeFont plugin settings page is not visible and I can’t use editor (gutengerg or classic) if Awesome font plugin is activated. I perhaps will try the non plugin method to load it.

    ++ Nicolas.

    • This reply was modified 3 months, 3 weeks ago by nicleg.
    • This reply was modified 3 months, 3 weeks ago by nicleg.
    • This reply was modified 3 months, 3 weeks ago by nicleg.
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Editor Issue in Widgets and Font Awesome Icon not displaying in UI’ is closed to new replies.