Support » Fixing WordPress » Editor displays post body as HTML instead of blocks

  • Resolved Bennett McElwee

    (@bennettmcelwee)


    Since upgrading to 5.4.1 from 5.3.something, the block editor is not working properly for editing existing posts or creating new ones. The post body appears as a single text field containing the HTML source code, e.g.

    <!-- wp:paragraph -->
    <p>The first paragraph, which should be a block.</p>
    <!-- /wp:paragraph -->
    
    <!-- wp:image {"align":"left","id":2407} -->
    <div class="wp-block-image"><figure class="alignleft"><img src="https://example.com/wp-content/uploads/2020/03/pic-676x1024.jpg" alt="" class="wp-image-2407"/></figure></div>
    <!-- /wp:image -->

    The rest of the block editor works fine! For example, the Block navigation button tells me that there is a Paragraph and an Image. And the Content structure button reports that there are 2 blocks and 1 paragraph.

    Displaying the post works as expected: it’s just the editor that is problematic.

    I have tried re-installing 5.4.1, disabling all plugins, switching to the Twenty Twenty theme, and using a different browser, all to no effect. I don’t think my web host is using any caching.

    Can you suggest something else I could check, or something I may have missed?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The three dot menu on the upper right has a choice of Visual or HTML mode. It sounds like you somehow clicked HTML mode.
    One of the changes in 5.4 was that the editor is fullscreen by default, which is also in that same menu.

    Thread Starter Bennett McElwee

    (@bennettmcelwee)

    Actually those options are missing from the … menu. The menu looks like this:

    View
       Top toolbar
       Spotlight mode
       Fullscreen mode
    
    Tools
       Block Manager
       Manage all reusable blocks
       Keyboard shortcuts
       Welcome Guide
       Copy all content
       Help
    
       Options

    Did you disable the visual editor in your user profile page?

    Thread Starter Bennett McElwee

    (@bennettmcelwee)

    I was going to say no, but I checked and apparently I did. So I re-enabled it and now everything is fine. Thanks for your help and I promise to check a bit more thoroughly next time. 😉

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Editor displays post body as HTML instead of blocks’ is closed to new replies.