Support » Plugin: Yoast SEO » Editor Conflict with Gutenberg 8.9 plugin

  • Resolved Robert Reiser

    (@robertreiser)


    I am running WP 5.5.1 with WordPress SEO version 14.9.

    As soon as I update the Gutenberg plugin to version 8.9, I can no longer edit posts, I only see a white screen. The console shows the following JavaScript error message:

    Uncaught (in promise) TypeError: u is null
        default https://*****/wp-content/plugins/wordpress-seo/js/dist/post-edit-1490.js:1
        o https://*****/wp-content/plugins/gutenberg/build/data/index.js?ver=86e17756483edb79c5c2acf422ecb400:1
        o https://*****/wp-content/plugins/gutenberg/build/data/index.js?ver=86e17756483edb79c5c2acf422ecb400:1
        h https://*****/wp-content/plugins/gutenberg/build/data/index.js?ver=86e17756483edb79c5c2acf422ecb400:1
        p https://*****/wp-content/plugins/gutenberg/build/data/index.js?ver=86e17756483edb79c5c2acf422ecb400:1
        s Redux
        A https://*****/wp-content/plugins/gutenberg/build/data/index.js?ver=86e17756483edb79c5c2acf422ecb400:1
    post-edit-1490.js:1:137773

    The same error is thrown when downgrading WordPress SEO to version 14.8.1.
    The error message disappears and I can edit posts fine when downgrading Gutenberg to version 8.8.
    For testing purposes, all other plugins were deactivated.

    Please let me know if there is any other information I can provide to help resolve this issue.

    Thanks

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Jeroen Rotty

    (@jeroenrotty)

    Hi @robertreiser,

    Thank you for reaching out! We always appreciate when things like these are reported.

    We tried to replicate the error you get. On a test environment, with WordPress 5.5.1, Yoast SEO 14.9, and Gutenberg 8.9.0 enabled and while using the TwentyTwenty theme, we couldn’t replicate the error. We are able to open up the editing screen for both existing or new posts/pages.

    Can you elaborate a bit more on what was enabled and what theme you were using while testing? Can you check if you can replicate the issue when you use the Troubleshooting Mode of the Health Check plugin? This switches to the default theme and disables all plugins, but only for your user. Site visitors or other users are not affected. Then you can enable Yoast SEO 14.9 and Gutenberg 8.9.0 and check if you can open the editing screen. If not, then we would like to further investigate. If it works, then switch to your theme and check if the issue reappears. If it does, there is a conflict with your theme. If it does not, please enable plugin per plugin to check when the issue reappears.

    Hope this makes sense, happy to hear what you can find.

    Plugin Support Jeroen Rotty

    (@jeroenrotty)

    Hi @robertreiser,

    I was just informed on an issue that might be the one that you are running into. It looks like it is caused by a change in the last Gutenberg plugin version, that when a featured image is set, the error can show up. You can find the related Github issue here: https://github.com/Yoast/wordpress-seo/issues/15989.

    We’d recommend downgrading the Gutenberg plugin at this time or to disable it on your live site. That is, if you don’t depend on the latest features the plugin brings. Please know that the Gutenberg plugin is a feature plugin that is not advisable to run in a live site, it is bleeding edge functionality that may resolve in bugs or conflicts.

    Hi Jeroen,

    thanks for the quick reply and the suggestions. I have a local development VM where I tried things out. Here are my findings:

    – The theme I am using for my production site is written by myself, based on _s.
    – For testing purposes, I have switched to TwentyTwenty
    – I do receive the same error message when I try to edit my post
    – As soon as I disable WordPress SEO or downgrade Gutenberg, the error message disappears and I can edit my post normally.

    So at this point I believe we can conclude this is not theme related. I did some further tests by trying to edit additional posts: The error message in my initial post is thrown only for *some* posts, but not for all. Some posts I can edit normally, some throw the error message. So it looks like the error is related to the *content* of the post?

    I can extract data from the database, if that helps. One of the affected posts is a very small test post. Let me know if this would help you or what else I can do to help with the investigation.

    Cheers, Robert

    Plugin Support Jeroen Rotty

    (@jeroenrotty)

    Hi Robert,

    Thank you for your thorough testing and reply.

    Can you please check whether the Github issue sounds similar? We’ve seen that it is related to having/not having a featured image set in the editor. It does happen with 8.9.0 of Gutenberg. We can reproduce that behavior.

    If this is the exact issue you are having, we are looking if this is something we need to address or it’s in the Gutenberg latest release.

    Thank you.

    Hi Jeroen,

    the issue described in Github is exacly what I have experienced. In one of the affected posts, I did remove the featured image and the post was editable immediately, even with the latest versions of Gutenberg and WordPress SEO.

    Is there anything else I can do to help?

    Cheers, Robert

    Plugin Support Jeroen Rotty

    (@jeroenrotty)

    Hi Robert,

    It’s ‘good’ that this is the exact issue you are experiencing. Our development team is investigating this and we’ll see how to go from there. There’s is not really anything you can do at this point to help us with this, we can replicate the issue so they will investigate.

    As a temporary workaround, you can either downgrade the Gutenberg plugin to version 8.8.0, this version should not have this issue. Additionally, please know that the Gutenberg plugin is a feature-plugin where all new functionality and tests are getting into. These are not always stable. It might also include experimental functionality. We would not recommend running the Gutenberg plugin on your live site. However, if you have been using functionality that is not included in WordPress core yet but only in the Gutenberg plugin, then it’s hard to disable/remove this plugin.

    Thank you Jeroen.

    I will see if it is possible to disable Gutenberg on my production site.

    Cheers, Robert

    Plugin Support Jeroen Rotty

    (@jeroenrotty)

    You’re welcome.

    Plugin Support djennez

    (@djennez)

    FYI: this is going to be fixed in Gutenberg: https://github.com/WordPress/gutenberg/issues/25045

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.