WordPress.org

Forums

editor complaint (3 posts)

  1. guitarplayr
    Member
    Posted 6 years ago #

    I have been reading the posts and i really don't understand why this issue is getting ignored.

    I have visual edotor activated, yes, I can code, but i find it a bit speedier to use the visual editor. So when i pasted something in that brought some residual formatting that made it pook like poo, i switched to code editor using the convenient tab, and lo and behold i could edit the existing code. So i thought

    The i switch back, finish, save the post and surprise: all my line breaks have been stripped out. It took far to long to find out that the only way to fix it was to switch to code, manually add the tags for line vbreaks or paragraphs then publish. switching to visual stripped everything again.

    What the heck is wrong with you? I see answer after answer advising us sagly that visual is not for entering code, and to turn it off.

    Then WHY THE HELL add a code tab and allow you to swtich over and completely destroy your formating?

    At the least remove the damn code tab so people dont blow themselves up. It makes no damn sense to tell people not to do it when you provide them the means to do so.

    As an addendum, if Editor Monkey and show you your code for editing, and Xinha can as well, why can't you include it natively?

    WordPress should be better. I updated to 2.6 excited about the add media buttons, which dont work, and the captions to images which i am losing as i am reactivating either editor monkey or xinha so i can at least post semi effectively.

    i'm not planning on switching, but I admit, I am sorely disappointed in your code.

  2. guitarplayr
    Member
    Posted 6 years ago #

    by the way, installing Advanced TinyMCE solves it. there is an option to NOT strip the <p> and br break tags.

    So apparently this is not only a known issue, but now looks like it is a by design feature that you have to suppress.

  3. Dgold
    Member
    Posted 6 years ago #

    Thanks for posting the solution that you found.

    Personally I just go into my Admin Profile and UNCHECK the visual editor. I do this the first time I install WP. Then I never start in the Visual Editor. I start all my posts in Code view. I dunno if this would help your situation tho. Good luck with your site.

    When posting on the Forum here please remember it's read, answered, by volunteers, just fellow coders and users of WP like yourself. It's open source and developed by all kinds of people in the wide community. And, it's free software. So sorry if you're disappointed.

    Be sure to thank that plugin developer if someone's free plugin helps to solve your issue.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.