Editor cannot edit any posts - but can view/delete (4 posts)

  1. Jon W
    Posted 6 years ago #

    My wife is set up as an editor for my blog, but just noticed that she cannot edit any post. She can delete!

    She is editor on other blogs, and that all works fine. I upgraded her to admin and she could then edit. Downgrading reverted back to same problem.

    Currently uploaded all 2.8.4 again, as I may have used auto-update on this blog (cannot remember, generally FTP but sometimes hit the update button). Maybe a file did not update properly? (uploaded all again did not fix). Will try deleting her account and creating again....

    Anyone had this problem before?

  2. esmi
    Forum Moderator
    Posted 6 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-related problems?

    - resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

  3. Jon W
    Posted 6 years ago #

    Spotted the problem - I had http://wordpress.org/extend/plugins/exec-php/ on this blog, and removing it allowed my editor to edit again.

    Raised on the plugin site.

  4. esmi
    Forum Moderator
    Posted 6 years ago #

    Have you tried runPHP? Don't know how well (or even if) it work on 2.8.4 though.

Topic Closed

This topic has been closed to new replies.

About this Topic