Support » Plugin: Elementor Website Builder » Editor broken in 2.9.4

  • I’m now getting the following error since updating to 2.9.4

    editor.min.js?ver=2.9.4:7 Uncaught (in promise) TypeError: Cannot read property ‘data’ of undefined
    at initSettings (editor.min.js?ver=2.9.4:7)
    at initialize (editor.min.js?ver=2.9.4:7)
    at i.h.Model (load-scripts.php?c=0&load[chunk_0]=underscore,jquery-core,jquery-migrate,backbone,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-draggable&ver=5.3.2:10)
    at new i (load-scripts.php?c=0&load[chunk_0]=underscore,jquery-core,jquery-migrate,backbone,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-draggable&ver=5.3.2:10)
    at new model (editor.min.js?ver=2.9.4:7)
    at i._prepareModel (load-scripts.php?c=0&load[chunk_0]=underscore,jquery-core,jquery-migrate,backbone,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-draggable&ver=5.3.2:10)
    at i.set (load-scripts.php?c=0&load[chunk_0]=underscore,jquery-core,jquery-migrate,backbone,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-draggable&ver=5.3.2:10)
    at i.add (load-scripts.php?c=0&load[chunk_0]=underscore,jquery-core,jquery-migrate,backbone,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-draggable&ver=5.3.2:10)
    at i.add (editor.min.js?ver=2.9.4:7)
    at i.reset (load-scripts.php?c=0&load[chunk_0]=underscore,jquery-core,jquery-migrate,backbone,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-draggable&ver=5.3.2:10)

    This breaks the editor. I cannot edit any pages as it does not recognize any editable regions. The sidebar controls do not function.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support davidr90

    (@davidr90)

    Hi,

    We are sorry for your inconvenience.

    Please try following the steps in our guides regarding this matter:
    https://docs.elementor.com/article/235-update-issues

    https://docs.elementor.com/article/576-elementor-widget-panel-not-loading

    Let me know if this information helped you solve your issue.

    We can mark this as solved. Here’s a timeline of how this issue was resolved.

    I started by deactivating all plugins and switching themes to 2019. After doing all this, I did notice that all the back pages were once again editable, but not the home page.

    I then went to my CDN (stackpath) and did a full purge. Went back to wordpress admin and was able to successfully open an editable version of the home page in Elementor.

    The key consideration here: I have a full CDN integration for Stackpath which also means changing the @ DNS record from my host root to Stackpath and creating a CNAME for http://www.[domain] to resolve to my CDN URL. Consequently, if elementor is retrieving a copy of a live page for the editor, with this configuration it’s pulling off the CDN and not the host root.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Editor broken in 2.9.4’ is closed to new replies.