WordPress.org

Support

Support » How-To and Troubleshooting » Editor broken after upgrade to 3.3?

Editor broken after upgrade to 3.3?

  • I upgraded to 3.3 this morning. Now if I go back and try to edit an old post, the editor screen is blank. If I use my mouse and highlight the entire editor box, I can see the HTML code but it is not working the way it did prior to the upgrade.

    I have tried changing themes to no avail. Is anyone else experiencing this issue?

Viewing 15 replies - 1 through 15 (of 22 total)
  • Have you tried deactivating all plugins?

    Yes, I meant to mention that in my original post. Disabled all plugins, tried reverting back to default them, and no change, still a blank editor window when I try to edit a previous post.

    Other people have reported the same or a similar problem. Unfortunately IDK the answer but you can read lots of other threads about it, particularly ones that are marked Resolved.

    Make sure you’ve read the entire Master List post and the New Features in 3.3 Post.

    Go to your own install’s about page – http://domain.com/wp-admin/about.php – to see what’s new.

    And then make sure you’ve tried…

    – flushing any caching plugins you might be running, as well as server and/or browser caches.

    – deactivating all plugins (yes, all) to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). If you can’t get into your admin dashboard, try resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems. Also remember to deactivate any plugins in the mu-plugins folder. The easiest way is to rename that folder to mu-plugins-old

    – switching to the Twenty Eleven theme to rule out any theme-specific problems. If you can’t log in to change themes, you can remove the theme folders via FTP so the only one is twentyeleven. That will force your site to use it.

    – manually upgrading. When all else fails, download a fresh copy of the latest.zip file of 3.3 (top right on this page) to your computer, and use that to copy up. You may need to delete the wp-admin and wp-includes folders on your server. Read the Manual Update directions first!

    Thanks Ipstenu, I have tried everything you mentioned with the exception of doing the upgrade again manually. Will try that this afternoon and report my results back here.

    Ok I have tried all the suggestions above. I even rolled back to the previous version of WordPress (running in a VmWare environment) and did the 3.3 upgrade manually and I still have the same issue, the “edit” box for previous posts is blank unless I select the box with the mouse then I can see what’s there.

    Same thing with trying to add a new post, I can enter a title for the post but cannot see anything in the edit box.

    I guess I will wait and see if anyone else runs into this issue.

    yes, I have; and I created another thread on this issue

    And then make sure you’ve tried…

    flushing any caching plugins you might be running, as well as server and/or browser caches.

    I can’t emphasize that part enough. Really, clear your browser cache and restart the browser. It’s amazing how strongly some browsers will hold onto old JS code.

    I have tried it with IE9, Firefox 8, and Chrome: always the same unpleasant result.

    @otto is right about flushing your browser cache. I had a 3.3 error and reverted back to 3.2.1 and was having this same problem this morning. Just tried again from my work computer and my visual editor works fine. Will be clearing my browser cache when I get home.

    This seems to be the same similar problem I encountered with 3.2.. 🙁

    WordPress 3.2 may ‘break’ your site… 🙁

    – suggested solutions did not work for me
    – I ‘rolled back’ to 3.2.1…

    http://wordpress.org/download/release-archive/

    It would be nice if the ‘auto-update’ had a ‘auto-revert’…

    🙂
    Dale

    Like a lot of folks on other threads, I was able to resolve this issue by installing the “Use Google Libraries” plugin.

    Seem like a round about way to solve the issue to me but hey, it works.

    dale_c, thanks for the hint, IT WORKED !

    Based on the description/notes this may provide a ‘fix’ where you:

    a) enable the plugin (and test for everything working) followed by
    b) disable the plugin (which should cause your server to ‘serve’ updated Javascript to your browser, i.e. ‘fixing’ the problem.)

    “Allows your site to use common javascript libraries from Google’s AJAX Libraries CDN, rather than from WordPress’s own copies.”

    http://wordpress.org/extend/plugins/use-google-libraries/

    Note that there may be performance or other advantages for using the plugin so you could just run it until/unless it causes a problem, i.e. if the Google CDN goes ‘down’ – probably not very likely…

    I will give this approach a whirl on with a multi-site install…

    🙂
    Dale

    If the problem is fixed by using Google Libraries (which I use and work nicely on Multisite, by the way), then the problem’s your cache :/

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Editor broken after upgrade to 3.3?’ is closed to new replies.
Skip to toolbar