Support » Plugin: Custom Post Type UI » Edition Box won't show

  • Resolved gustmf


    I’m not sure if I have the same problem, but it is similar for sure. We updated WordPress to 3.6.1 and CPT UI to 0.8 and ever since we are able to edit regular posts but not customized posts.
    When in a regular post I click in “edit” and the page for edition is show with these options:
    – Permanent link: xxx [change permanent link] [view post];
    – [Add Media]
    – Edition Box {Visual] [Text]
    – WordPress Yost SEO (another plugin)
    When in a CPT UI post I click in “edit” and the page for edition is show with these options:
    – Permanent link: xxx [change permanent link] [view post];
    – WordPress Yost SEO (another plugin)
    Note that neither Add Media/Edition Box are shown for customized posts.
    What have we done wrong?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Michael Beckwith


    Nothing wrong that I can immediately identify. Not sure what you mean by “Edition box” but you should have an “Add media” button.

    What settings are you using with this post type? I’ll see if I can reproduce

    I’m not an WordPress expert, sorry if I don’t know the proper terms..
    By “edition box” I mean the very basic area where you can see and edit the post text, be it in a [Visual] representation (what you actually see) or in [Text} representation (the html code). It includes buttons for changing character/paragraph features such as bold, italic, size, or for creating links, aligning text, cut/paste and so on…
    They are working as expected for regular posts but not in CPT posts.

    We have 2 CPT:

    Action: Delete/Edit/Get Code; Name: conteudo; Label: Conteúdo; Public: true; Show UI: true; Hierarchical: true; Rewrite: true; Rewrite slug: conteudo; Total Published: 107; Total Drafts: 14; Supports: title, editor, excerpt, revisions, thumbnail, author, page-attributes

    Action: Delete/Edit/Get Code; Name: cedoc; Label: Centro de Mídia; Public: true; Show UI: true; Hierarchical: false; Rewrite: true; Rewrite slug: cedoc; Total Published: 616; Total Drafts: 8; Supports: title, editor, excerpt, trackbacks, custom-fields, comments, revisions, thumbnail, author, page-attributes

    Plugin Author Michael Beckwith


    ah, the editor textarea. Gotcha.

    From the 2 CPT details that you have typed out, I see “Editor” is supported for both, so that should be showing up for you. I believe the media button is default with that. If the media button is not, showing up despite the editor area being there, I suspect it’s an issue caused by something outside of our plugin, or some sort of possible javascript error, though that’s a bit more far-fetched.

    That’s the problem, the editor isn’t there also. Neither media button, neither editor 🙁
    They used to be there before updating to WordPress 3.6.1 and CPT UI to 0.8 .
    Now we see, for Regular posts:

    – Permanent link: xxx [change permanent link] [view post];
    – [Add Media] button
    – Editor [Visual] [Text]
    – WordPress Yost SEO (another plugin)

    for CPT UI posts:

    – Permanent link: xxx [change permanent link] [view post];
    – WordPress Yost SEO (another plugin)

    Plugin Author Michael Beckwith


    Click on “Advanced options” for the CPT in question and make sure that “Editor” is checked at the bottom. If that’s still checked, then I’m not sure what may be going on. Curious if the settings got mixed up somehow.

    I had already verified that. Editor was already checked.
    Just to make sure I even tried to uncheck Editor and than check it again, to no use. The editor won’t show when editing the post.
    I used the BETA feature to get the code that I reproduce here:

    add_action('init', 'cptui_register_my_cpt');
    function cptui_register_my_cpt() {
    register_post_type('conteudo', array(
    'label' => '__('Conteúdo')',
    'description' => '',
    'public' => 'true',
    'show_ui' => 'true',
    'show_in_menu' => 'true',
    'capability_type' => 'post',
    'hierarchical' => 'true',
    'rewrite' => array('slug' => 'conteudo', 'with_front' => '1'),
    'query_var' => 'true',
    'has_archive\' => 'true',
    'exclude_from_search' => 'false',
    'menu_position' => '5',
    'supports' => array(''title','editor','excerpt','revisions','thumbnail','author','page-attributes','),
    taxonomies' => array(''category','post_tag','),
    'labels' => 'array (
      'name' => 'Conteúdo',
      'singular_name' => 'Conteúdo',
      'menu_name' => 'Conteúdo',
      'add_new' => 'Add Conteúdo',
      'add_new_item' => 'Add New Conteúdo',
      'edit' => 'Edit',
      'edit_item' => 'Edit Conteúdo',
      'new_item' => 'New Conteúdo',
      'view' => 'View Conteúdo',
      'view_item' => 'View Conteúdo',
      'search_items' => 'Search Conteúdo',
      'not_found' => 'No Conteúdo Found',
      'not_found_in_trash' => 'No Conteúdo Found in Trash',
      'parent' => 'Parent Conteúdo',
    ) ); }

    [Moderator Note: Please post code & markup between backticks or use the code button. Your posted code may now have been permanently damaged by the forum’s parser.]

    Plugin Author Michael Beckwith


    I’m honestly at a loss with this one. I’m not sure what could be causing it as everything looks like it should be working with an editor box shown. Is it just the one post type? or is it no matter what ones you use? Does it happen with a different theme or all other plugins disabled?

    We are using the Advanced Custom Fields plugin. Disabling it returns the Editor to our custom post types. Enabling it back just hides it away again…
    It might be some incompatibility at some level 🙁

    Plugin Author Michael Beckwith


    I’ll go ahead and install that and see if I can recreate the issue, thanks for the tip regarding it. If at all possible, I’d love to make sure it’s all compatible.

    Plugin Author Michael Beckwith


    Well, I installed the latest version of Advanced Custom Fields (4.2.2), with WP 3.6.1 and CPTUI version 0.8.0 and wasn’t able to see any issue with media/editor boxes disappearing. Tested with both a CPT already created, and a brand new one. So I’m really at a loss at this point as to what’s causing it. Have you tried turning on WP_DEBUG that will show php errors, and have you checked your browser’s js error console at all? Those are the only places left that I can think of to check.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Edition Box won't show’ is closed to new replies.