Support » Networking WordPress » Editing sites with Primary URL

Viewing 15 replies - 1 through 15 (of 16 total)
  • Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    You mean you want to map your domains?

    kb0000

    (@kb0000)

    I have already map the domain i.e. primary1.domain.com to site1.blogs.domain.com.

    Now, when someone opens site1.blogs.domain.com it redirects to primary1.domain.com, but I also want that when someone is logged in, at that time also site1.blogs.domain.com should go to primary1.domain.com

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    What plugin did you use to map the domain?

    With one of them, there’s an option to redirect the admin side as well.

    kb0000

    (@kb0000)

    I have used WordPress MU Domain Mapping, but now I am not able find where is this option.

    Please let me know where is this option in this plugin or suggest some other plugin having this option.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Go to yourdomain.com/wp-admin/network/settings.php?page=dm_admin_page

    Uncheck options 1 and 4.

    kb0000

    (@kb0000)

    I am not able to uncheck option 4. When I click on option 4 and uncheck it and then save it, next page again shows it as checked.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    What version of the plugin are you using?

    kb0000

    (@kb0000)

    Version is: 0.5.4 and it is not showing in List of active plugins but in Must-use.

    Do I need to change it from Must-Use to active?

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    No, Must Use is fine. But you need to update 🙂

    http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/

    Version 0.5.4.2 is out.

    That’s the problem though, with MU. You don’t see when they need updates.

    kb0000

    (@kb0000)

    I have upgraded it to version 0.5.4.2 by installing this plugin and removing it from Must Use.

    When I am in admin panel, and click on My Sites from drop down menu, then again it is showing non mapped domain only and not primary1.domain.com (though when I open primary1.domain.com/wp-admin, it is working fine).

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Did you go to yourdomain.com/wp-admin/network/settings.php?page=dm_admin_page

    and uncheck options 1 and 4 again?

    *hint hint* The upgrade was so those check boxes would work again 😉

    kb0000

    (@kb0000)

    Yes, I did this only. Though only options 2,3 are checked but links shown are site1.blogs.domain.com

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    My links in /wp-admin/network/sites.php show the old subdomain, but when I click on them, they are correctly forwarded.

    kb0000

    (@kb0000)

    I have not created *.domain.com as it was causing issues with cpanel.domain.com type sub-domains.

    So, for “My links in /wp-admin/network/sites.php show the old subdomain, but when I click on them, they are correctly forwarded.” they are not forwarding, instead shows default hosting pages (i.e. not configured). That is the reason I wanted to have these links as primary links and not sub-domain one (like http://site1.blogs.domain.com).

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    I have not created *.domain.com as it was causing issues with cpanel.domain.com type sub-domains.

    You MUST have the subdomain for your mapped domain working before you attempt to map them. Period.

    I get what you want to have in the end, but you MUST make sure everything is okay in Multisite before you start mapping.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Editing sites with Primary URL’ is closed to new replies.