Support » Themes and Templates » Editing in the theme editor

  • I am trying to edit the home page of my blog – the content is in the listing-header.php file and as I know HTML I want to do this directly within the theme editor, editing the templates/files. The message says that I need to make the file writable before I can save changes, which I think I understand. Do I set just this file to ‘owner’, ‘group’ and ‘public’ permissions to read and write (or just change the numeric value to 666?). Do I need to change any other files apart from this one? Will this cause me any security issues? I can’t access my FTP files myself because I am having problems downloading Filezilla so am having to ask a friend to do this (this blog was set up by a previous work colleague who I can’t ask now!) and it is getting all a bit confusing! Will I see a ‘save’ button on the theme editor page once I set the files to ‘write’ or do I have to save the file on my desktop and upload it – obviously this is a problem as I can’t get the FTP access myself. Apologies for the long post . . . Any help you can give me would be great as I have been trying to sort this for days (and I’ve got issues upgrading as well, but that’ll come later once I’ve sorted this problem out!)

Viewing 3 replies - 1 through 3 (of 3 total)
  • esmi


    Forum Moderator

    Try 666 first. If that doesn’t work, try 766. The final catch-all is 777.

    Extending file permissions on a server always carries with it an implied security issue, so it’s good practice to keep the mode (ie the number) as low as you can possibly get away with.

    Once you changed the permissions appropriately, a “Save Changes” button or similar will appear. Sorry I can’t be more specific about the button – it’s been a while since I modified files on the server. 🙂

    I had the same problem – the Update File button was not showing up at all, so I knew something was askew.
    I tried setting permissions on the entire folder – didn’t work.

    When I set 766 to each file in the themes/mine/ folder, it worked. Thanks!

    i am new to wordpress and i am trying to edit the default theme file on stylesheet css and i have the update file button which saves the changes once i change something but the changes do not work would any1 know why this is? is there something i need to activate?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Editing in the theme editor’ is closed to new replies.