WordPress.org

Support

Support » Plugins and Hacks » Front-end Editor » [Resolved] Editing categories shows [Empty] instead of the inputted categories

[Resolved] Editing categories shows [Empty] instead of the inputted categories

  • Hi 🙂

    I’ve been using the alpha version that allows editing categories through input box instead of drop down menu for a while. Today i saw the change log and it says that the feature made it to the stable version. So i updated to it.

    My issue is that when I edit any of the categories, they reset and show [Empty] when I save. What could be causing the issue?

    Thank you very much for the help!

Viewing 13 replies - 1 through 13 (of 13 total)
  • Also, I tried to go back to the Alpha but that didn’t help either.

    Same problem here. Any help?

    Plugin Author scribu

    @scribu

    Hm… it would be helpful if you could post the generated HTML markup, i.e. the <span class="fee-field"... bit.

    And also the underlying PHP code from your theme, i.e. the_category( ... ). The entire loop surounding that code would be nice, actually. Put it on pastebin.com if it’s too long.

    After editing the categories and then clicking save it shows [Empty]. If we reload the page we see that the post got the Uncategorized Category. It resets all the categories.

    <span data-type=”terminput” data-post_id=”1178″ data-taxonomy=”category” data-before=”” data-sep=”, ” data-after=”” data-filter=”the_category” class=”fee-field”>Uncategorized</span>

    I’m using the Thesis theme.

    I’m listing the categories by using

    echo get_the_category_list(‘, ‘);

    but I’m not finding where that function is.

    Plugin Author scribu

    @scribu

    Ah, ok, I can reproduce it now. Stay tuned for a fix.

    Ok. Thanks a lot.

    Plugin Author scribu

    @scribu

    There, the Development Version (2.1.2-alpha) should work.

    Works like a charm. Thanks! Great work!

    I think I found another bug.

    When using the plugin, the titles in the main page are appearing twice.

    For a post named “this is a test post” the title in the main page is displayed:

    This is a test post”>This is a test post

    In the post page there’s no problem but all the titles in the main page appear like that. Hovering the mouse on the title there’s an alt text:

    Permanent link to <span data-type=

    Any help?

    Plugin Author scribu

    @scribu

    See http://scribu.net/wordpress/front-end-editor/common-mistakes-in-themes.html

    If that doesn’t help, please start a new thread, as this one has been resolved.

    Yes,it worked. I fixed my theme. Thanks a lot, once again. Everything is perfect now.

    Sorry for the delay in response. I’m glad that you were able to reproduce and fix the issue (Thank you rpOliveira!) . The fix worked great!

    Thank you very much!!!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Resolved] Editing categories shows [Empty] instead of the inputted categories’ is closed to new replies.
Skip to toolbar