Support » Fixing WordPress » Edited post not updating in edit window after submission

  • This is a strange bug that is happening on my WP 2.0 upgrade from 1.5.

    After publishing a post, if I try and go back to edit that post and submit, the post itself will be updated, but the text in the edit box will not be updated. Even after refreshing the browser, closing the browser window and opening it back up again, the previous version of that post will show up in the edit box. So if I wanted to edit a post twice, I would essentially have the first version in the edit box even after I’ve edited it once already.

    Sorry if that explanation is confusing, but I don’t know how else to describe this.

Viewing 11 replies - 1 through 11 (of 11 total)
  • It sounds like your browser cache is doind something funky. I usually use both IE and Firefox to test if it is a browser problem (either that or deleting all offline files).

    It doesn’t sound like a WP problem that I have seen; especially since the post is updating. Make sure your browser is up to date. – Trip

    I checked. It’s not a browser problem because the data I’m getting is from my wordpress blog, not the cache. I tried both IE and firefox, and they both give me the same error.

    It sounds weird, I know, but somehow the post is updating, and yet there’s an old version of the post somewhere such that I get that when I want to edit the post again.

    Maybe someone who knows how the database and posting works together can help?

    Perhaps it has to do with the wordpress cache. I am not sure if you have access to this area but it can be cleared by removing everything under wp-content/cache from what I am told. I have never done this myself but this is what someone suggested to me when my 2.0 wasn’t allowing me to delete categories. (I imagine the best way to do this would be to rename the cache folder to cache.old and create a new one, that way if something goes terribly wrong you could restore it.)

    The cache is disk based so this could have something to do with the OS of your server. Worth a try. I have noticed disk write slowdowns on NFS partitions with heavy traffic before – Trip

    Hmmm, That sounded like a really good idea! Unfortunately, I deleted the cache and it still behaves the same. Could there be anything else that’s causing this?

    And thanks for all of your suggestions!

    Bummer. The only other thing I can think of is to cahnge your defult editor to the opposite of what it is in WP 2.0. This is in the Options/Writing section of the admin console.

    I haven’t been using the new Rich editor because I like to get htmly (new word!!) so i cahnged back to the “old style” editor right away. Something has to give here.

    Good luck. Let me know if you figure it out.


    You have a great blog by the way. – Trip

    I’ve been using Xinha4WP (it worked with 1.5 too). I should also note that I turned off all of my plugins to no avail.

    This isn’t really a life or death kind of problem, but it is really annoying when I want to re-edit a post.

    One more thing, it only does this when I have a post that’s published. So if I write a draft and edit it, the new edited version shows up correctly in the edit box. I have no idea why. And changing a post back to a draft and editing it doesn’t work either…

    So disabling the cache entirely solved the problem. I think this must have something to do with the internal caching system of wordpress thinking that the post wasn’t updated and using the same cached info as before. It could also be that a plugin that writes to the cache was messing with it. I’ll check out all of my plugins that do this and report back if I can isolate the problem.

    So soundtrip, thanks for your initial suggestion that it was the cache!


    This is great information. Hope all goes well from here on out.


    Same problem here with 2.0.2. For what it’s worth, disabling the WordPress cache seems to have solved the problem.

    According to this post:

    2.0.2 should have caching disabled by default. However, that doesn’t seem to be the case.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Edited post not updating in edit window after submission’ is closed to new replies.