WordPress.org

Support

Support » Requests and Feedback » edit_post_link() issue

edit_post_link() issue

  • I wasn’t sure whether to post this in troubleshooting or here.
    The issue is this. I installed WordPress in a /wordpress directory and then followed the “Install WordPress files and blog in different directories” instructions. This worked like a charm. The trouble is, it breaks the edit_post_link() functionality, because the path for the “I’m logged in” cookies is still set to /wordpress.
    I’d like to see this fixed in upcoming versions, but could anybody give me a quick hack in the meantime? I’m not quite acquainted with the WordPress code just yet.
    By the way, great work on the software!

Viewing 11 replies - 1 through 11 (of 11 total)
  • Oops, I just found another issue with the same feature: If you move index.php, you cannot edit it within the WordPress UI (Templates > Main Index), you get “Oops, no such file exists! Double check the name and try again, merci.”

    that’s a lil issue which has come up often. not sure if there’s a solution, yet.

    I had the same problem after I moved my blog to a different location and clearing my cookies and relogging into the admin site did the trick. Hope it works for you!

    It hasn’t for me, but thanks for the advice anyway. This problem always screws up the login for that great MicroWiki plugin. I read in some other thread (looking for it now) that this is solved in 1.2.2, but I have yet to upgrade–no time at the moment. I hope upgrading works 🙂

    This has already been fixed in CVS, you’ll have to wait for the next version.

    I’m on 1.2.1 but I’m going to try upgrading to 1.2.2 tonight to see if that makes a difference. Fingers crossed!

    Using new install of 1.2.2, with index.php one directory up from the WordPress folder (and everything else working), the Edit Link does not appear at all. It does not display in the browser source code *at all*, but here’s the code:

    <?php edit_post_link(); ?>

    Have I been blinded, or what might be the issue?

    Yeah, I installed 1.2.2 and no go. Still brokies. I guess we have to wait for 1.3?

    Well, you’re lucky it’s just “broke”; it won’t even *display* for me. I think I’ll go back to 1.2.1.

    I found the answer in:
    http://wordpress.org/docs/installation/different-address/

    It appears that in WP 1.2.2, when index.php is in a different directory than the WP files, then the Edit This link does not appear. That’s a shame, as I’d rather not have all the WP files in the same directory as the templates — far too messy.

    I’ll note that 1.2 (and, I believe, 1.2.1) do not behave this way.

    MY MISTAKE!

    I was unable to log out, so I deleted cookies in my browser, then logged back in — and the Edit link now appears on index.php.

    [Phew. Thought I’d have to reinstall.]

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘edit_post_link() issue’ is closed to new replies.
Skip to toolbar