Support » Plugin: Elementor Website Builder » “Edit with Elementor” missing from top bar?

  • admiraltuuvok

    (@admiraltuuvok)


    The “Edit with Elementor” when you’re on a page you can edit seems to have disappeared for me :s

Viewing 15 replies - 1 through 15 (of 27 total)
  • Plugin Support davidr90

    (@davidr90)

    Hi,

    We are sorry for the inconvenience.

    This issue has been fixed in our 3.0.8 patch release.
    Please update to the latest Elementor version and let me know if it solved your issue.

    dvazquez260376

    (@dvazquez260376)

    Hi,

    Same problem here with the latest version: 3.0.8.1. The “Edit with Elementor” button has disappeared.

    I didn’t have this problem with 3.0.7 version.

    bob reeves

    (@bob-reeves)

    Hi,

    same problem, have updated 3 websites to 3.0.8.1, edit with Elementor disapeared from top WordPress bar.

    Does not rollback to 3.0.7, just hangs at the downloading screen.

    Redpik

    (@redpik)

    Same bug.

    Elementor v3.0.8.1
    Elementor Pro v3.0.4

    Is it a JS error ?

    
    Uncaught ReferenceError: elementorModules is not defined
        at Object.714 (admin-bar.min.js?ver=3.0.8.1:2)
        at __webpack_require__ (admin-bar.min.js?ver=3.0.8.1:2)
        at admin-bar.min.js?ver=3.0.8.1:2
        at admin-bar.min.js?ver=3.0.8.1:2
    
    dvazquez260376

    (@dvazquez260376)

    Hi @redpik @davidr90

    I’m getting the same JS error.

    Thread Starter admiraltuuvok

    (@admiraltuuvok)

    Still missing after latest update

    nohler

    (@nohler)

    Me also. Multiple sites.
    p.s I experimented with different jQuery configurations, and it came and went.
    I used this: https://wordpress.org/plugins/wp-jquery-update-test/

    supa

    (@supapiouce)

    Same thing for me since the 3.0.7. On the front end, “Edit with Elementor” no longer shows active “modal windows” and i can’t edit them from here.
    The problem goes away if you revert to 3.0.6

    No error if I disable Autoptimize.

    The same for me, if I disable Autoptimize Edit with Elementor reappears.

    Untick the “also optimize for logged in editors/ administrators” near the bottom of Autoptimize’s main settings screen and all should work.

    hope this helps,
    frank (ao dev)

    Hi @optimizingmatters, it worked for me, Thanks.

    you’re welcome Bob 🙂

    I have the same problem as of elementor 3.0.7 later updates.
    In my case I have tried with an empty wordpress, only with elementor installed. The problem appears with the Editor role, the administrator role can see the link in the top bar.
    In order for the role editor link to appear, I had to add the “manage_options” capability to it. But I understand that this is not a good solution, since this implies that the editor has access to the entire Settings section of the web.
    Any solution about it?

    Thanks

    Hi, have just updated 4 sites to 3.0.12 and the same problem persists, even though Elementor stated that the problem had been fixed in this version.

    In fact the resolution that @optimizingmatters gave us, that worked with previous versions now no longer works with the latest version of elementor.

    I must say that I am disappointed with the lack of response from Elementor.

Viewing 15 replies - 1 through 15 (of 27 total)
  • You must be logged in to reply to this topic.