Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » Edit thumbnail screen blank

  • Hi
    I get a blank screen on the popup for editing the thumbnail inside the galleries.

    I did the standard troubleshooting > deactived plugins and test, change themes and check, rest options and check. No luck.

    I’d appreciate any other troubleshooting, please.

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Support gabyimagely

    (@gabyimagely)

    Hello @artbiz,

    One thing you should check is if your environment meets our requirements.
    Confirm with your hosting provider that your installation meets these requirements: https://www.imagely.com/docs/requirements/

    If the problem persists, please try to remove the plugin and re-install the recent version.

    Please, keep us posted, we are happy to help!

    Hi
    Yes the server meets all the requirements. We have been using Nextgen for nearly 10 years and this is the first time the thumb editor doesn’t come up.

    I deleted the plugin via the backend so as not to lose the galleries and images. I downloaded and installed via the backend as well. Still no thumb editor.

    Plugin Support Jaime Imagely

    (@jaimeimagely)

    Maybe an update to another of your plugins is causing an issue.

    Please perform a conflict check:

    Deactivate your other plugins and try again. If the editor appears, reactivate your plugins one at a time and check after each to see which one brings the issue back.

    Please keep us posted.

    @jaimeimagely I did plugin and theme tests prior to logging this ticket.
    Other things I have tried:
    -reset all options
    -reinstalled from the backend
    -reinstalled wordpress
    -optimized the database
    -ran a repair on the database
    -check your host compatibility list

    The only thing I have not tried is to delete the plugin from the front end as I believe it deletes the galleries as well. If I am wrong about that I can try that. LMK

    Plugin Support gabyimagely

    (@gabyimagely)

    Hello @artbiz,

    No need to delete the plugin from the front end at the moment.
    Our next advice will be for you to enable WordPress to debug log to see if there is any information in the logs that will provide a lead to the cause of this particular problem.

    Here is some description about how to enable the debug mode in WordPress

    Debugging in WordPress

    I like these variables, and it saves the logs to a file that you can check later (/wp-content/debug.log).

    // Enable WP_DEBUG mode
    define( 'WP_DEBUG', true );
    
    // Enable Debug logging to the /wp-content/debug.log file
    define( 'WP_DEBUG_LOG', true );
    
    // Disable display of errors and warnings
    define( 'WP_DEBUG_DISPLAY', false );
    @ini_set( 'display_errors', 0 );
    
    // Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
    define( 'SCRIPT_DEBUG', true );

    Be sure to trigger the problem after enabling the debug mode, so we can have a proper output. You can also take a look at your console error log for any extra information.

    Please, keep us posted.
    We are happy to help!

    The only error trigger was…Notice: get_currentuserinfo is deprecated since version 4.5.0! Use wp_get_current_user() instead. in /home/deborahcatton/public_html/wp-includes/functions.php on line 4648

    I deleted the plugin after backing up the database and images and installed a fresh copy via the front end. Still get a blank edit thumb popup.

    Plugin Support mihai-imagely

    (@mihaiimagely)

    We are not being able to replicate the above mentioned problem. Can you please let us know what device, browser, OS and NextGen Gallery version are you using?

    It’s not just my computer or operating system, it is others as well. Windows and Mac alike. All are up to date including the plugin. So it can’t be a local problem.

    I have over a 100 sites on the same server all using Nextgen. Those sites look to be fine. It is just this one. I have to conclude it is something corrupt in the database since the site has been using the plugin going back 10 years.

    The only solution I can see from here is a new WP install c/w plugins and database, so, we will live without editing thumbnails.

    Thanks for trying.

    Plugin Support mihai-imagely

    (@mihaiimagely)

    Hi @artbiz,

    Can you please verify to see if you are getting any JS errors in the browser’s console while trying to edit the thumbnails?

    Also, what I would try is to create a new gallery – upload just a single image to it and try to edit its thumbnail to see if that would be possible.

    Please let us know

    This is the error in the JavaScript Profile in Chrome….
    VM219:1 POST https://deborahcatton.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/ngglegacy/admin/edit-thumbnail.php?id=731 403

    I was trying the thumb editor in the new gallery and image upload you suggested.

    I checked and the file edit-thumbnail.php is there.

    • This reply was modified 2 months, 2 weeks ago by artbiz.
    Plugin Support gabyimagely

    (@gabyimagely)

    Hello @artbiz,

    Unfortunately, it seems that what we need to do is to remove the plugin and re-install.
    It will not affect your galleries; you should be fine.
    Nevertheless, we always recommend a full website backup.

    We hope that this helps.
    Please, keep us posted.

    I have already done that. Twice. Once from the back end and then again from the front end. But I just delete the plugin from under Plugins. Is there another way? Like an uninstall feature from within the plugin settings? I could see one.

    • This reply was modified 2 months, 2 weeks ago by artbiz.
    Plugin Support mihai-imagely

    (@mihaiimagely)

    Hi @artbiz,

    I think we have reached a roadblock with this one since none of our support team could replicate the problem, unfortunately.

    Can you please let us know what hosting provider are you using and what’s your domain server’s OS?

    • This reply was modified 2 months, 2 weeks ago by mihai-imagely.

    Server Information:
    cPanel Version 84.0 (build 21)
    Apache Version 2.4.41
    PHP Version 7.2.26
    MySQL Version 10.2.30-MariaDB-cll-lve
    Architecture x86_64
    Operating System linux
    Shared IP Address 158.106.136.179
    Path to Sendmail /usr/sbin/sendmail
    Path to Perl /usr/bin/perl
    Perl Version 5.16.3
    Kernel Version 3.10.0-962.3.2.lve1.5.26.3.el7.x86_64

    It also has Lightspeed and I have to disable a few rules in htaccess in order to remove a 403 error I get when saving within a gallery. That is true for all sites on this server that used Nextgen. I don’t think that is the problem here as I removed the rule and the thumb editor still did not come up.

    I appreciate you not giving up.

    Plugin Support gabyimagely

    (@gabyimagely)

    Hello @artbiz,

    Please, if you have some time, we´d like to take a closer look, please send us a bug report here: http://www.imagely.com/report-bug, refer back to this forum thread and let them know Gaby referred you.

    Many Thanks.

Viewing 15 replies - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.