Support » Plugin: WP eCommerce » Edit product link returns blank page

  • scottmaui

    (@scottmaui)


    Store URL: https://www.hawaiianvoice.com
    WordPress version: 5.0.3
    WP eCommerce version: 3.13.1
    Gold Cart version: N/A
    Theme: Hawaiian Voice New
    I did this: clicked on the Edit link beneath any product in the products page https://www.hawaiianvoice.com/wp-admin/edit.php?post_type=wpsc-product
    I expected this: To be able to edit a product.

    However, the edit product page does not load, instead I just get a white page. My client doesn’t update her products very often, so she just noticed it but isn’t sure how long it may have been happening.

    I went through all of the steps in “Before Posting Read This” to deactivate other plugins, use generic theme, flush theme and browser cache, etc, but the problem still persisted.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • th3bish0p

    (@th3bish0p)

    the plugin doesn’t seem to be compatible with gutenberg (wp5) and it hasn’t been updated in ages…

    Andrew1977

    (@andrew1977)

    Hi Scott,

    I experienced the same issue, as soon as WordPress released version 5.0 with “Gutenberg”

    I found 2 options available to rectify this, to be able to carry on editing products, without the white page.

    1) To install the classic editor plugin
    2) To install the disable gutenberg plugin

    (I found number 2 the best option)

    Details below

    I installed the Disable Gutenberg plugin V1.4 by Jeff star, as this disables Gutenberg everywhere, allowing you to carry on using the old classic editor, with the current version of the wp-ecommerce plugin.

    I did noticed with the classic editor plugin running (without the Disable Gutenberg Plugin running), that when you edit a product and save the changes the following text was appearing above the quantity box:

    classic-editor-remember: classic-editor

    You can delete the text above that was appearing, from within the editing product page section.

    Hope this helps?

    Kind Regards,

    Andrew

    scottmaui

    (@scottmaui)

    that seems to have done the trick! thanks so much for your reply.

    Andrew1977

    (@andrew1977)

    Your very welcome.

    Glad I could help.

    reginaldebanks

    (@reginaldebanks)

    Thank you, this works for me too!

    Hi,

    There does appear to be occasions when the Gutenburg Editor fails to display the page. I am running WordPress 5.2.2, and whilst I can successfully edit most of my pages and posts, I do have a small number of pages/posts that display as a blank screen when attempting to Edit. I have tried disabling all plugins and switching to theme Twenty Nineteen to no effect. The solution for me was to install ‘Classic Editor’ plug-in and switch to the classic Editor.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.