WordPress.org

Support

Support » Alpha/Beta » 2.7 beta – Edit Problem

2.7 beta – Edit Problem

  • kiljaedener
    Member

    @kiljaedener

    After I edit and update the post, the screen show that You attempted to edit a post that doesn’t exist. Perhaps it was deleted?
    How to fix it?Thanks.

Viewing 15 replies - 1 through 15 (of 15 total)
  • What host, PHP version, Operating System are you using?

    If PHP 4, wonder if changing to PHP 5 might help.

    kiljaedener
    Member

    @kiljaedener

    Oh.It’s PHP 4.Thank you!

    I have the same problem after upgrading to 2.7 beta 3. It actually publishes the post, but it still says “You attempted to edit a post that doesn’t exist. Perhaps it was deleted?”
    I’m using php5, on godaddy host.

    This problem is still occurring for me, except now it is every single time I edit or publish a new post (since RC1).
    I am also with GoDaddy, like BettyJJ. I never had this problem before 2.7.

    phototristan
    Member

    @phototristan

    I’m having this problem too. My host is hostgator and I’m on PHP 5.2.6).

    For me, it churns for a while and eventually gives that error even though the post seems to be edited a-okay.

    phototristan
    Member

    @phototristan

    It looks like the page doesn’t reload properly after posting/editing. If I watch the ‘update’ button after clicking it, it blinks and then it seems the post is updated when it blink. But, the page never reloads properly after that.

    phototristan
    Member

    @phototristan

    Fixed in latest nightly build. Thanks.

    i just downloaded the latest RC1 and this problem is still occurring.

    On another note, I’m not sure if it was intended or not, but once you save a post, and are staring at it again and want to make a minor edit, it shouldn’t require you having to go back to the edit screen to select the post you want to edit.

    I presume that is not what the designers intended, but if they did that creates and extra step which I don’t think is necessary.

    I’m having this same problem with RC1. Updating a post works (the page does get updated) but I see the following error message each time I try to update a post.

    WordPress database error: [MySQL server has gone away]
    SELECT comment_approved, COUNT( * ) AS num_comments FROM wp_comments GROUP BY comment_approved

    WordPress database error: [MySQL server has gone away]
    SELECT * FROM wp_posts WHERE ID = 361 LIMIT 1

    You attempted to edit a post that doesn’t exist. Perhaps it was deleted?

    Tyler Regas
    Participant

    @tylermobodojocom

    I’m having the same issue, though I’m on RC1 via SimpleScripts and hosted by BlueHost. I’ve not attempted the in-built updater just yet. As described by others, after Publishing a new Post it hangs until it errors out.

    I had this issue but with 2.7rc2 that came out yesterday, the problem went away.

    I have this problem the production 2.7 code. Posts are saved but the “you attempted to edit a post that doesn’t exist. perhaps it was deleted” message is displayed. Funny thing is it’s not happening every time. Seems like if I quickly create a post or make an edit quickly I don’t get the error. Something to do with automatic draft saves perhaps?

    It’s still happening (but with full 2.7 release, not beta). I’m with SiteGround.com, PHP v. 5.2.5.

    askew_media
    Member

    @askew_media

    Hello, I am having this same issue. I am redirected to a page that says “You attempted to edit a post that doesn’t exist. Perhaps it was deleted?” after I click “update post”.

    Its been working fine all along. I tried to disable some plugins to see if that was the issue. I also upgraded from 2.7 to 2.7.1. Still not working.

    I am with Siteground using PHP 5.2.6. Any suggestions?

    Thanks

    renderingstudio
    Member

    @renderingstudio

    Hello Friends,

    I have a also same issue Please Suggest me.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘2.7 beta – Edit Problem’ is closed to new replies.