WordPress.org

Forums

Edit Post Box Jumps to Top (16 posts)

  1. jhsing
    Member
    Posted 5 years ago #

    Everytime I have a long post that I'm writing, the edit post box would jump to the top every 10-15 seconds. It would jump back to where I was if I continued typing. This make writing a long post difficult as it would keep jumping up and down.

    I tried changing autosave by setting it up to 300s from wp_config but that didn't work. I also removed the autosave command from post.php and post-new.php and it's still doing it. Now I just don't get the autosave written on the bottom of the edit box, but it still jumps to the top at random times, like every 5 seconds or so.

    How can I prevent it from doing this?

  2. hoss501
    Member
    Posted 5 years ago #

    It does the same thing to me.
    I get the same result on three different machines with a mix of wirless, trackball and optic mouse....es.

    This is a serious problem.
    I'm sure we're not the only ones experiencing this.

    Please let us know if there's a fix or not.

    My workaround is to cut and paste to an editor, make changes and cut and past back.

  3. W B
    Member
    Posted 5 years ago #

    I've been experiencing the same thing... HIGHLY aggravating.

    I've been using IE and the cursor jumps back to the beginning of the post every 10-15 seconds. Very distracting and annoying.

    What is the solution to this bug?

    Also, I've only experienced this while in HTML mode. Visual mode does not create this strange behavior on the editor's part. Perhaps until the HTML component is fixed we can use the visual aspect and be less bothered.

  4. alism
    Member
    Posted 5 years ago #

    What browsers are you trying? Have you tried disabling any plugins?

  5. colinfang
    Member
    Posted 5 years ago #

    yes yes i am experiencing this problem too. whenever I move my mouse cursor out of the edit box, the content in the editbox jumps to the top. very very annoying!!!!!

  6. colinfang
    Member
    Posted 5 years ago #

    plus, this happened still when I tried firefox3.5, ie8, chrome, and disabled all plugins. i am using wordpress 2.8.6

  7. mtpollack
    Member
    Posted 5 years ago #

    I have recently upgraded from a much earlier version and now have this problem as well. It is a horrible annoyance. If it could save without refreshing the page that ought to take care of it; it's obviously possible, as the older version didn't have this problem.

  8. colinfang
    Member
    Posted 5 years ago #

    horrible issue, why no one pays attention to it?

  9. vtxyzzy
    Member
    Posted 5 years ago #

    You might try Dean's FCKEditor plugin. I like it much better than TinyMCE.

  10. wrowlands
    Member
    Posted 5 years ago #

    This is a terrible problem. I have spoken with a number of people who use WordPress to edit code and they ALL have this problem. I appears that no one is working on a change to fix the bug. The Dean's FCKEditor plugin has its own bugs. I am not interested in plugins that create "bulky" code. I just want to write pure HTML. I anyone out there working on this? I am using version 2.9.2

  11. savvy4
    Member
    Posted 5 years ago #

    Here are some observations that I've noticed that hopefully will help someone more clever than me figure this out.

    If you open a post, either new or existing, in the html editor, and stay there, then my page does not jump. You can still click the Preview to see how the post looks, and return to the html editor with no jumping.

    But, as soon as you toggle over to the Visual tab, and then back to the HTML editor, the jumping begins.

    I have worked around the problem by extending my text box (while in Visual) very long to cover the length of my html code.

    I hope someone comes up with a solution soon.

  12. mortifrog
    Member
    Posted 4 years ago #

    This is still ultra annoying! I hope this gets fixed as a priority. Also, a slighty bigger (like twice as long) editing window in html view would be nice. Pleeease fix this.

    According to this post, the workaround is to use compatibility view in IE8. Not ideal, but seems to work.

  13. vtxyzzy
    Member
    Posted 4 years ago #

    @mortifrog, you can change the size of the edit window in Admin->Settings->Writing->Size of the post box.

  14. mortifrog
    Member
    Posted 4 years ago #

    Thanks for that vtxyxxy

  15. kenb22
    Member
    Posted 4 years ago #

    I was having the mad jumping post box problem as well when editing in HTML mode using FCK Editor. What I disocvered was that the problem went away when I was using Firefox as opposed to IE. My advice: If you're at the end of your rope with this problem, try switching to Firefox.

  16. lovelure
    Member
    Posted 4 years ago #

    I have dabbled with WP for a few years and am just launching my first real live blog. I have tried both FireFox and IE8 (not compatibility mode) and have had the same problem in both places. I agree with savvy4 though - it does seem to be a problem when you toggle views from Visual to HTML.

    I have found a stupid but helpful workaround for me. I found the two most common reasons I was switching to HTML view were a) to create tables b/c WP's table management seems to stink, and b) to insert horizontal rules. My workaround was to try to install two plugins that allow me to take care of these two tasks in Visual view. I say "try to" because the HR one created an error, so I'll have to rewrite that one. But the table looks pretty good. It's called wp-table-reloaded. HTH.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.