Support » Plugin: QA Cost of Goods & Margins » edit.php?post_type=product keeps loading forever

  • Resolved donot

    (@donot)


    Hi there, this is a great plugin but has big issue (at least what I am facing).

    When the plugin is active, the edit.php?post_type=product in the Developer Tools > Network is always pending, making the admin page unresponsive and keep loading forever.

    I don’t know if anyone has had this issue but is there anything I can provide you so you can maybe have a look/replicate?

    Thanks

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor Robbie Cleijsen

    (@cleijsen)

    Hi,

    thanks for your feedback.

    We have not seen or heard about this issue before, but we’ll have a look at it right away.

    Let me get back to you if we need more information.-

    Kind regards
    Robert

    Plugin Contributor KHAN

    (@codemascot)

    Hi donot,

    Thanks for letting us know your issue regarding our plugin. We have tried to replicate your issue in our localhost with Firefox and Chrome latest version, but failed to do so with both of them. So, now we need some more details regarding the issue. Obviously you can skip any of them if you think they are confidential.

    Our queries-

    1. Both WordPress and WooCommerce version numbers.
    2. Our plugin, QA Cost of Goods & Margins version number.
    3. Browser(s) name and version number(s).
    4. Can you send us the WooCommerce status report? You’ll get it by going to WooCommerce >> Status >> System status.
    5. Have you tested your system for this issue by deactivating all the other plugins except WooCommerce and any third party themes?

    Lastly, it would be really helpful if you send us the process of replicating the issue.

    Have a good day.

    Thank you.

    Regards,
    Khan

    Plugin Contributor KHAN

    (@codemascot)

    Hi donot,

    Thanks for letting us know your issue regarding our plugin. We have tried to replicate your issue in our localhost with Firefox and Chrome latest version, but failed to do so with both of them. So, now we need some more details regarding the issue. Obviously you can skip any of them if you think they are confidential.

    Our queries-

    1. Both WordPress and WooCommerce version numbers of your system.
    2. Our plugin, QA Cost of Goods & Margins version number.
    3. Your browser(s) name(s) and version number(s).
    4. Can you send us the WooCommerce status report? You’ll get it by going to WooCommerce >> Status >> System status.
    5. Have you tested your system for this issue by deactivating all the other plugins except QA Cost of Goods & Margins and WooCommerce and any third party themes?

    Lastly, it would be really helpful if you send us the process of replicating the issue.

    Have a good day.

    Thank you.

    Regards,
    Khan

    Hi Khan, thanks for looking into this.

    1. WordPress 5.2.4 – WooCommerce 3.8.0
    2. QA Cost of Goods & Margins Version 1.1.0
    3. Version 78.0.3904.87 (Official Build) (64-bit)
    4. Long report, so create a DOC: https://docs.google.com/document/d/1-rXp4aG4b1ez_tvf9Lw4lizekhv9liSOa62hFG-GuxE/edit?usp=sharing
    5. The issues doesn’t exist when “QA Cost of Goods & Margins” is disabled. But I will try it right now to only leave WooCommerce and QA Cost of Goods & Margins active and get back to you.

    To replicate is very easy.
    From anywhere in the administration, I click on /wp-admin/edit.php?post_type=product and then this happens. (See screenshot https://ibb.co/LpbrcFG).

    And after a really long waiting time, I get this error message from my site: “And then, I get email notification from my site:
    An E_ERROR error has been caused in line 23 of the file /wp-content/plugins/woocommerce/includes/wc-term-functions.php. Error message: Maximum execution time of 240 seconds exceeded”

    Thanks,
    Klaudio

    p.s. Maybe it is worth mentioning that I have a lot of variable products. One product can have from 40 variants to 7500 variants, totalling ± 70 000 variations.

    • This reply was modified 11 months, 3 weeks ago by donot.

    Update: I confirm that the issue stil persists, while having only WooCommerce & QA Cost of Goods & Margins plugins activated.

    Plugin Contributor Robbie Cleijsen

    (@cleijsen)

    Hi Klaudio,

    we will try and replicate this issue in our test environment and will get back to you during the day or latest tomorrow.
    as you mention, it might have to do with the high number of variations, but we’ll hopefully have a better understanding soon.

    Thanks for your patience.

    BR
    Robbie

    Plugin Contributor Robbie Cleijsen

    (@cleijsen)

    Hi Klaudio,

    just a short follow up on this issue. We have not been able to replicate this issue.
    At the moment, we are adding a number of new features and requests, which is taking most of our time. We plan to be ready with these by the end of this week and will then reach out to you once more to see if we can understand what is happening and whether this is related to the amount of variations, or related to our plugin.

    Thanks for your patience.

    Kind Regards,
    Robbie

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘edit.php?post_type=product keeps loading forever’ is closed to new replies.