WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Edit page shows apparently empty edit area

[Resolved] Edit page shows apparently empty edit area

  • lockettpots
    Member

    @lockettpots

    Hi
    After a year of working correctly I have run into a real problem.
    The website displays correctly but on going to the admin area and attempting to edit a post this happens:-

    The editing area is apparently blank. I say apparently because if I drag the cursor over the area the text shows, highlighted in blue, in HTML format.

    No toolbar shows.

    The Visual and HTML tabs do not work.

    The upload media buttons do not work.

    The same things apply also when I try to create a new post.

    This happens in Firefox, IE, Chrome and Opera browsers. I have disabled all plugins, switched to default theme, Used FTP to rename the plugins folder and updated to 3.4.1. None of these have made any difference to the problem.

    This first happened before updating to 3.4.1

    Where do I go from here please?

    Thanks in advance
    John

Viewing 12 replies - 1 through 12 (of 12 total)
  • esmi
    Forum Moderator

    @esmi

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.

    lockettpots
    Member

    @lockettpots

    Hi esmi
    Thanks for the response. You will see from the original post that I have done everything except the last, but I did an upgrade to 3.4.1.

    What about the config file? I presume that I don’t re-upload that?

    John

    esmi
    Forum Moderator

    @esmi

    Please try the last step I gave above.

    lockettpots
    Member

    @lockettpots

    A bit more information

    If I view the page source the content of the post is there!!!

    John

    lockettpots
    Member

    @lockettpots

    Hi esmi

    I’ve re-uploaded by FTP all the files and folders from a fresh download but to no avail I’m afraid.

    What now?

    John

    esmi
    Forum Moderator

    @esmi

    Site url?

    Have you checked your servers error logs?

    lockettpots
    Member

    @lockettpots

    Hi esmi

    http://www.breakthrough-to-learning.co.uk is the URL but as I said the site displays perfectly to visitors. It’s the content editor that has the problem.

    The server error logs do not show any related errors.

    John

    esmi
    Forum Moderator

    @esmi

    Try adding define('CONCATENATE_SCRIPTS', false ); to the bottom of your wp-config.php file (just before the require_once line).

    lockettpots
    Member

    @lockettpots

    Hi esmi

    I’m afraid that produced a server error when I tried to access the site through Chrome. Removing the line gave me access again.

    I’ve contacted the hosting provider in case they have changed any server settings which might account for the problem, but any further suggestions from you would be very much appreciated since the site actually belongs to a client and as you can imagine I’m getting no end of grief!!!

    lockettpots
    Member

    @lockettpots

    Hi esmi

    Ignore the first part of the reply. I think I mistyped it.

    lockettpots
    Member

    @lockettpots

    Hi esmi

    You are a GENIUS!!!! That extra line on the config file did the trick.
    I can’t tell you how grateful I am.

    John

    lockettpots
    Member

    @lockettpots

    Seems to be resolved!

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] Edit page shows apparently empty edit area’ is closed to new replies.