Support » Fixing WordPress » Site not displaying properly and 'Edit Page' content looks blank?!

  • Hi,

    I was trying to edit some pages this evening and the ‘Edit Page’ content window is blank. It’s also missing the tool bar.

    If I highlight within the window, there is actually some text (looks like HTML) there, but it doesn’t look as it normally does. Clicking the ‘text’ and ‘visual’ tabs does nothing, so it’s not that I’ve accidentally clicked there.

    At the same time, I have noticed that my site ( isn’t displaying as it should. The layout is merely text links, no sidebar, no dropdown menu etc.

    I tried deactivating a few of the most recently updated plug-ins, but that hasn’t helped. Any ideas?

    I’m not aware that I’ve changed anything structurally at all since I posted my last page and post yesterday, so I really can’t work out what’s changed.

    I’ve also tried viewing the site on my mobile in case the problem was specific to this laptop, but the problem was replicated there. I’ve also checked in Firefox, Chrome and IE, all the same.

    Please help!

Viewing 15 replies - 1 through 15 (of 27 total)
  • I don’t have an answer, but I am having a similar problem.

    When I try to edit a site, the edit box is blank and the toolbar is gone, just as the previous poster described.

    However, when I visit site, all pages and content are there.

    I have re-installed WordPress to see if that would solve the problem but the behavior is still the same.

    I had been working on the site yesterday, took a break, and there was a few-second power glitch due to a thunderstorm. I have a UPS and the computer remained running. However, the next time I tried to work on the website I observed this problem. I don’t know if it is related, but that is why I tried a re-installation of WordPress to see if that would help.

    Moderator Jan Dembowski


    Brute Squad and Volunteer Moderator

    I was trying to edit some pages this evening and the ‘Edit Page’ content window is blank. It’s also missing the tool bar.

    A blank page is sometimes (almost always) a sign of a PHP problem such as a theme and/or plugin conflict. Can you try the following from the WordPress dashboard for troubleshooting purposes?

    – Deactivate all of your plugins. Everyone, you can re-activate them later.

    – Switch to the Twenty Twelve theme.

    – Clear your browser’s cache and cookies.

    Then re-login and attempt to edit a page again. Does the editor work after that?


    I deactivated all plugins on Cleared cache and cookies. Webpages still displaying incorrectly, Edit Page still blank.

    So, (with all plugins still deactivated) I switched to TwentyEleven Parent Theme (only other one already installed). Cleared cache and cookies. Webpages displaying as I’d expect, Edit Page still blank.

    So, (with all plugins still deactivated) I installed and activated TwentyTwelve Theme. Cleared cache and cookies. Webpages displaying as I’d expect, Edit Page still blank.

    WordPress dashboard and website is veeerry sloow to respond, if that gives any clues? All other browsing is normal.

    I’m returning site to TwentyEleven Child Theme and all plugins so anyone who wants to can look at it as was.

    Your site displays fine for me – in twentyeleven child.

    It looks like you are using W3 total cache which can be quite problematic – try deactivating it and flushing the cache – if you need specific help on how to do that – see the plugins page and/or forum:

    Hi WPyogi,

    I’m interested that you say the site displays fine for you. I’ve checked on my laptop in three different browsers, on my mobile, and on my husband’s laptop, all of which are not displaying it as per the theme, although the content and banner image are at least present, just not as they’re supposed to be.

    I’ve deactivated W3 Total cache again (Jan asked me to deactivate all plugins, and that didn’t work) but I’m afraid I don’t know what you mean by ‘flushing the cache’? I tried searching the forum you linked to but none of the threads I read explained it. I clicked ’empty all caches’ before deactivating, if that helps?

    Site also looks correct to me, drop down menus, etc. in IE10.

    Aha, when I first loaded the site today, I had the same problem, but I followed a link to my site from Facebook and it does indeed display correctly now, no matter whether I type the address in directly or follow a link… how odd.

    But the Edit Page window is still not working properly. 🙁

    And I’m back to square one. Site again no longer displaying correctly, on my laptop, mobile, PC, and husband’s laptop 70 miles away at work, so not even just a local issue…

    I have been unable to write or edit any pages in days because the Edit Page window is still blank.

    Load times have also increased massively – average page load time for the last month was reliably around 500ms according to pingdom – since April 2nd it has increased to 2000ms and even 3000ms.

    Can anyone help?!?!

    Hey Big_Birtha…

    Have you deactivated all plugins as suggested by Jan Dembowski?

    Just a quick look at the source of your site has it loading a few javascripts that I really wouldn’t expect to see there from a vanilla site.


    Hi help@meta4themes,

    If you see the post I wrote immediately after Jan Dembowski, I did exactly as suggested, in stages, and detailed the results.

    I then returned it to the site as it was previously as Jan’s suggestions didn’t work.

    What is a vanilla site? And what javascripts?



    Javascripts are basically the programs that make a lot of the web work the way it does.

    And a vanilla site is a site with just the most basic elements installed.

    Another look at the way your site loads indicates to me that you are having similar issues to this person here:

    You don’t have to understand whats being said there, but just that the plugin’s author suggested reinstalling the Jetpack plugin to try and fix the problem.

    Maybe you could do the same?


    Hi help@meta4themes,

    Sorry, you misunderstood/misread my question about javascript – it wasn’t what IS javascript, but rather what javascripts are you seeing that you wouldn’t expect?

    Is ‘vanilla’ a derogatory term? It seems it when I’ve spent so long working on the site!

    I tried uninstalling and deleting Jetpack. I also rolled back my site to before I had the problem, just in case. Edit Page is STILL BLANK!?!

    I tried running P3 Plugin Profiler after deleting Jetpack to see if that identified any plugins causing the problem – but that isn’t displaying correctly either – it ran the scan, but didn’t display a graphical breakdown of plugin use.

    I’ve left Jetpack (and W3 Total Cache) uninstalled for now.

    Any further help or suggestions graefully received, this is really driving me nuts now!!

    This is what your site looks like to me. I zoomed it down so I could capture more of it.

    Does it look like that to you?

    Is ‘vanilla’ a derogatory term?

    Not at all. It is just a site with no bells or whistles.


    Is ‘vanilla’ a derogatory term?

    …perhaps someone has a preference for chocolate?

    Anyway.. is the “edit” screen broken for posts, too, or just pages?

    Hi kmessinger,

    That is what the site is supposed to look like. This is what I’m seeing:

    Although I have occasionally had it display correctly over the last few days it has mostly looked like my link above – like I say, I’ve checked in Firefox, Chrome and IE, all the same, and on my laptop, my husband’s laptop at work 70 miles away, my mobile, my PC… I just don’t understand how it’s working ok for you and not for me. I don’t understand how it’s come to be broken in the first place, but that’s another matter!

    If it was just displaying wrongly for me and correctly for everyone else, I wouldn’t mind, but the fact that I can’t edit anything it a real problem.

    help@meta4themes, yes, edit posts is as broken as edit pages.


Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘Site not displaying properly and 'Edit Page' content looks blank?!’ is closed to new replies.