Site not displaying properly and 'Edit Page' content looks blank?! (28 posts)

  1. Big_Birtha
    Posted 2 years ago #


    I was trying to edit some pages this evening and the 'Edit Page' content window is blank. It's also missing the tool bar.

    If I highlight within the window, there is actually some text (looks like HTML) there, but it doesn't look as it normally does. Clicking the 'text' and 'visual' tabs does nothing, so it's not that I've accidentally clicked there.

    At the same time, I have noticed that my site (http://bigbirthas.co.uk) isn't displaying as it should. The layout is merely text links, no sidebar, no dropdown menu etc.

    I tried deactivating a few of the most recently updated plug-ins, but that hasn't helped. Any ideas?

    I'm not aware that I've changed anything structurally at all since I posted my last page and post yesterday, so I really can't work out what's changed.

    I've also tried viewing the site on my mobile in case the problem was specific to this laptop, but the problem was replicated there. I've also checked in Firefox, Chrome and IE, all the same.

    Please help!

  2. opustwo
    Posted 2 years ago #

    I don't have an answer, but I am having a similar problem.

    When I try to edit a site, the edit box is blank and the toolbar is gone, just as the previous poster described.

    However, when I visit site, all pages and content are there.

    I have re-installed WordPress to see if that would solve the problem but the behavior is still the same.

    I had been working on the site yesterday, took a break, and there was a few-second power glitch due to a thunderstorm. I have a UPS and the computer remained running. However, the next time I tried to work on the website I observed this problem. I don't know if it is related, but that is why I tried a re-installation of WordPress to see if that would help.

  3. I was trying to edit some pages this evening and the 'Edit Page' content window is blank. It's also missing the tool bar.

    A blank page is sometimes (almost always) a sign of a PHP problem such as a theme and/or plugin conflict. Can you try the following from the WordPress dashboard for troubleshooting purposes?

    - Deactivate all of your plugins. Everyone, you can re-activate them later.

    - Switch to the Twenty Twelve theme.

    - Clear your browser's cache and cookies.

    Then re-login and attempt to edit a page again. Does the editor work after that?

  4. Big_Birtha
    Posted 2 years ago #


    I deactivated all plugins on http://bigbirthas.co.uk. Cleared cache and cookies. Webpages still displaying incorrectly, Edit Page still blank.

    So, (with all plugins still deactivated) I switched to TwentyEleven Parent Theme (only other one already installed). Cleared cache and cookies. Webpages displaying as I'd expect, Edit Page still blank.

    So, (with all plugins still deactivated) I installed and activated TwentyTwelve Theme. Cleared cache and cookies. Webpages displaying as I'd expect, Edit Page still blank.

    WordPress dashboard and website is veeerry sloow to respond, if that gives any clues? All other browsing is normal.

    I'm returning site to TwentyEleven Child Theme and all plugins so anyone who wants to can look at it as was.

  5. WPyogi
    Forum Moderator
    Posted 2 years ago #

    Your site displays fine for me - in twentyeleven child.

    It looks like you are using W3 total cache which can be quite problematic - try deactivating it and flushing the cache - if you need specific help on how to do that - see the plugins page and/or forum:


  6. Big_Birtha
    Posted 2 years ago #

    Hi WPyogi,

    I'm interested that you say the site displays fine for you. I've checked on my laptop in three different browsers, on my mobile, and on my husband's laptop, all of which are not displaying it as per the theme, although the content and banner image are at least present, just not as they're supposed to be.

    I've deactivated W3 Total cache again (Jan asked me to deactivate all plugins, and that didn't work) but I'm afraid I don't know what you mean by 'flushing the cache'? I tried searching the forum you linked to but none of the threads I read explained it. I clicked 'empty all caches' before deactivating, if that helps?

  7. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    Site also looks correct to me, drop down menus, etc. in IE10.

  8. Big_Birtha
    Posted 2 years ago #

    Aha, when I first loaded the site today, I had the same problem, but I followed a link to my site from Facebook and it does indeed display correctly now, no matter whether I type the address in directly or follow a link... how odd.

    But the Edit Page window is still not working properly. :(

  9. Big_Birtha
    Posted 2 years ago #

    And I'm back to square one. Site again no longer displaying correctly, on my laptop, mobile, PC, and husband's laptop 70 miles away at work, so not even just a local issue...

    I have been unable to write or edit any pages in days because the Edit Page window is still blank.

    Load times have also increased massively - average page load time for the last month was reliably around 500ms according to pingdom - since April 2nd it has increased to 2000ms and even 3000ms.

    Can anyone help?!?!

  10. help@meta4themes
    Posted 2 years ago #

    Hey Big_Birtha...

    Have you deactivated all plugins as suggested by Jan Dembowski?

    Just a quick look at the source of your site has it loading a few javascripts that I really wouldn't expect to see there from a vanilla site.


  11. Big_Birtha
    Posted 2 years ago #

    Hi help@meta4themes,

    If you see the post I wrote immediately after Jan Dembowski, I did exactly as suggested, in stages, and detailed the results.

    I then returned it to the site as it was previously as Jan's suggestions didn't work.

    What is a vanilla site? And what javascripts?


  12. help@meta4themes
    Posted 2 years ago #


    Javascripts are basically the programs that make a lot of the web work the way it does.

    And a vanilla site is a site with just the most basic elements installed.

    Another look at the way your site loads indicates to me that you are having similar issues to this person here:


    You don't have to understand whats being said there, but just that the plugin's author suggested reinstalling the Jetpack plugin to try and fix the problem.

    Maybe you could do the same?


  13. Big_Birtha
    Posted 2 years ago #

    Hi help@meta4themes,

    Sorry, you misunderstood/misread my question about javascript - it wasn't what IS javascript, but rather what javascripts are you seeing that you wouldn't expect?

    Is 'vanilla' a derogatory term? It seems it when I've spent so long working on the site!

    I tried uninstalling and deleting Jetpack. I also rolled back my site to before I had the problem, just in case. Edit Page is STILL BLANK!?!

    I tried running P3 Plugin Profiler after deleting Jetpack to see if that identified any plugins causing the problem - but that isn't displaying correctly either - it ran the scan, but didn't display a graphical breakdown of plugin use.

    I've left Jetpack (and W3 Total Cache) uninstalled for now.

    Any further help or suggestions graefully received, this is really driving me nuts now!!

  14. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    This is what your site looks like to me. I zoomed it down so I could capture more of it. https://www.dropbox.com/s/vpnnw2hkpkdasvm/bb.jpg

    Does it look like that to you?

    Is 'vanilla' a derogatory term?

    Not at all. It is just a site with no bells or whistles.

  15. help@meta4themes
    Posted 2 years ago #


    Is 'vanilla' a derogatory term?

    ...perhaps someone has a preference for chocolate?

    Anyway.. is the "edit" screen broken for posts, too, or just pages?

  16. Big_Birtha
    Posted 2 years ago #

    Hi kmessinger,

    That is what the site is supposed to look like. This is what I'm seeing: http://bigbirthas.co.uk/wp-content/uploads/2013/04/Capture.jpg

    Although I have occasionally had it display correctly over the last few days it has mostly looked like my link above - like I say, I've checked in Firefox, Chrome and IE, all the same, and on my laptop, my husband's laptop at work 70 miles away, my mobile, my PC... I just don't understand how it's working ok for you and not for me. I don't understand how it's come to be broken in the first place, but that's another matter!

    If it was just displaying wrongly for me and correctly for everyone else, I wouldn't mind, but the fact that I can't edit anything it a real problem.

    help@meta4themes, yes, edit posts is as broken as edit pages.


  17. WPyogi
    Forum Moderator
    Posted 2 years ago #

    That looks like CSS is not being loaded - and it does show a problem with CSS from JetPack - see:


    I'd also still suspect W3 Total Cache - that's known to be problematic and deactivating it does not get rid of it entirely. There are some other files that you have to delete - I'm not sure of the details on how to do that - see the plugin sub-forum as I suggested above.

  18. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    I agree with WPyogi. You should disable and remove W3 Total Cache. You do not need any caching software at the stage anyway. W# writes a bunch of stuff in the htaccess file that all needs to be taken out even when you delete it.

    Please delete the wp-content and wp-includes folder. Download a fresh copy of wordpress and upload new copies of those directories using ftp. Watch the ftp log for any errors. Make sure you delete not just copy over. Do not touch the wp-content folder.

    As always, make sure you have a backup of the database before doing anything.

  19. Big_Birtha
    Posted 2 years ago #

    Hi, thanks guys and sorry it's been so long since I replied. Teething 10 month old has meant that I haven't been on the PC in days - http://bigbirthas.co.uk has been very neglected :(

    That W3C thing looks very interesting. And led me to realise that even before deleting W3TC the BBPress forum had disappeared. The 'Forum' page had gone completely, although its menu link was still there. Yet another problem, which is now null and void as the bbpress plugin is currently inactive so it wouldn't work anyway.

    I tried to follow the instructions on how to delete W3 Total Cache here http://journalxtra.com/websiteadvice/wordpress/uninstall-w3-total-cache-proper-3920/
    but fell at the first hurdle, well, the second hurdle: "Ensure your htaccess file has its permissions set to at least 644" I opened my htaccess file and could find nothing in it about permissions or anywhere there was a number even?!
    Same problem for hurdle # 3: Ensure wp-config.php has its permissions set to at least 644 - nothing in wp-config.php about permissions or a number.

    But I carried on regardless.

    I got stuck again on #9 Check the site’s .htaccess file has no W3TC re-write rules in it.
    I checked htaccess. it says this:

    <FilesMatch "\.(ttf|otf|eot|woff)$">
    <IfModule mod_headers.c>
        Header set Access-Control-Allow-Origin "*"
    # END W3TC CDN
    # BEGIN W3TC Browser Cache
    <IfModule mod_deflate.c>
        <IfModule mod_headers.c>
            Header append Vary User-Agent env=!dont-vary
            AddOutputFilterByType DEFLATE text/css text/x-component application/x-javascript application/javascript text/javascript text/x-js text/html text/richtext image/svg+xml text/plain text/xsd text/xsl text/xml image/x-icon application/json
        <IfModule mod_mime.c>
            # DEFLATE by extension
            AddOutputFilter DEFLATE js css htm html xml
    # END W3TC Browser Cache
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    If that means anything to anyone.

    I don't want to alter anything as I don't understand it. And then I discovered that there are several other htaccess files in subfolders... but none of them mention W3TC. But I assume that's the one that I'm meant to edit?

    Finally, #10 says open the site wp-config.php file and change the line that reads "define('WP_CACHE', true) to define('WP_CACHE', false)" except that isn't there either.

    Other than that, I followed the instructions as best I could!

    I then removed the wp-content and wp-includes folders, downloaded WordPress, extracted wp-content and wp-includes folders and uploaded them again. No ftp upload errors.

    I checked the site. It's displaying correctly, apart from the header, and the forum and it's link have now disappeared completely (not a surprise since all the plugins are gone and it was a bbpress forum) but when I try to Edit Page or Edit Post the pages are STILL not functioning?!!?!

    Here's what the edit page screen looks like:

    And here it is again with the apparently blank window highlighted:

    So, next plan of action?

  20. Big_Birtha
    Posted 2 years ago #

    I've now tried installing Google Libraries Plug-in, as per the instructions on this page: http://dmjcomputerservices.com/blog/2012/02/15/wordpress-post-edit-area-is-blank-displays-white-text-on-white-background/

    Didn't work either :(

  21. Rajesh Soni
    Posted 2 years ago #

    Have you tried switching to "text" mode on the edit page?

    I am suspecting a broken CSS / html tag that's why the content appears 'invisible' in visual mode.

  22. Big_Birtha
    Posted 2 years ago #

    Hi Rajesh,

    Thanks for your help, but if you read my original post, the fourth line reads "Clicking the 'text' and 'visual' tabs does nothing".

  23. Big_Birtha
    Posted 2 years ago #

    OK, further information...

    I backed up the database.
    I deleted EVERYTHING (except the apache logs because I couldn't).
    I reinstalled WordPress from scratch.
    Even with no new plugins, no new themes, nothing, the edit page still does not work.

  24. WPyogi
    Forum Moderator
    Posted 2 years ago #

    Have you tried this:
    - open wp-config.php and try adding the following line before "That's all, stop editing! Happy blogging" Add this to your wp-config file: define('SCRIPT_DEBUG', true);

    If that does not work, remove it and try the fix in this thread:


  25. Big_Birtha
    Posted 2 years ago #

    Thanks for your help everyone. I have fixed the problem. Sort of.

    I had been using Cloudflare, which necessitates routing your website through their nameservers. I reverted my nameservers back to the GoDaddy original settings. Took 24 hours to do, but now a fresh install of WordPress does actually work.

    All I need to do now is work out why my content doesn't seem to be showing up despite my returning it to the folders using FTP. :o(

  26. Big_Birtha
    Posted 2 years ago #

    OK, when people told me to 'backup my database' what did they mean by that? How should I have gone about it? I went into my file manager on my hosting account, downloaded all the files as a zip file (from 3 different points in time)...

    Now I've reinstalled WordPress and it's working, but when I re-upload the files to their folders, WordPress can't find them and I no longer have any content.


  27. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    http://codex.wordpress.org/Backing_Up_Your_Database and your host most likely has a faq which talks about it. Did you set-up a new database?
    If so the other should still be there.

  28. Big_Birtha
    Posted 2 years ago #

    Hi, I've spoken to my host. Turns out I did a very silly thing.

    I deleted the files and uninstalled and reinstalled wordpress safe in the knowledge that I had downloaded and saved all the files, and if my some freak of chance there was a problem, GoDaddy keeps a history of files for about 2 weeks.

    Except I didn't understand that the content of my website was not stored in files, but in an SQL database, which GoDaddy doesn't automatically keep a history of. My restoring the files via FTP wouldn't achieve anything without the database, but I had no idea that was the case, obviously, or I wouldn't have done it.

    It's all gone. GoDaddy can get it back for me, but would charge $150 for the privilege. I can't justify that for a personal website, even if it does mean the loss of 3 months work...

    Shame that at the point of uninstalling and re-installing WordPress, which was a pretty simple two-click operation, the 'are you sure you want to do this?' didn't advise me to back up the SQL database first... I had never heard of an SQL database until I learnt that I'd irrevocably deleted mine.

    Lesson learnt. Have now saved all the webpages cached by Google and am preparing to rebuild from scratch.

    On the plus side, I seem to have fixed my original problem...

Topic Closed

This topic has been closed to new replies.

About this Topic