Support » Plugin: Permalink Manager Lite » Edit once then greyed out

  • palmtek

    (@palmtek)


    Well, it didn’t work. Had a post with two categories. I changed the “Current URI” to switch the default category, saved it and failed the test. Went back to check the edit and my changes were undone and greyed out so as not to be able to touch that posts URI anymore and it was stuck on the first Category again.

    What a friggin waste of time

    • This topic was modified 7 months ago by palmtek.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Thread Starter palmtek

    (@palmtek)

    To be a little fair, I can make the change from their URI editor in the posts tab. Very clunky though. Even worse interface in the edit post screen.

    Plugin Author Maciej Bis

    (@mbis)

    Hi @palmtek,

    First of all, I would like to apologize for the inconvenience. Your comment is maybe a little too harsh, but actually you are right – there is a big room for improvement when it comes to UX & UI of my plugin.

    I think that I should try to explain what happened in your particular case. I guess that you probably enabled “Auto-update” mode:
    https://permalinkmanager.pro/docs/basics/automatically-update-the-permalinks/

    Then, as the URI field was greyed-out, it was not possible to adjust the individual permalink via “Edit Post/page” interface. However, in the bulk editor (Tools -> Permalink Manager -> URI Editor) it was still possible to change it, because none of the URI fields is blocked for edit. The problem here is that whenever you adjust the URI there, your manual changes are overwritten with the default permalink (because of “Auto-update” mode).

    Here is the first thing that will be improved in the next release. Whenever “Auto-update” mode is turned-on, the URI field will be disabled not only in “Edit Post/Page” interface but also in Tools -> Permalink Manager -> URI Editor section.

    Furthermore, I decided to add additional description and improve the UI/UX in the URI editor. It should be straightforward and easy to understand what exactly happens when “Auto-update the URI” mode is turned on and the URI field disabled (greyed out).

    Best regards,
    Maciej

    Plugin Author Maciej Bis

    (@mbis)

    As a follow-up to my previous comment.

    To “patch” the most critical UI issues (before I do the full revamp) I decided to add two adjustments in the next release:

    Single URI Editor:
    https://imgur.com/xJsrnFL
    * Additional description below URI field when “Auto-update” mode is turned on.

    Bulk URI Editor:
    https://imgur.com/kd4I9pK
    * Additional description below URI field when “Auto-update” mode is turned on.
    * The URI field is set to “read-only” when “Auto-update” mode is turned on.

    Best regards,
    Maciej

    • This reply was modified 7 months ago by Maciej Bis.
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Edit once then greyed out’ is closed to new replies.