Support » Fixing WordPress » Edit/New post/page is a blank white screen in WP 5.0

  • Resolved Reggy

    (@fluxwavez)


    Similar to this topic, upgrading to WP 5.0 made it so attempting to create a new post would simply lead to a completely empty, white page with no elements at all.

    Unlike that issue, however, the problem did not go away once I disabled every plugin on the website, emptied the caches, or changed the theme to Twenty Nineteen. Installing the Classic Editor plugin, I’m able to at least use the previous editor.

    But I have no access to the new editor, and if I install the Gutenberg plugin, the blank page issue remains.

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator ๐Ÿš€

    You won’t need the Gutenberg plugin under WP 5.0, it actually won’t run.

    Thanks for ruling out plugins and the theme! Let’s try the browser next.

    First, please make sure that your browser is up to date by visiting https://whatbrowser.org/

    If it is not, please try updating your browser or switching to a different browser.

    If it is, please do these two things:

    1. Try clearing your browser’s cache and cookies.

    2. Try with all browser extensions or add-ons temporarily disabled.

    Please let us know how each step goes for you, and which browser (and version of) you’re using if you’re still having trouble.

    That did it. Initially, I used an up-to-date version of Chrome (Ver. 70.0.3538.110), and I thought I had ruled this one out because I had asked someone else (who was also using Chrome) what they were seeing on their own end, and it was the same blank page.

    However, trying on Microsoft Edge and also clearing cookies for the Chrome browser, I am able to see the Gutenberg editor.

    Thanks.

    • This reply was modified 7 months, 2 weeks ago by  Reggy.
    Moderator James Huff

    (@macmanx)

    Volunteer Moderator ๐Ÿš€

    Excellent! I’m glad that worked out. ๐Ÿ™‚

    Actually i too was faced by the same issue after updating my wordpress to version 5.1 but clearing the browser cache resolved the issue.

    Clearing cache did not work for me…nor did disabling plugins. Editing or posting pages or posts give a blank white screen.

    • This reply was modified 3 months, 1 week ago by  topspeak.

    Guys, I am so lost..

    I canโ€™t figure out any of the solutions or tech stuff. I canโ€™t even access or login to my site, so how am I supposed to deactivate a plugin? Iโ€™ve tried downloading WordPress but I canโ€™t even โ€œopenโ€ it, it just looks like a folder on my computer. I doesnโ€™t make ANY sense to me ๐Ÿ™ ๐Ÿ™

    Please help..

    The best solution is to install the classic editor. 4 million users can’t be wrong.
    It’s now a plugin:
    https://wordpress.org/plugins/classic-editor/
    When activated, all my blank screen problems went away, and I could go back to what works, and works well!

    I have the same problem with the white screen and not being able to post. It all started when I changed from Firefox to chrome. I am still working on old faithful windows xp and maybe that’s part of my problem. But I go on my laptop with windows 10, I can go on my website and I have no problem writing a blog post. The page is normal with no issues. To me that seems like a computer issue and not a plug-ins. I hate to upgrade my operating system but I will if I new for sure it would help. I am not a computer guru so I wouldn’t know where to start looking in my settings for the problem, but I think that’s where the culprit is. Like I said it worked fine until I changed to Chrome.

    @fakeologist, your trick works for me ๐Ÿ™‚

    Thank you

    • This reply was modified 1 month, 1 week ago by  Ajay Malhotra.
    RibOne

    (@ribone)

    I run several WordPress websites but I’m too now struggling with the white page on posts and pages. It’s visual on the text screen but not on the visual screen. I’ve done all the usual, disable all plugins, clear cache etc.

    All sites updated to 5.2.1โ€“en_GB which has worked well until this last one. In particular, I always revert back to the ‘classic editor’ as this works best for me. However, going back to Gutenberg on this site, the page just collapses with the toolbar defaulting to a vertical aspect over the posts/pages content and unable to edit.

    I’ve tried a reinstall 5.2.1 but alas no better. Everything else appears to be working well. It’s looking like a missing piece of code, but where?

    Any direction appreciated.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.