Support » Fixing WordPress » Edit media preview not working

  • When I try to edit a graphic (resize / crop / etc.) the preview image does not show, (broken icon – no error message) so no editing is possible.

    Have tried removing all plugins / moving to 2012 theme / clear cache / etc.

    I’ve tried fresh image uploads as well as via Set Featured Image.

    I presume this is the ajax preview.

Viewing 15 replies - 1 through 15 (of 18 total)
  • Hi,

    Did you check folder permissions for the “uploads” folder :
    …/wp-content/uploads

    Permissions code should be “755”, but if it’s still don’t work, try with “777”.

    Thanks for the quick reply.

    Yes… permissions are already “777”

    Everything uploads fine… just this darn preview image does not want to show.

    Is a little popup (even if empty) appear when you click on “Preview” ?

    Hmmm… I’m not seeing a “Preview” button in the “Edit Media” screen.

    Just the image title, permalink, crop tools (dimmed), the broken image icon, cancel/save buttons.

    On the right… the upload date/time, file URL, name type etc., delete permanently link and Update button.

    Am I in the right place?

    Yes, you’re in the right place, sorry.

    Try to compare the broken image URL/name and the new generated files in your wp-content/uploads/2012/… folder, you should see new files created after you saved the changes.

    Thank you for your patience.

    Since I can’t edit the image (without the pre

    The link above shows the icon I’m referring to. Since I can’t edit it, I can’t save a new version to see if it shows up.

    Again… VERY much appreciate you walking me through this.

    No… With your browser, do a right click on the broken image and select “Properties” (or somethinkg like that), this will give you the new image URL/name.

    Then check for this image URL/name exist on wp-content/uploads/2012…

    Not like this, you have to find the URL your browser try to display, not the URL that the link open.

    Do you have “properties” when you do a right click ?

    Right click on the icon…

    Save image as…
    Copy image URL
    Copy image (dimmed)
    Open image in new tab
    Inspect element

    The previous link I showed you was the “Copy image URL”

    I do not get or can find in the inspect code a classic URL of the image I’m editing.

    Again… thanks for your patience.

    In a post, do you try to do “insert media” then find and select the new media (generated after crop/resize) ?
    If yes, when you save the post, is the image appears correctly in the post ?

    Typically… create post, add image, load from outside source. Everything is hunky dory.

    My new theme has required that I do featured images so it displays properly on the front page, etc. (yes, I have tried deactivating all plugins and switched to 2012 theme for testing) So I click on featured image, find the image already loaded to the post, then try to edit it for the featured post and FIZZLE, no image to edit. Does not affect the original post or the image already posted.

    Is that what you mean? (Sorry to be so dense.)

    OK, it seems other guys had the same issue like you.

    check your functions.php file, and any files included within.
    if there are any errors or even empty lines strange things and errors will occur in wp-admin (WordPress Dashboard)

    The problem may be an empty line between PHP tags

    <?php function(){ ... } ?>
    
    <?php function(){ ... } ?>

    needs to be :

    <?php function(){ ... } ?>
    <?php function(){ ... } ?>

    Hi Riveratile…

    Yeah, saw that earlier and have tried that to no avail.

    Thank you for all your efforts and your time. As my wife always says, time to seek professional help. I hope she’s referring to code.

    3.5 is still a baby, so I’ll struggle here a bit more.

    Again, thanks for your time, and happy new year!

    Richard654

    Hey guys,

    I know this thread is 3 months old but I was having the exact same issue. I Disabled all plugins, re-installed fresh WP install and checked functions file for any line spaces but to no avail.

    The scale / crop tools for WordPress Admin are dependant upon the PHP GD Library. It turns out that this was not installed on the server we were using. Once the GD Library was installed, everything worked fine 🙂

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Edit media preview not working’ is closed to new replies.