Support » Plugin: Gravity Forms Directory » Edit Link is not showing

  • Resolved kmtrent


    WordPress version:3.8
    Gravity Forms Directory version:3.5.3

    I did this: updated the Directory plugin

    I expected the plugin to do this: perform more accurately

    Instead it did this: all the Edit links in Single Entry View disappeared

    Here’s a link to see what I mean: I can’t give you the link because edit links are linked to and limited to users. The only link on the Single Entry View is now the Back to Directory link at the top. Before updating, the Edit This Entry link was at the bottom of the Single Entry View.

    I have deactivated and reactivated the plugin. Tried checking and unchecking the Allow edit option in Settings. I have tried to add a useredit shortcode to form using both useredit=”yes” and useredit=”y”

    I am not seeing anyone else having this issue after update. I have looked through the forum as much as is possible to see if I can find help there.

    Whatever you can offer to help me get the Edit This Entry link and option back onto the Single Entry View, I would greatly appreciate it! My customers will also be extremely happy to not have to complete a new form everytime they need to add or make a change!

Viewing 15 replies - 1 through 15 (of 15 total)
  • Hi,

    I can confirm I don’t seem to have any edit links either!

    Also, not seeing any way to get Single Entry View either – will post separately on that…

    Not sure if this will help you, but I was able to get editing working again by giving the “gravityforms_directory” capability to the user.

    ok, not sure what I changed, if anything, but I seem to have lost the ability to edit entries again so I guess you can safely ignore my previous comment…

    Not sure if this is the reason actually, but I went to Configuration in the Dashboard and checked some related checkboxes on “Administration of Entries” section and now I can see the edit entry link.
    Hope it helps.



    Setting this checkbox displays the edit entry link.
    In Directory $ Addons Setting page:

    Allow administrators to edit all entries. Will add an ‘Edit Your Entry’ field to the Single Entry View. (adminedit)

    Checking this box does not display the edit entry link for me:
    Allow logged-in users to edit entries they created. Will add an ‘Edit Your Entry’ field to the Single Entry View. (useredit)

    I had the same problem happen to me. It seems like there is a tiny hiccup with the logic in gravity-forms-addons.php around line 832. Link will display to users with admin user level but any other user level the link won’t show. I tried installing the Members plugin and giving additional permissions for gravityforms_edit_entries as suggested by the plugin author which didn’t seem to work.

    I then enabled the permission for gravityforms_directory as mentioned by vivojack in his comment above and it did work for me. He mentioned that it stopped working and I’m not sure why that might be but it would have to be set on each user level that you have. It might be possible that he set it on one user level (contributor) and was testing with another (author).

    Also for those of you who are using this functionality I highly suggest you check out these functions to add to your functions.php file to keep people from viewing and editing others entries by just changing the entry id in the url (url guessing).

    Vivojack’s solution worked for me. I used the User Role Editor plugin to help me add the permission to the subscriber role.

    Sorry, false alarm. When I add the gravityforms_directory permission to the subscriber role, ANY user could edit ANY entry. So I disabled it, and now no users can edit entries. Hope a fix is in the works!

    I think I fixed it. There was an error in the logic. Lines 831-834 in gravity-forms-addons.php currently reads:

      !empty($options['useredit']) && is_user_logged_in() && $current_user->ID === $lead['created_by'] || // Is user who created the entry
      !empty($options['adminedit']) && self::has_access("gravityforms_directory") // Or is an administrator
    ) {

    should read:

      (!empty($options['useredit']) && is_user_logged_in() && $current_user->ID == $lead['created_by']) || // Is user who created the entry
      (!empty($options['adminedit']) && self::has_access("gravityforms_directory")) // Or is an administrator
      ) {

    The conditions needed to be grouped by brackets, and there was an extra “equals” sign in $current_user->ID === $lead[‘created_by’].

    Has anyone received a fix for this? I am unable to view my edit button also. I can view the results of the form but I can’t go back in and edit it.

    Plugin Author Zack Katz


    This is fixed in – thanks!

    I have added a shortcode to a ‘manage your entry’ page so a user can edit their entry. I have set the appropriate things in the addon so that user can edit their entries (when logged in) and only see their entries.

    In the page however, no edit entry link or button is visible ?
    I even tried this with an admin user and no luck

    whats going on ?



    I’m having the same problem — not seeing the Edit Entry link. I used to, not sure what happened, as I can’t pinpoint exactly when I stopped seeing it. I am on WP 3.9.1, GF 1.8.7 and of this Directory plugin.

    Anyone still having this issue after the “fix” in Any help please?

    Update: it works if I set the option globally from plugin settings… but it is not working when I try to specify in the shortcode for a particular directory. The shortcode is correct — or should be, since it is the shortcode generated by the plugin when inserting a directory; it’s not something I typed in manually…

    i have word press 3.9.1 and the latest plugin and i have same problem Edit Link is not showing ,

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Edit Link is not showing’ is closed to new replies.