• Resolved grungepuppy



    this was a recent problem that seemed to pop up out of the blue.

    when i add an image to a post, i like to take advantage of the custom thumbnail feature of the recently updated media editor. i’ve been trucking along, uploading files, making new thumbnails in the image editor, embedding into posts… then all of a sudden the preview no longer showed the image.

    here’s a screen shot of essentially what is happening:

    as you can see, the image that you edit on the left is missing and i can no longer take advantage of the editing features. i decided to get a screen shot of an file i already successfully uploaded and edit, though it is not working for all files, recently uploaded or not. all other functions of the media library are working fine.

    i am using vr 2.9.2, firefox 3.6.3 (though it also is broken in other browsers like opera and chrome,) with updated plug ins etc. i looked through the sticky article about the editor though nothing seemed to work. the fact that it literally worked one day, then stopped working the next with no changes to any of the settings in between is what baffles me.

    does anyone have any suggestions/solutions?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Thread Starter grungepuppy


    still having this problem.

    i tried a number of things, including the popular deactivating all plug-ins thing. i tried setting different permissions to the uploads folder. clearing caches. making sure everything is up to date. trying out different file types with different bit per pixel settings. nada.

    to reiterate, the preview image – the image you are supposed to edit and crop etc when you click “edit image” – is broken. firefox does not have an image placeholder, so i couldn’t tell. but in safari and opera and chrome, it shows up as a broken image:

    to add again: this problem came out of the blue. i literally stopped editing images one day, and picked it up the next, and this function was suddenly not working. this is for every image, old or new.

    if it helps, i looked at the file path of the broken image and it was this:

    i will also mention that i use dreamhost. perhaps it is something with them?

    i’m stumped fellas! is anyone else having this issue? i really need to know if i can resolve this.

    Thread Starter grungepuppy


    new development. to be sure that it wasn’t dreamhost’s fault, i made a new install on a sub-domain and it worked, same version and everything. so… really, i am still stumped.

    does anyone know how to fix this issue or know what it might be? i’m just floating in the dark right now.

    Thread Starter grungepuppy


    i literally tore down my site and built it back up piece by piece due to this problem. it began fine as usual, but yet again the image suddenly fails to show during editing of any picture.

    can someone – anyone – help me figure out why this image is not loading? it’s such a small glitch yet it really puts my whole site development at a stand still.

    Thread Starter grungepuppy


    i really don’t know if anyone’s looking at this, but i thought i’d keep updates anyway…

    new development: i increased the memory using a few of those tricks i found in the forum. at first it didn’t seem to have an effect, but when i loaded up my work the next day, the edit image miraculously worked again. i got back into re-building my site, re-uploading all the images… when it suddenly stopped working, AGAIN.

    i guess my conclusion is it has something to do with memory. i get no errors. as before, it is just simply the preview image in the image editor that is broken. my site is image intensive. i utilize the gallery short hand often, and one post could have several dozen images. i wonder if my frequent uploading and image editing has something to do with this.

    what do you think? is there a way i can, i don’t know, clear some sort of chache that might be full?

    Thread Starter grungepuppy


    AT LAST! i found the issue. it was indeed the template i was using. i recall that being mentioned on other related posts, and i was sure i tried it before. but indeed with my current build that is the problem. my custom site template causes that preview image to break.

    but now my question is… WHY? what about a custom template makes that part of the image editor break? i assumed admin functions had nothing to do with the templates. does anyone know what causes this? what the connection is, and how it can be fixed? i’d hate to have to switch my site to default templates every time i want to edit a picture.

    check your functions.php file, and any files included within.
    if there are any errors or even empty lines strange things and errors will occur in wp-admin

    I was having this exact problem in a theme I’m developing and the problem was an empty line between php tags

    <?php function(){ ... } ?>
    <?php function(){ ... } ?>

    needs to be :

    <?php function(){ ... } ?>
    <?php function(){ ... } ?>

    hope that helps…

    THANK YOU JAY.WEEKS! This was driving me NUTS all day! Although I have no clue WHY this would cause problems with the Admin screen, I went into functions and sure enough, there was a blank line and when I took it out, presto, edit worked again. I can’t thank you enough for your insight. I didn’t start the thread so I can’t flag it as resolved, but for me it certainly is. My life just got a tiny bit better, Paul

    Thread Starter grungepuppy


    OH WOW!

    i know it’s been a while since i posted and checked this entry, but i just recently came across the problem again (hadn’t really updated my site in a while).

    this fixed EVERYTHING. who knew? wow, thanks so much, jay! you are a REAL life saver!

    Hi Jay,
    Which functions.php file are you talking about? The one in the theme folder?
    And what are you guys using to open the file?
    I opened the generic WP functions.php file, and the one in the theme folder in an html editor, and I see lots of line breaks. When I open it in notepad, there are none.
    thanks 😀

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘“Edit Image” – image does not show up…’ is closed to new replies.