Support » Alpha/Beta/RC » Edit Image Dialogue/Media Uploader Not Appearing (Chrome)

  • Resolved Barried


    Hi Guys,

    Neither the Media Uploader or Edit (existing) Image dialogue appears for me in Chrome. Screen ‘shadows’ out as if dialogue box is about to appear but it doesn’t.

    Using 3.3b3 and latest version of Chrome (15.0.874.121). I’ve deactivated all plugins and I’m using 2011 theme. No such problems with Firefox.

Viewing 15 replies - 1 through 15 (of 19 total)
  • Moderator Jon Cave


    WordPress Dev

    Have you tried flushing your browser’s cache, restarting it and retrying? Preferences > Under the Hood > Clear browsing data in Chrome.

    X-ref to similar report from an Opera user which fixed itself after a browser restart.

    Brilliant! Many thanks. Flushing cache/restart resolved.

    I’m having the same problem with
    Opera 11.52
    OS 10.6.6
    WordPress 2.9.2.
    Emptied Opera cache and restarted it but nothing changed – the add media dialog button launches a gray window with a progress bar which disappears after a few seconds and that’s it. Need to go into Safari in order to insert media into a post

    Using Safari and FF there’s no problem


    Using the latest build for WordPress beta plus latest versions of firefox, chrome and IE and i have this problem in all three browsers.

    Tried to flush cash but even then the media uploader does not appear as a iframe. When i rightclick the link and choose to have it displayed in a new tab it does appear.. as a new tab. So it seems that the iframe is wrongle addressed?

    It’s working for a high number of people… Beta 4 is due out (well, it’s overdue, but I’d expect to see it this week) – If that doesn’t fix it, it’s possible something’s really wild.

    I know the new uploader uses HTML 5, silverlight, flash and old-media-upload (I think in that order), but the new floated iframe didn’t really change THAT much.

    What OS are you on?

    I am on Windows 7 Enterprise.

    The weird thing is that it does open when selected as a new tab. And IE gives the following: Error: ‘html() is null or not an object.

    I will await the beta 4. Hopefully this wil resolve this little issue.

    Okay. Updated now to 3.3-beta4. No luck. Stil no response when clicking on the media upload function.

    All plugins disabled. Chrome to the latest version. Cache wiped clean.

    What can i do next to pinpoint the cause for you guys?

    What do you see at wp-admin/media-new.php ?

    I get what would normally be displayed in the iframe.

    The “Upload New Media” screen with the dotted line around it. I can even select a file or drag and drop and the file is then processed but when i select to add it to a post the proces halts.

    Okay that is REALLY weird, and I’m inclined to put it down as ‘Something is VERY wrong on your computer.’ I’m on Chrome 16.something and it works, it also works when I test it on my Windows XP box, on Chrome, IE 8, Firefox and Safari. Ditto Mac.

    I hate to ask, but can you test on a different computer?

    I can make it even weirder for you. At home now with laptop and even then it does not show the add media iframe.

    So what i plan to do next is to complete erase all wp files and complete reinstall the latest beta4.

    Or you can pull a trick from that hat of yours 😉

    Moderator Jon Cave


    WordPress Dev

    All plugins disabled.

    Did you also switch to the default theme (Twenty Eleven)?

    And IE gives the following: Error: ‘html() is null or not an object.

    Could you get a file and line number for that? Check Chrome web inspector console (F12) too; it might give a better message.

    yeah i switched back to the absolute default. Twenty Eleven en no plugins running.

    The IE error has line 3 char 5 for the file post-new.php

    But the good news is that by using the Chrome web inspector i found the culprit. I had deactivated all plugins at the network admin console however it turns out that the plugin named “TM Replace Howdy” is still active on the main site even though you chose to network deactivate it.

    I removed that particular plugin and now the media upload iframe is working once again.

    My apologies if this wasted any of your time and thanks for the advices.


    Oh, that makes sense. if you’d activated it on a site before Network Activating it (MultiSite is tricky that way) it stays active when Network Deactivated.

    I’ll add this to my list of known issues, and we should probably tell “TM Replace Howdy” that it’s breaking the media uploader…

    Edited to add – What version of the plugin are you running? It shows a new one as of the 20th that should work with 3.3.

    I use plugin central to keep tabs on any new plugin version so the mentioned plugin was at it’s latest version.

    The plugin was not activated on my central site before i started using multisite. The plugin was added long after i started running more then 1 site with wordpress. And that is wat worries me. I network deactivated the plugin via network admin but it was stil active on the central site, i had to remove it there as wel to make wordpress function again.

    Hopefully you can do something usefull with the info.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Edit Image Dialogue/Media Uploader Not Appearing (Chrome)’ is closed to new replies.